Download it now!
Bug 109146 - FILESAVE XLSX: Resaving file can change conditional formatting style
Summary: FILESAVE XLSX: Resaving file can change conditional formatting style
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Conditional-Formatting XLSX
  Show dependency treegraph
 
Reported: 2017-07-16 17:16 UTC by Gabor Kelemen
Modified: 2017-07-28 11:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file with autofilter, conditional format and hyperlink (9.15 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-07-16 17:16 UTC, Gabor Kelemen
Details
Same file resaved from 5.4 (6.50 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-07-16 17:16 UTC, Gabor Kelemen
Details
The two example files in Excel 2013 (55.44 KB, image/png)
2017-07-16 17:17 UTC, Gabor Kelemen
Details
Same file saved from LO 5.4.0.3 (6.48 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-07-28 11:17 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-07-16 17:16:25 UTC
Created attachment 134670 [details]
Example file with autofilter, conditional format and hyperlink

This is a variation of attachment #134667 [details] in bug #109144:

Attached file was made with Excel 2013 and contains a few numbers with a simple conditional format set: red font and strikethrough if value <= 100.
It also contains an autofilter above these numbers.
In D2 it contains a hyperlink as well.

Resaving this file in 5.4RC1 makes the ConditionalFormat1 style have the properties of the Excel Built-in Hyperlink style: blue font and underline instead of the red font and strikethrough.
Comment 1 Gabor Kelemen 2017-07-16 17:16:40 UTC
Created attachment 134671 [details]
Same file resaved from 5.4
Comment 2 Gabor Kelemen 2017-07-16 17:17:21 UTC
Created attachment 134672 [details]
The two example files in Excel 2013
Comment 3 Xisco Faulí 2017-07-28 09:37:39 UTC
I can't reproduce it in

Version: 6.0.0.0.alpha0+
Build ID: 1e87e93132f808ab95eab932b36bfe40d3cc607a
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-07-25_06:09:29
Locale: es-ES (es_ES); Calc: group

nor in

Versión: 5.4.0.3
Id. de compilación: 92c2794a7c181ba4c1c5053618179937228ed1fb
Subproc. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group

Could you please try in 5.4.0.3 ?
Comment 4 Gabor Kelemen 2017-07-28 11:17:15 UTC
Created attachment 134930 [details]
Same file saved from LO 5.4.0.3

I just tried to export it from LO 5.4.0.3 and now it looks to be fine, the custom conditional format is not mixed up with the style of the link.
Comment 5 Gabor Kelemen 2017-07-28 11:19:36 UTC
Let's say it's fine now.