Bug Hunting Session
Bug 109174 - EDITING: There are lots of font queries when changing the font size (DirectWrite)
Summary: EDITING: There are lots of font queries when changing the font size (DirectWr...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.3.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 112173 (view as bug list)
Depends on:
Blocks: Too-Much-File-Access DirectWrite DirectWrite-Regression
  Show dependency treegraph
 
Reported: 2017-07-17 18:21 UTC by Telesto
Modified: 2017-10-18 11:13 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (8.92 KB, application/vnd.oasis.opendocument.text)
2017-07-17 18:22 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-07-17 18:21:27 UTC
Description:
There are lots of font queries when changing the font size (which weren't there before)

Steps to Reproduce:
1. Open the attached file
2. Open Process Monitor. Filter settings:
Process Name 'is' 'soffice.bin'
Path: begins with: C:\Windows\Fonts
3. Select the text within the attached file and change the font size to different sizes (choose some extremes). Take notice of the font queries. Same happens also with Bold/Underline/Italic. It's occurring just once for every 'setting' made in the same configuration.


Actual Results:  
In this case LiberationSerif-Regular.ttf is excessively access


Expected Results:
Shouldn't happen


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Versie: 5.4.0.2 
Build ID: 2b906d450a44f2bbe506dcd22c51b3fa11dc65fd
CPU-threads: 4; Besturingssysteem:Windows 6.2; UI-render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 5.3.3.1 
Build ID: 46360c72c4823cefeaa85af537fba22bd568da7e
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: standaard; Layout-Engine: nieuw; 
Locale: nl-NL (nl_NL); Calc: CL

but not in
Version: 5.3.0.3
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Telesto 2017-07-17 18:22:17 UTC
Created attachment 134695 [details]
Example file
Comment 2 Aron Budea 2017-07-21 03:36:34 UTC
This is another case that points to the following commit. Let's assume it's a bug with DirectWrite renderer.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a51b7a1c3a7e7cf7b0c733e1dec40288278c1884
author		Khaled Hosny <khaledhosny@eglug.org>	2017-03-03 03:15:14 (GMT)
committer	Khaled Hosny <khaledhosny@eglug.org>	2017-03-03 13:22:53 (GMT)

"tdf#103831, tdf#100986: Force using GDI when needed"
Comment 3 Aron Budea 2017-07-21 03:41:26 UTC
Btw, I filtered on "ttf" instead of C:\Windows\Fonts, because the bibisect repo used the fonts from its own font directory.
Comment 4 Buovjaga 2017-09-10 14:40:57 UTC
*** Bug 112173 has been marked as a duplicate of this bug. ***
Comment 5 Telesto 2017-10-03 17:30:08 UTC
No repro with:
Version: 5.3.7.0.0+
Build ID: 8580472270972733cda7fa6ecf23db73359d30bb
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-TDF, Branch:libreoffice-5-3, Time: 2017-10-02_13:08:01
Locale: nl-NL (nl_NL); Calc: CL

Repro with:
Version: 6.0.0.0.alpha0+
Build ID: 4020945651b4f3c636980e2103db440b5c55459c
CPU threads: 4; OS: Windows 6.29; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-09-25_23:14:03
Locale: nl-NL (nl_NL); Calc: CL
Comment 6 Telesto 2017-10-04 08:48:06 UTC
Version: 5.3.7.0.0+
Build ID: 8580472270972733cda7fa6ecf23db73359d30bb
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-TDF, Branch:libreoffice-5-3, Time: 2017-10-02_13:08:01
Locale: nl-NL (nl_NL); Calc: CL
Comment 7 Xisco Faulí 2017-10-04 21:00:51 UTC
This is a problem in DirectWrite, thus it's not fixed. My commit only changes the behaviour to use GDI instead, as it was before. The plan is to move to DirectWrite at some point. Keeping it open.
Comment 8 Xisco Faulí 2017-10-18 11:03:50 UTC
Currently there's no way to enable the DirectWrite from the UI, thus closing as
RESOLVED FIXED