Download it now!
Bug 112173 - FORMATTING: Performance issue after consecutively changing font size
Summary: FORMATTING: Performance issue after consecutively changing font size
Status: RESOLVED DUPLICATE of bug 109174
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, perf, regression
Depends on:
Blocks:
 
Reported: 2017-09-02 07:14 UTC by Emil Tanev
Modified: 2017-09-10 14:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test file (783.61 KB, application/vnd.oasis.opendocument.text)
2017-09-09 18:34 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emil Tanev 2017-09-02 07:14:52 UTC
Open a word document of around 58 000 words, font size is 11
Select all
Change the font size from the drop down to the maximum - 96
Wait for the font to change
Change back to 12
Wait for the font to change
Click on the font size drop down. 

Issue: the application stalls for a long time, even though the previous font change has been applied. 
https://www.screencast.com/t/roWkRZNHc5

OS specs:
Intel Core i7 2.60 GHz, RAM 8 GB
Comment 1 Telesto 2017-09-03 07:07:44 UTC
Could be related to bug 109174
Comment 2 Buovjaga 2017-09-09 18:34:15 UTC
Created attachment 136137 [details]
Test file

Varney the Vampire with 200k words.

It froze my whole system for a few minutes. I guess this means it is not related to bug 109174 because that one is about Windows.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: a27eb931c22313d4dd5c73b35358c0532d20b79e
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on September 8th 2017
Comment 3 Buovjaga 2017-09-09 18:36:11 UTC
Regression as the change is instantaneous in 3.6.

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 4 Buovjaga 2017-09-10 14:40:57 UTC
Eh, it was bug 109174 after all: I bibisected it to the same commit :(

*** This bug has been marked as a duplicate of bug 109174 ***