Bug Hunting Session
Bug 109191 - Presentation does not show rotated text box
Summary: Presentation does not show rotated text box
Status: RESOLVED DUPLICATE of bug 107090
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Textbox DirectWrite
  Show dependency treegraph
 
Reported: 2017-07-18 14:35 UTC by Massimo
Modified: 2017-09-01 18:58 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Impress file with animation (11.35 KB, application/vnd.oasis.opendocument.presentation)
2017-07-18 14:35 UTC, Massimo
Details
Slide with rotated text (10.57 KB, application/vnd.oasis.opendocument.presentation)
2017-09-01 15:21 UTC, Laurent BP
Details
Slide with rotated text (14.15 KB, application/vnd.oasis.opendocument.presentation)
2017-09-01 16:41 UTC, Laurent BP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Massimo 2017-07-18 14:35:45 UTC
Created attachment 134711 [details]
Impress file with animation

Textbox rotated does not show up in animation. See the attached file. Run screen show, "horizontal text" shows up, "inclined text" does not.
It works if in Tools > Option > Libreoffice > View I enable OpenGL. But then, when the presentation ends, I get a black screen!
Tested in LO 5.3.4.2 (x64) under Windows 10, both English.
Comment 1 raal 2017-07-18 16:37:09 UTC
This seems to have begun at the below commit.
Adding Cc: to Khaled Hosny; Could you possibly take a look at this one? Thanks

 19490574e42c3180a38d55ccbbf1e3a00802150d is the first bad commit
commit 19490574e42c3180a38d55ccbbf1e3a00802150d
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Tue Mar 7 03:23:53 2017 -0800

    source sha:a51b7a1c3a7e7cf7b0c733e1dec40288278c1884
author	Khaled Hosny <khaledhosny@eglug.org>	2017-03-03 03:15:14 (GMT)
committer	Khaled Hosny <khaledhosny@eglug.org>	2017-03-03 13:22:53 (GMT)
commit	a51b7a1c3a7e7cf7b0c733e1dec40288278c1884 (patch)
tree	6452088195b6c0ad617e7a6b9f97ecc8672d321e
parent	5742868ccf030b2c0f03538d030bd18bd5666bdb (diff)
tdf#103831, tdf#100986: Force using GDI when needed
Our DirectWrite renderer is incomplete and can’t handle rotated text or text
with horizontal scaling, so route these two through GDI for now.
Comment 2 Massimo 2017-07-18 16:42:34 UTC
By the way, disabling hardware acceleration seems to help as well.
Comment 3 Regina Henschel 2017-08-17 10:11:43 UTC
Likely duplicate to bug 97943
Comment 4 Laurent BP 2017-09-01 15:15:43 UTC
(In reply to Regina Henschel from comment #3)
> Likely duplicate to bug 97943

I do not think it is duplicate. Text is correctly shown with 0° or 180° rotation. But with any other angle, text does not appear.
By the way no need for animation:
1. Create new presentation
2. Insert text box and type some text
3. F4, Rotation: choose any angle different from 0 and 180
4. F5

Expected:
text is visible

Actual:
no text visible

Tested with 5.3.3 (change version accordingly)
Comment 5 Laurent BP 2017-09-01 15:21:46 UTC
Created attachment 135931 [details]
Slide with rotated text

Simple example:
1. Open attached file
2. F5

Expected:
Dummy text should be shown

Actual:
Blank screen
Comment 6 V Stuart Foote 2017-09-01 15:35:57 UTC

*** This bug has been marked as a duplicate of bug 107090 ***
Comment 7 Laurent BP 2017-09-01 16:41:47 UTC
Created attachment 135934 [details]
Slide with rotated text

Dirty workaround:
Right click on rotated text > Convert > To Curve
See attached: during Slide Show text converted to curve is visible but not rotated text

Same behavior with Version: 5.4.1.2 (x64)
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: fr-FR (fr_FR); Calc: CL
Comment 8 Laurent BP 2017-09-01 18:58:01 UTC
(In reply to Laurent BP from comment #7)
> Dirty workaround:
> Right click on rotated text > Convert > To Curve
> See attached: during Slide Show text converted to curve is visible but not
> rotated text
As mentioned in bug 107090 a better workaround:
Tools > Options > LibreOffice > View: uncheck "Hardware acceleration"