Bug Hunting Session
Bug 109291 - Toolbars disappear when out of context, causing flicker/zoom changes in the slide view
Summary: Toolbars disappear when out of context, causing flicker/zoom changes in the s...
Status: RESOLVED DUPLICATE of bug 36976
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ImpressDraw-Toolbars
  Show dependency treegraph
 
Reported: 2017-07-23 20:46 UTC by Federico Mena-Quintero
Modified: 2017-07-24 13:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Federico Mena-Quintero 2017-07-23 20:46:47 UTC
1. Make sure there's a text object in the current slide.

2. Unselect all objects.

3. Add a contextual toolbar, like View/Toolbars/Line and filling, and put it in its own row (i.e. not in the same row as an existing toolbar).

4. Click inside the text object to edit it.

The Line and Filling toolbar disappears, since it is not valid for the text editing context.  However, this causes the entire slide view to change zoom.  This is very disorienting, as it changes *again* when you are finished editing the object.

The slide view should stay at a fixed position and zoom factor.  If a toolbar is out of context, just disable its items temporarily.
Comment 1 V Stuart Foote 2017-07-23 23:42:04 UTC

*** This bug has been marked as a duplicate of bug 36976 ***