Download it now!
Bug 109373 - Open font Modern Pictograms Pro doesn't display
Summary: Open font Modern Pictograms Pro doesn't display
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-26 05:37 UTC by cryptic
Modified: 2017-07-26 09:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cryptic 2017-07-26 05:37:13 UTC
As soon as I installed this version of Libre Office, the font "Modern Pictograms Pro" doesn't display. It worked fine in the previous version.

I have tried using Photoshop, and the font still displays in Photoshop.
Comment 1 Julien Nabet 2017-07-26 08:22:16 UTC
The font isn't free.
Any traces/logs when launching LO from console/terminal?

Also, you can give a try to 5.3.4 and use a brand new LO profile (see https://wiki.documentfoundation.org/UserProfile#macOS)
Comment 2 cryptic 2017-07-26 09:01:18 UTC
I bought the font.

Okay, I will try 5.3.4.
Comment 3 Alex Thurgood 2017-07-26 09:02:32 UTC
@cryptic : sorry, but we need more information than what you have provided.

1) which "previous" version did the font work with ?
2) what kind of font precisely is "Modern Pictograms Pro" ?

If it is a PS Type 1 font, then these are no longer supported.
Comment 4 Alex Thurgood 2017-07-26 09:06:48 UTC
According to 

http://johncaserta.com/modern-pictograms-pro/

there is also more than one version of the Modern Pictograms Pro font - which one are you using ?
Comment 5 cryptic 2017-07-26 09:09:57 UTC
Modern Pictograms Pro version 1.0
Comment 6 Alex Thurgood 2017-07-26 09:13:07 UTC
FWIW, the standard Modern Pictograms font by the same author is available under the OFL (Open Font Licence) for free.
Comment 7 Alex Thurgood 2017-07-26 09:18:23 UTC
FWIW, the free font crashes my OSX FontBook application, failing on validation. If this is the same as the Pro font, then there is something in the font descriptor for which OSX flags the font as invalid.
Comment 8 Alex Thurgood 2017-07-26 09:23:54 UTC
Despite the error, the font Modern Pictograms gets installed into my User fonts.

The font is not shown in the list of available fonts in Writer 

Version: 5.4.0.3
Build ID: 92c2794a7c181ba4c1c5053618179937228ed1fb
Threads CPU : 4; OS : Mac OS X 10.12.6; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 9 Alex Thurgood 2017-07-26 09:27:57 UTC
But this is normal given that =

/Users/*/Library/Fonts/modernpics.otf

is 

PostScript Type1

according to the OSX FontBook.app

so, it is likely that your Modern Pictograms Pro font is a PS Type 1 font which is no longer supported by LibreOffice, Type 1 font support having been removed.

Setting as RESOLVED INVALID - if your v1 font is not PS Type 1, then please feel free to reset this back to UNCONFIRMED
Comment 10 Alex Thurgood 2017-07-26 09:34:59 UTC
I would also point you to the discussion in bug 104701 about the reasons for removal of Postscript Type 1 font support