Bug 104701 - PS Type 1 URW fonts missing in LibreOffice 5.3.0.0.beta1 and 5.3.0.0.beta2
Summary: PS Type 1 URW fonts missing in LibreOffice 5.3.0.0.beta1 and 5.3.0.0.beta2
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2016-12-15 16:43 UTC by JPJ
Modified: 2017-12-24 15:53 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JPJ 2016-12-15 16:43:29 UTC
URW fonts are missing when selecting a font in Writer or Calc via the Formatting toolbar or the Format -> Character... menu and dialog.

Version: 5.3.0.0.beta2
Build ID: a7e30712ad6d8bc9286007b37aa581983e0caba3
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; VCL: x11; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: group

OS: KDE Neon User Edition 5.8 = KDE Plasma 5.8.4 on Ubuntu 16.04.1


    URW fonts are available on the same system when running earlier versions of LibreOffice including:

Version: 5.2.4.1
Build ID: 9b50003582f07ac674d6451e411e9b77cccd2b22
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 JPJ 2016-12-15 16:47:12 UTC
The same issue exists with 5.3.0.0.bet1 on a separate physical machine with the same OS.

Version: 5.3.0.0.beta1
Build ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; VCL: kde4; Layout Engine: new;
Locale: en-US (en_US.UTF-8); Calc: group

OS: KDE Neon User Edition 5.8 = KDE Plasma 5.8.4 on Ubuntu 16.04.1
Comment 2 Buovjaga 2016-12-15 19:53:03 UTC
This is obviously due to the text layout engine changes in 5.3.
Please give more information about these URW fonts. I know they are proprietary and thus practically untestable by QA and developers.
Check the font properties and give us all the relevant data you can.
Please especially check, if they are Type1 fonts.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 3 Buovjaga 2016-12-15 19:54:32 UTC
Disregard my previous mention about them being proprietary. You might well be talking about the free ones.
Comment 4 Adolfo Jayme 2016-12-15 23:00:02 UTC
Support for old Type-1-format fonts has been dropped. Ensure the URW fonts you have installed are SFNT (TrueType or OpenType).
Comment 5 JPJ 2016-12-16 00:26:05 UTC
It looks like they are type 1 fonts from the gsfonts package.  It's really unfortunate if those are going to be dropped in LO 5.3.  These URW fonts are pretty much the only ones I used and I only discovered them because of LibreOffice.

> fc-list | grep URW
/usr/share/fonts/X11/Type1/p052024l.pfb: URW Palladio L:style=Bold Italic
/usr/share/fonts/X11/Type1/p052023l.pfb: URW Palladio L:style=Italic
/usr/share/fonts/X11/Type1/b018015l.pfb: URW Bookman L:style=Demi Bold
/usr/share/fonts/type1/gsfonts/p052023l.pfb: URW Palladio L:style=Italic
/usr/share/fonts/X11/Type1/z003034l.pfb: URW Chancery L:style=Medium Italic
/usr/share/fonts/type1/gsfonts/z003034l.pfb: URW Chancery L:style=Medium Italic
/usr/share/fonts/X11/Type1/a010033l.pfb: URW Gothic L:style=Book Oblique
/usr/share/fonts/X11/Type1/a010015l.pfb: URW Gothic L:style=Demi
/usr/share/fonts/X11/Type1/p052004l.pfb: URW Palladio L:style=Bold
/usr/share/fonts/type1/gsfonts/a010013l.pfb: URW Gothic L:style=Book
/usr/share/fonts/type1/gsfonts/p052004l.pfb: URW Palladio L:style=Bold
/usr/share/fonts/X11/Type1/b018032l.pfb: URW Bookman L:style=Light Italic
/usr/share/fonts/type1/gsfonts/a010015l.pfb: URW Gothic L:style=Demi
/usr/share/fonts/X11/Type1/a010035l.pfb: URW Gothic L:style=Demi Oblique
/usr/share/fonts/type1/gsfonts/a010033l.pfb: URW Gothic L:style=Book Oblique
/usr/share/fonts/type1/gsfonts/b018035l.pfb: URW Bookman L:style=Demi Bold Italic
/usr/share/fonts/type1/gsfonts/a010035l.pfb: URW Gothic L:style=Demi Oblique
/usr/share/fonts/X11/Type1/b018035l.pfb: URW Bookman L:style=Demi Bold Italic
/usr/share/fonts/type1/gsfonts/b018012l.pfb: URW Bookman L:style=Light
/usr/share/fonts/X11/Type1/a010013l.pfb: URW Gothic L:style=Book
/usr/share/fonts/X11/Type1/b018012l.pfb: URW Bookman L:style=Light
/usr/share/fonts/type1/gsfonts/b018032l.pfb: URW Bookman L:style=Light Italic
/usr/share/fonts/type1/gsfonts/p052003l.pfb: URW Palladio L:style=Roman
/usr/share/fonts/type1/gsfonts/b018015l.pfb: URW Bookman L:style=Demi Bold
/usr/share/fonts/X11/Type1/p052003l.pfb: URW Palladio L:style=Roman
/usr/share/fonts/type1/gsfonts/p052024l.pfb: URW Palladio L:style=Bold Italic
> 

>dpkg-query -S /usr/share/fonts/type1/gsfonts/a010013l.pfb
gsfonts: /usr/share/fonts/type1/gsfonts/a010013l.pfb
>                                                                                                                               
> dpkg-query -S /usr/share/fonts/X11/Type1/a010013l.pfb
gsfonts-x11: /usr/share/fonts/X11/Type1/a010013l.pfb
>                                                                                                           
> apt-cache show gsfonts
Package: gsfonts                                                                                                                                                                   
Priority: optional                                                                                                                                                                 
Section: text                                                                                                                                                                      
Installed-Size: 4764                                                                                                                                                               
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>                                                                                                              
Original-Maintainer: Masayuki Hatta (mhatta) <mhatta@debian.org>
Architecture: all
Version: 1:8.11+urwcyr1.0.7~pre44-4.2ubuntu1
Conflicts: gs (<< 5.50-5), gs-aladdin (<< 6.50-4), gsfonts-x11 (<< 0.13)
Filename: pool/main/g/gsfonts/gsfonts_8.11+urwcyr1.0.7~pre44-4.2ubuntu1_all.deb
Size: 3373970
MD5sum: 47126e30ae67398d61e7af8cff54f3db
SHA1: 261a68c2136932e975e50e3f053233845af09923
SHA256: fae918c51d76e993f984d0a9e108c9abb64db0dfcd75d39a40f939d740972661
Description-en: Fonts for the Ghostscript interpreter(s)
 These are free look-alike fonts of the Adobe PostScript fonts.
 Recommended for all flavors of Ghostscript (gs-gpl, gs-afpl and gs-esp).
Description-md5: c77fd616d53a8b059361ca26ef255651
Homepage: http://www.ghostscript.com/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 5y
Task: ubuntu-desktop, ubuntu-usb, print-server, kubuntu-desktop, edubuntu-desktop, edubuntu-usb, xubuntu-core, xubuntu-desktop, mythbuntu-frontend, mythbuntu-desktop, lubuntu-core, ubuntustudio-desktop-core, ubuntustudio-desktop, ubuntu-gnome-desktop, ubuntu-sdk, ubuntukylin-desktop, ubuntu-mate-core, ubuntu-mate-desktop, ubuntu-mate-cloudtop

>
Comment 6 V Stuart Foote 2016-12-16 03:44:34 UTC
the non Unicode Type 1 PS fonts have been completely dropped with ESC approval
Comment 7 Khaled Hosny 2016-12-16 04:01:52 UTC
You can use the TeX Gyre fonts (http://www.gust.org.pl/projects/e-foundry/tex-gyre/) which are based on these URW fonts but are available as OpenType fonts as well. Other Ghostscript fonts are also available as OpenType fonts from upstream.
Comment 8 Khaled Hosny 2016-12-16 04:05:39 UTC
(In reply to Khaled Hosny from comment #7)
> Other Ghostscript fonts are also available as OpenType fonts from upstream.

http://git.ghostscript.com/?p=urw-core35-fonts.git;a=tree
Comment 9 S. 2017-02-21 23:32:23 UTC
This unfortunate change breaks formatting for many years of documents I have created. I have always used the Ghostscript extra fonts, especially "Bitstream Charter", which is not available in either of the links that Khaled posted. Please consider revoking this inconsiderate decision.
Comment 10 Khaled Hosny 2017-02-21 23:47:19 UTC
This is not going to happen, unfortunately. All code supporting Type 1 fonts have been removed in the upcoming 5.4 release and I don’t see anyone volunteering to bring it back and adding the code required for the new layout engine to support them.

A better investment, going forward is to find a non-Type 1 replacement of these fonts, to convert them to OpenType using AFDKO or FontForge.
Comment 11 V Stuart Foote 2017-02-22 00:20:19 UTC
(In reply to Khaled Hosny from comment #10)
> This is not going to happen, unfortunately.

Nothing unfortunate about it--the ESC made the correct decision with the move to a common rendering framework.

What might be helpful (and not slipping backward) is to assure that any Type1 PS receive suitable fallback font, so opening an "archival" document receives reasonable fidelity with no missing blocks of text. IHMO that is all the more we're obliged to do for Type1 and bitmap fonts.

Otherwise resolving any residual annoyances in the HarfBuzz implementations interplay with FreeType, CoreText and DirectWrite shaping is time better spent.

And bye the way--thank you Khaled!
Comment 12 Khaled Hosny 2017-02-22 13:48:16 UTC
Since this is Linux, font fallback should be handled by FontConfig somehow.
Comment 13 Bruce Byfield 2017-02-28 17:59:42 UTC
The decision to drop support for Type 1 fonts must have been made by someone who isn't a designer.

Even though the availability of free fonts has blossomed in the last few years, many designers have invested substantially in Type 1 fonts over the years and still use them, if only for legacy documents

The change also means that LibreOffice is less compatible with other free software, including GIMP, Krita, and Inkscape.

Please reconsider this decision.
Comment 14 V Stuart Foote 2017-02-28 18:39:34 UTC
(In reply to Bruce Byfield from comment #13)
> The decision to drop support for Type 1 fonts must have been made by someone
> who isn't a designer.

> ...

> 
> Please reconsider this decision.

Why? PS Type 1 font conversion is trivial, and most Adobe PS Type 1 was converted years ago and is distributed as TTF/OTF already. Little new PS Type 1 since the mid-90's with advent of TTF/OTF, industry moved on.

Would expect any serious "designer" needing to retain library of archival 20+ year old Type 1 fonts would have done conversions some time ago if only for convenience of being compatible with workflows using TTF/OTF.

As a cross-platform project, getting consistent HarfBuzz based layout in place (and working correctly with OpenGL) is a lot more important than legacy support for that corner case of users still dragging deprecated PS Type 1 fonts around.

At this phase in LibreOffice development, no support in HarfBuzz means simply no support in LibreOffice--accordingly PS Type 1 is out.  And this remains a clear WONTFIX.
Comment 15 Bruce Byfield 2017-03-01 03:52:28 UTC
The conversion of hundreds of fonts is hardly trivial. It is time-consuming, and should be unnecessary.

Yes, Type 1 is a legacy format, but this is hardly comparable to some of the earlier formats that have been long ago dropped. Type 1 fonts are still more than adequate for professional work, so there is no particular incentive to convert them to another format, especially when most graphic editors continue to support them.


Personally, I am mostly unaffected, since I have been using only free-licensed fonts for the last few years, few of which are in Type 1 format. But I now have to either waste my time on conversions, or else retain an older copy of LibreOffice if I want continued access to legacy documents. 

Still, what irritates me is how unnecessary the change is. Did anyone think to ask graphic designers using LibreOffice? The decision seems arbitrary, based on the interest of developers, and not in the best interest of users.
Comment 16 Buovjaga 2017-03-01 07:05:05 UTC
(In reply to Bruce Byfield from comment #15)
> Still, what irritates me is how unnecessary the change is. Did anyone think
> to ask graphic designers using LibreOffice? The decision seems arbitrary,
> based on the interest of developers, and not in the best interest of users.

Why do you claim it is unnecessary, as if we could have continued supporting Type 1 without a significant development effort?

https://en.wikipedia.org/wiki/PostScript_fonts#Type_1 "They are not supported in the Windows GDI+, WPF or DirectWrite APIs"

MS Office dropped Type 1 support in 2013, with the only way to use them being an awkward workaround: https://social.technet.microsoft.com/Forums/office/en-US/8c15a4ea-ac83-40bd-8800-d3532e1dee07/office-2013-and-type-1-fonts-not-supported?forum=officesetupdeploy

The writing has been on the wall for Type 1 fonts for a long time.

Users of Type 1 fonts have been forced to jump through hoops for years: https://forums.adobe.com/message/7382830#7382830 Adobe principal scientist commenting in 2015: "it is really a good time to accelerate migration to cross-platform OpenType fonts."
Comment 17 Francisco 2017-05-21 19:55:27 UTC
(In reply to S. from comment #9)
> This unfortunate change breaks formatting for many years of documents I have
> created. I have always used the Ghostscript extra fonts, especially
> "Bitstream Charter", which is not available in either of the links that
> Khaled posted. Please consider revoking this inconsiderate decision.

S., if it may help, you can download a "Bitstream Charter package" from  this web:

http://practicaltypography.com/charter.html

According to the author, there you will find OTF, TTF and webfonts. The download link is at the end of the webpage.
Comment 18 Ganton 2017-08-24 12:53:24 UTC
    This page seems to be the best one that Google finds when looking for those problems (documents badly seen because Bitstream Charter is suddenly unavailable, because URW fonts are suddenly unavailable, etc.).

    I wondered why those good fonts, and Courier 10 Pitch (which is much better than the [spindly, lumpy, and just plain ugly Courier New](http://practicaltypography.com/courier-alternatives.html)) stopped working when using LibreOffice 5.3 but kept on working when using Calligra Words.

    Courier 10 Pitch can be substituted for an improved version of it, named Courier Code (http://www.linux-magazine.com/Online/Blogs/Off-the-Beat-Bruce-Byfield-s-Blog/Free-equivalents-for-standard-proprietary-fonts , https://fontlibrary.org/en/font/courier-code). This way we avoid adding another "Courier 10 Pitch" font equally named; we have the same advantage with Charis SIL (https://fontlibrary.org/en/font/charis, http://packages.ubuntu.com/charis) when installing it instead of another Bitstream Sans.

    People wonder what the hell happened to their documents, although HarfBuzz ends up being an improvement. Thanks to all the good people that helped on this page!