Download it now!
Bug 109391 - When opening "Styles and Formatting" (undock) with F11, the cursor is out of screen
Summary: When opening "Styles and Formatting" (undock) with F11, the cursor is out of ...
Status: RESOLVED DUPLICATE of bug 101915
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: a11y Sidebar-Styles
  Show dependency treegraph
 
Reported: 2017-07-26 18:41 UTC by Alex ARNAUD
Modified: 2017-07-28 10:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex ARNAUD 2017-07-26 18:41:07 UTC
Description:
Dear all,

On LibreOffice, the new "Styles and Formatting" dialog produces inconsistency.
1) It places the cursor out of screen when the user starts it
2) It produces illogical keyboard navigation sequence so pressing tab and shift+tab when opening the dialog doesn't place the cursor on the same place as before the tab command

Steps to Reproduce:
1. Undock the sidebar
2. Close the sidebar window if opened
3. On a writer document press F11

Actual Results:  
The focus is on an invisible close button (discover with the Orca screen reader)

Expected Results:
The focus should be placed the focus on the styles list (as in earlier version)


Reproducible: Always

User Profile Reset: No

Additional Info:
Best regards.


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Yousuf Philips (jay) (retired) 2017-07-27 20:38:18 UTC
Whether the sidebar is docked or not F11 should have the same behaviour.

*** This bug has been marked as a duplicate of bug 101915 ***
Comment 2 Alex ARNAUD 2017-07-28 09:04:51 UTC
(In reply to Yousuf Philips (jay) from comment #1)
> Whether the sidebar is docked or not F11 should have the same behaviour.
> 
> *** This bug has been marked as a duplicate of bug 101915 ***

Hello Jay,

I'm not sure my bug description is completely clear. I don't talk exactly about the behavior but I talk about the wrong focus position when I launch the "Styles and Formatting" where it is undock.

When I press F11 the "Styles and Formatting" is correctly open and the focus go through the new window. The issue here is the focus position on a non-visible button instead of the styles list.

I don't understand the relationship between this bug and the bug 101915.

Did I misunderstand something ?

Best regards.
Comment 3 Yousuf Philips (jay) (retired) 2017-07-28 10:39:53 UTC
(In reply to Alex ARNAUD from comment #2)
> I'm not sure my bug description is completely clear. I don't talk exactly
> about the behavior but I talk about the wrong focus position when I launch
> the "Styles and Formatting" where it is undock.

Yes behaviour meant where the focus is. Please read the description i wrote for bug 101915, as the current behaviour (docked or undocked) is a regression.