Download it now!
Bug 101915 - F11 shortcut should put focus to control sidebar content panel of Styles and Formatting deck (or back in document on closing the panel)
Summary: F11 shortcut should put focus to control sidebar content panel of Styles and ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.1.0.1
Keywords: accessibility, regression
: 109391 118550 121315 (view as bug list)
Depends on:
Blocks: Sidebar-Styles Sidebar-Accessibility
  Show dependency treegraph
 
Reported: 2016-09-05 20:40 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-11-09 21:56 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-09-05 20:40:48 UTC
After we made the styles and formatting exclusive to the sidebar in bug 73151, it has been unaccessible to a11y users as focus remains in the document rather than in the sidebar deck, like it used to be in the style dialog. So similar to the style dialog, the sidebar should set focus to the drop down control at the bottom when the sidebar deck is open and should set focus back to the document when the sidebar deck is closed. See LO 4.2.6 to test the old behaviour.
Comment 1 V Stuart Foote 2016-09-06 01:19:33 UTC
Yes, but Keyboard navigation between the Style & Formatting modes needs to be normalized--enabling Tab and arrow cursor movement, and Enter to select/apply the style/formatting. Presently the F11 Styles & Formatting content panel only supports mouse actions with limited cursor movements once in the list of styles.

Then, rather than to the deck's dropdown menu--as with F10 toggle movement between File on the main menu and the document canvas--the F11 ought to move to a default landing on the Paragraph Styles mode. But enable Tab to move between Style modes applicable to the module. An Enter to enter the list (only possible now with mouse click), cursor movement, and Enter to apply the style to document canvas as appropriate.

Paragraph to current paragraph
Character to a selection or current word
Frame to current frame contained object
Page to the current page
List to a current list
Table to selection or current cell/row/column of table
etc.


Like F10, a second F11 would return focus to document canvas.
Comment 2 Yousuf Philips (jay) (retired) 2016-09-06 05:06:07 UTC
(In reply to V Stuart Foote from comment #1)
> Yes, but Keyboard navigation between the Style & Formatting modes needs to
> be normalized--enabling Tab and arrow cursor movement, and Enter to
> select/apply the style/formatting. Presently the F11 Styles & Formatting
> content panel only supports mouse actions with limited cursor movements once
> in the list of styles.

Believe that is because of bug in 5.2 (bug 101921). Alternatively if you want to make changes to keyboard behaviour in the deck from what it was in 5.1 and prior, though i found it quite fine, please submit an enhancement for it and CC this bug.

> Then, rather than to the deck's dropdown menu--as with F10 toggle movement
> between File on the main menu and the document canvas--the F11 ought to move
> to a default landing on the Paragraph Styles mode. But enable Tab to move
> between Style modes applicable to the module. An Enter to enter the list
> (only possible now with mouse click), cursor movement, and Enter to apply
> the style to document canvas as appropriate.

Well my intent was to have it work just like it did before, but i'm fine with having it focus on a different deck control, ideally one that best suits a11y users. My thoughts on what to focus is the style list, so it will be easy for users to f11 and change the style and then f11 back to the doc and then f11 back to the list and choose a different one.

> Paragraph to current paragraph
> Character to a selection or current word
> Frame to current frame contained object
> Page to the current page
> List to a current list
> Table to selection or current cell/row/column of table
> etc.

I dont think the style list type should be changed without the user requesting that change, unless that particular style type is not applicable to the current object, which is how we do it now. There are multiple situations where multiple style types are applicable at the same time (for example in a list you would possibly want access to paragraph, character and list style), so the user should change the list type.

> Like F10, a second F11 would return focus to document canvas.

Yep thats what i meant when i said "the sidebar should set focus to the drop down control at the bottom when the sidebar deck is open and should set focus back to the document when the sidebar deck is closed."
Comment 3 Xisco Faulí 2016-09-12 12:47:12 UTC
Adding keyword 'bibisectRequest'.
Comment 4 Yousuf Philips (jay) (retired) 2017-07-27 20:38:18 UTC
*** Bug 109391 has been marked as a duplicate of this bug. ***
Comment 5 Alex ARNAUD 2017-07-28 11:38:51 UTC
> Well my intent was to have it work just like it did before, but i'm fine
> with having it focus on a different deck control, ideally one that best
> suits a11y users. My thoughts on what to focus is the style list, so it will
> be easy for users to f11 and change the style and then f11 back to the doc
> and then f11 back to the list and choose a different one.

I agree with this behavior. The focus should be placed on the "styles list." On LibreOffice 4.2, when I press F11 the focus is in the "styles list"

What is the plan for the integration of this behavior on LibreOffice ? What I can do to help you ?

In which version the behavior was correct with the new dialog based on the sidebar ? On LibreOffice 4.2 the behavior was correct but it was a completely different dialog so I don't see the usefulness of the bibisect in this case. If I understand I could proceed to bibisection.

Best regards.
Comment 6 Cor Nouws 2018-04-03 14:28:48 UTC
Hi Arnaud,

(In reply to Alex ARNAUD from comment #5)

> In which version the behavior was correct with the new dialog based on the
> sidebar ? On LibreOffice 4.2 the behavior was correct but it was a
> completely different dialog so I don't see the usefulness of the bibisect in
> this case. If I understand I could proceed to bibisection.

I can't start version 4.1 up to 4.4 on my Ubuntu since Ubuntu 17.10 (maybe should try reinstalling, but...)

4.0 indeed does not have the Side bar.
But opening Styles and Formatting, does put the focus in the list at the bottom, with which one chooses the view.
5.0 does open the Styles and Formatting in the Side bar. But leaves the focus in the document.
(Closing Styles and Formatting, makes the focus not re-appear in the document.)

I'm not sure if bibisecting this problem will help that much. It is new code/functionality (Side bar versus old dialog) so not something easy to point at as cause of the problem. I guess.
Comment 7 Cor Nouws 2018-04-03 14:32:40 UTC
@raykowj, Jim,

Sorry for adding you here, but seeing your work for e.g. bug 115451, you might be interested in this one too.
Comment 8 Jim Raykowski 2018-04-05 07:36:19 UTC
(In reply to Cor Nouws from comment #7)
> @raykowj, Jim,
> 
> Sorry for adding you here, but seeing your work for e.g. bug 115451, you
> might be interested in this one too.

Hi Cor,

No apologies required! Feel free to add me to any bug you feel I might be able to help with.

Unfortunaly there doesn't seem to be an easy way to move focus to a control inside a panel like there is for moving focus to a deck title.
Comment 9 Jim Raykowski 2018-04-08 21:57:54 UTC
This bug is related to bug 115786 where it is suggested by Samuel Thibault that

"F11 should just always get the caret into the style panel, be it in the sidebar or a floating window. If the style panel is already visible, then the caret should just be moved there, instead of closing it."

The patch here does just this. The already implemented Ctrl-F6 can be used to move focus back to the the document view from anywhere. 

https://gerrit.libreoffice.org/#/c/52612/
Comment 10 Commit Notification 2018-06-05 05:42:01 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b5af679c74774036de323b687a3901bd8f97a09b

tdf#101915 move focus to sidebar styles panel

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2018-06-05 07:06:44 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=47ccfe2c92027458287bd91f9df891e319e08d04&h=libreoffice-6-1

tdf#101915 move focus to sidebar styles panel

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Alex ARNAUD 2018-06-16 13:32:47 UTC
Hello all,

I'm currently testing LibreOffice daily build the 2018-06-12 and I can confirm that pressing F11 moves the focus on the sidebar but pressing F11 another time no longer close the sidebar.

I mark the bug as reopen because I think we lose the ability to close the sidebar with F11.

Let me know if I could help for testing.

Best regards,
Alex.
Comment 13 Heiko Tietze 2018-06-17 07:29:36 UTC
(In reply to Alex ARNAUD from comment #12)
> ...I can
> confirm that pressing F11 moves the focus on the sidebar but pressing F11
> another time no longer close the sidebar.

The shortcut to toggle View > Sidebar is Ctrl+F5 (bug 85850), F11 is to go into a "style selection mode". Jim and me had a discussion on Gerrit about that, https://gerrit.libreoffice.org/#/c/52612/
Comment 14 Alex ARNAUD 2018-06-17 08:33:24 UTC
(In reply to Heiko Tietze from comment #13)
> (In reply to Alex ARNAUD from comment #12)
> > ...I can
> > confirm that pressing F11 moves the focus on the sidebar but pressing F11
> > another time no longer close the sidebar.
> 
> The shortcut to toggle View > Sidebar is Ctrl+F5 (bug 85850), F11 is to go
> into a "style selection mode". Jim and me had a discussion on Gerrit about
> that, https://gerrit.libreoffice.org/#/c/52612/

Thanks for sharing that.

Samuel Mehrbrodt has replied the same as me. The new behavior is not correct not just in my opinion but for consistency. The style element is on the View menu, if F11 should open the style pane, it should also close it. I understand the utility of ctrl+F5 but for our beginner user he will prefer to keep the same behavior as before and he will find not logical to use one key for opening the style pane and another one for closing it.

If the user has to know such complexity I really think we're doing things not for Benjamin but for Eve.

@Heiko: You're reasoning is correct for people reading man or searching a bit to understand things but if me and Samuel think in first time it's a bug how a new user will think ?

Also the title of the bug explains "back in document", it's what I expect to have, sincerely, for the end-user.

Best regards,
Alex.
Comment 15 Heiko Tietze 2018-06-17 09:00:22 UTC
(In reply to Alex ARNAUD from comment #14)
> The new behavior is not correct not just in my opinion but for consistency.

Hope Jim will chime in here.
Comment 16 Jim Raykowski 2018-06-17 20:48:32 UTC
Chimming in with a patch that closes the sidebar and moves focus back to the document view when focus is currently in the sidebar styles panel and F11 is pressed. 

https://gerrit.libreoffice.org/#/c/55969/
Comment 17 Commit Notification 2018-06-19 06:48:27 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3a8375eb974eb8ba36ac616478acd881b70f8e19

tdf#101915 make F11 close the sidebar when focus is in sidebar

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Heiko Tietze 2018-06-19 09:16:26 UTC
(In reply to Jim Raykowski from comment #16)
> Chimming in with a patch...

Thank you!
Comment 19 Commit Notification 2018-06-19 09:17:16 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=657c141acbae11945072ae3f38982cb225131de6&h=libreoffice-6-1

tdf#101915 make F11 close the sidebar when focus is in sidebar

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 V Stuart Foote 2018-07-13 12:19:09 UTC
*** Bug 118550 has been marked as a duplicate of this bug. ***
Comment 21 Alex ARNAUD 2018-08-02 16:45:17 UTC
It works like a charm.

I've tested it on Debian 9 "Stretch" with LibreOfficeDev from today.

Best regards,
Alex.
Comment 22 V Stuart Foote 2018-11-09 21:56:29 UTC
*** Bug 121315 has been marked as a duplicate of this bug. ***