Download it now!
Bug 109411 - FILEOPEN: DOCX: moon signs and text in table are misplaced
Summary: FILEOPEN: DOCX: moon signs and text in table are misplaced
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard: target:6.5.0 target:6.4.0.2
Keywords: filter:docx
Depends on:
Blocks: DOCX-Tables DOCX-Images
  Show dependency treegraph
 
Reported: 2017-07-27 03:03 UTC by vihsa
Modified: 2019-12-20 17:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
moon signs and text are misplaced (58.70 KB, image/png)
2017-07-27 03:09 UTC, vihsa
Details
ScreenshotOfTheSampleFileBeforeAndAfterThePatch (160.25 KB, image/png)
2019-12-20 08:39 UTC, Attila Bakos (NISZ)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vihsa 2017-07-27 03:03:09 UTC
Description:
moon signs and text are misplaced inside the table.

Steps to Reproduce:
i was verifying attachment 97273 [details] in bug 77374 on Bug 79329.

i noticed that moon signs and text are misplaced on page 1 below table. please find the attachment.

verified

version: 5.3.0.0.alpha1+
build ID: 4136757

device: lyf flame 3 [ ls-4001 ]
os: android 5.1

unable to open file on

Version: 6.0.0.0.alpha0+
Build ID: 1e87e93

device: lyf flame 3 [ ls-4001 ]
os: android 5.1

Actual Results:  
 

Expected Results:
 


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Android 5.1; Mobile; rv:56.0) Gecko/56.0 Firefox/56.0
Comment 1 vihsa 2017-07-27 03:09:33 UTC
Created attachment 134885 [details]
moon signs and text are misplaced
Comment 2 Xisco Faulí 2017-07-27 08:21:57 UTC
Also reproduced in

- Version: 6.0.0.0.alpha0+
Build ID: e0b6a4a2d2dec4e9614f27fc03f84b1c578028ec
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

- Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

- Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 3 QA Administrators 2018-07-28 02:43:34 UTC Comment hidden (obsolete, spam)
Comment 4 Roman Kuznetsov 2018-12-24 21:21:27 UTC
still repro in

Версия: 6.2.0.1 (x64)
ID сборки: 0412ee99e862f384c1106d0841a950c4cfaa9df1
Потоков ЦП: 4; ОС:Windows 10.0; Отрисовка ИП: GL; VCL: win; 
Локаль: ru-RU (ru_RU); UI-Language: ru-RU
Calc: threaded
Comment 5 Commit Notification 2019-12-20 07:05:00 UTC
Bakos Attila committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/10f29d8bf05d44ca8bc11d34d1294ec17f8ac0f1

tdf#87569 tdf#109411 DOCX import: fix shape anchor in tables

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Attila Bakos (NISZ) 2019-12-20 08:39:12 UTC
Created attachment 156687 [details]
ScreenshotOfTheSampleFileBeforeAndAfterThePatch

Hi,

The moon sign has gone back to its cell, however the text is not porfect yet. If you want, it can be tested. Halfly resolved...
Comment 7 Xisco Faulí 2019-12-20 09:54:13 UTC
(In reply to Bakos Attila (NISZ) from comment #6)
> Created attachment 156687 [details]
> ScreenshotOfTheSampleFileBeforeAndAfterThePatch
> 
> Hi,
> 
> The moon sign has gone back to its cell, however the text is not porfect
> yet. If you want, it can be tested. Halfly resolved...

Which text are you talking about? the numbers below the moons? The look fine here
Anyway, I would prefer to have both issues separately and close this one as RESOLVED FIXED since the moons' problem is fixed by your commit
Comment 8 Attila Bakos (NISZ) 2019-12-20 10:26:34 UTC
(In reply to Xisco Faulí from comment #7)
> (In reply to Bakos Attila (NISZ) from comment #6)
> > Created attachment 156687 [details]
> > ScreenshotOfTheSampleFileBeforeAndAfterThePatch
> > 
> > Hi,
> > 
> > The moon sign has gone back to its cell, however the text is not porfect
> > yet. If you want, it can be tested. Halfly resolved...
> 
> Which text are you talking about? the numbers below the moons? The look fine
> here
> Anyway, I would prefer to have both issues separately and close this one as
> RESOLVED FIXED since the moons' problem is fixed by your commit

You are right, I mean the numbers under the moon sign... But it looks fine me also, so let's threat it separately, so this one is set to Resolved Fixed.
Comment 9 Commit Notification 2019-12-20 17:00:39 UTC
Bakos Attila committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/b83d394a16a9a93b314f20ea8fb2ccbb99d9d07f

tdf#87569 tdf#109411 DOCX import: fix shape anchor in tables

It will be available in 6.4.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.