Download it now!
Bug 109439 - Uncomplete icon Properties (registry/data/org/openoffice/Office/UI/WriterCommands.xcu)
Summary: Uncomplete icon Properties (registry/data/org/openoffice/Office/UI/WriterComm...
Status: RESOLVED DUPLICATE of bug 106784
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Toolbars
  Show dependency treegraph
 
Reported: 2017-07-27 09:46 UTC by AvoMieliPide
Modified: 2017-08-21 12:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description AvoMieliPide 2017-07-27 09:46:54 UTC
Description:
I wondered why not possible to add icon for column break command etc.
So aster I added that command to toolbar in  Customize and it shows just with text, not with icon and in icon-themes is not icon for that command.
And there is similar situation with many common other commands too - adding them to toolbar or else makes toolbar much longer and UI incoherent. 

Then I found out from these:
https://docs.libreoffice.org/icon-themes.html
registry/data/org/openoffice/Office/UI/WriterCommands.xcu

that property "Properties" missing of several common useful (toolbar etc) commands. 

Can that "Properties" property just be added more complete in that definition file for to add UI icons? Or does it need something else to be done too? 

I also understood that icons must then be added in Galaxy icon theme first, for to use them in other themes. (libreoffice/core/tree/icon-themes)
Is that right? Or can I just make own icon theme images_NAME.zip for to include more icons? (lc_COMMAND.png and sc_COMMAND.png icon images)

For example in 
registry/data/org/openoffice/Office/UI/WriterCommands.xcu
(https://cgit.freedesktop.org/libreoffice/core/tree/officecfg/registry/data/org/openoffice/Office/UI/WriterCommands.xcu)
these would be very usefull to have "Properties" property for to enable tool icons too:

.uno:InsertColumnBreak
(.uno:InsertPagebreak alrady has Properties)

.uno:ConvertTableText
.uno:ConvertTableToText
.uno:ConvertTextToTable

.uno:MergeTable
(.uno:SplitTable already has Properties)

And in GenericCommands.xcu 

.uno:ChangeCaseToSentenceCase
(.uno:ChangeCaseToLower and .uno:ChangeCaseToUpper alrady have Properties) 

So is it possible & enough to do to add on those this property?

<prop oor:name="Properties" oor:type="xs:int">
          <value>1</value>

Thank you


Steps to Reproduce:
1. checked with Galaxy icon them
2. customize, add mentioned commands to toolbar
3. --

Actual Results:  
toolbar shows just text of mentioned commands, not icons

Expected Results:
toolbar should be able to enable to show icons for mentioned commands too, while they are quite common in use


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36
Comment 1 Yousuf Philips (jay) (retired) 2017-08-21 12:11:46 UTC
Yes this is a bug introduced in 5.3 that still hasnt been fixed.

*** This bug has been marked as a duplicate of bug 106784 ***