Bug 106784 - Custom toolbar icons don't appear if sized bigger than "small"
Summary: Custom toolbar icons don't appear if sized bigger than "small"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:6.1.0 target:5.4.5 target:6.0.0.2
Keywords: bibisected, bisected, regression
: 109439 (view as bug list)
Depends on:
Blocks: Customize-Dialog Toolbars
  Show dependency treegraph
 
Reported: 2017-03-26 18:43 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-01-01 03:28 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-03-26 18:43:53 UTC
Steps:
1) Right-click on the formatting toolbar and click the 'Customize toolbar...' entry in the context menu.

2) Select the bold entry and change its icon by clicking the 'Change Icon' entry in the 'Modify' split button

3) Notice that the icon will appear change in the customize dialog, but wont appear in the default icon sized toolbar (Tools > Options > View > User Interface > Toolbar icon size)

Regression as it works in 5.2, but not in 5.3 and above. Seems the 'change icon' dialog was changed to apply 16x16 icons rather than 26x26/24x24 icons.

Version: 5.4.0.0.alpha0+
Build ID: a5a6694128728c48c1a8482450a21ad49025c40c
CPU threads: 2; OS: Linux 3.19; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-03-07_02:52:26
Locale: en-US (en_US.UTF-8); Calc: group

Version: 5.2.4.0.0+
Build ID: ab64ae2a828f4acd6d118abc14193c543d04b940
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-2, Time: 2016-11-07_16:55:16
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Xisco Faulí 2017-03-26 19:53:35 UTC
Regression introduced by:

author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2016-10-31 12:28:26 (GMT)
committer	Tomaž Vajngerl <quikee@gmail.com>	2016-10-31 14:49:57 (GMT)
commit	c3043a3072465c489d3b20991b17d222771305eb (patch)
tree	8981124cc9435802c72e1123d5e16a404e4d239f
parent	7de287ba422107f54018f2ba0f054d642c86c966 (diff)
tdf#103591 icon theme name resolving, ui fixes, prioritize png
- Prefer "png" over "svg" because for Tango theme we include both
  "png" and "svg" icon, but rendering of "svg" crashes
- We save the choice of which icons to use into the profile. When
  32px icons were added the values have shifted - "auto" had value
  2 has became "32px" choice and "auto" has the new value 3. In the
  case of the default "auto", we now always showed 32px icons. This
  commit reverts the "auto" value 2 and puts "32px" choice to 3.
- Name resolving now always removes the icon file extension and
  adds the ".png" and ".svg" extension before resolving. This
  makes it possible to define the name of the icon without the
  file extension.

Bisected with bibisect-linux-64-5.3

Adding Cc: to Tomaž Vajngerl
Comment 2 Thomas Lendo 2017-05-22 21:37:20 UTC
I tested it and it seems to work at least in

Version: 5.5.0.0.alpha0+
Build ID: 20d04d6938a104124ac06271f17978a290cccf6c
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-05-21_01:40:38
Locale: de-DE (de_DE.UTF-8); Calc: group

In my 5.3 installations it don't work.
When a pre-release of 5.4 is available I will test again.

Can anybody confirm that?
Comment 3 Yousuf Philips (jay) (retired) 2017-05-25 02:04:38 UTC
Still broken from me when using large icons.

Version: 5.5.0.0.alpha0+
Build ID: 0e6297932252403883a6057feee488e4ee2bc360
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-05-22_23:44:32
Locale: en-US (en_US.UTF-8); Calc: group
Comment 4 Yousuf Philips (jay) (retired) 2017-08-21 12:11:46 UTC
*** Bug 109439 has been marked as a duplicate of this bug. ***
Comment 5 Rainer Bielefeld Retired 2017-11-23 06:58:01 UTC
a) For me the effect is visible for any symbol (icon) size bigger than "small"
Comment 6 daniel 2017-12-08 11:58:10 UTC
(In reply to Rainer Bielefeld Retired from comment #5)
> a) For me the effect is visible for any symbol (icon) size bigger than
> "small"

Same here. LO 5.3.7.2 on Windows.
Comment 7 Maxim Monastirsky 2017-12-21 11:09:16 UTC
I can reproduce this only when the icon size is set to "automatic", like the original report, and unlike comment 5. This seems to fix it for me:

https://gerrit.libreoffice.org/46899/

But in this case, the bisect in comment 1 is wrong, as it must be caused by a different commit (see commit message in gerrit). My guess is that the user profile wasn't cleared during bisect, which might be affected by the incompatibility described in the commit message of comment 1.
Comment 8 Commit Notification 2017-12-21 12:44:08 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1d55c1baed9977bad449691012807c6f09e2fca8

tdf#106784 Also handle automatic icon size

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Maxim Monastirsky 2017-12-23 21:18:30 UTC
Assuming this is fixed, backport is in gerrit.
Comment 10 Commit Notification 2018-01-01 03:27:39 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=25b66ffe5d4f0fab876972cc471fb82470ebae12&h=libreoffice-5-4

tdf#106784 Also handle automatic icon size

It will be available in 5.4.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2018-01-01 03:28:58 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5bd8887e8def134ba59b9524f9d6c85dad14c693&h=libreoffice-6-0

tdf#106784 Also handle automatic icon size

It will be available in 6.0.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.