Bug Hunting Session
Bug 109532 - PNG image in PDF export is corrupted (sometimes not, like when exported with 5.3.4.2)
Summary: PNG image in PDF export is corrupted (sometimes not, like when exported with ...
Status: RESOLVED DUPLICATE of bug 116888
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2017-07-27 21:13 UTC by Gene Kohlenberg
Modified: 2019-03-27 13:12 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT file of church bulletin (754.28 KB, application/vnd.oasis.opendocument.text)
2017-07-27 21:16 UTC, Gene Kohlenberg
Details
Church News Letter (1.57 MB, application/vnd.oasis.opendocument.text)
2017-07-28 10:30 UTC, Gene Kohlenberg
Details
PDF file generated using Libreoffice 5.3.4.2 (666.59 KB, application/pdf)
2017-07-28 10:39 UTC, Gene Kohlenberg
Details
PDF file generated using Libreoffice 5.4.0.1 (807.84 KB, application/pdf)
2017-07-28 10:42 UTC, Gene Kohlenberg
Details
PDF from Libreoffice with 256 colors per pixel PNG corrupted (754.29 KB, application/pdf)
2018-11-13 11:47 UTC, gui
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gene Kohlenberg 2017-07-27 21:13:10 UTC
Description:
I exported a PDF using 5.4.0.1 and found two images that were corrupted. However,if I export the same PDF using 5.3.4.2, the images are not corrupted.

Steps to Reproduce:
1.Export PDF using 5.4.0.1 get image corruption
2.Export PDF using 5.3.4.2 get no image corruption
3.

Actual Results:  
Some images in PDF are corrupted using 5.4.0.1

The images are not corrupted using 5.3.4.2

Expected Results:
The images should not be corrupted.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
Comment 1 Gene Kohlenberg 2017-07-27 21:16:25 UTC Comment hidden (obsolete)
Comment 2 Xisco Faulí 2017-07-27 22:49:53 UTC
I can' reproduce it in

Versión: 5.4.0.3
Id. de compilación: 92c2794a7c181ba4c1c5053618179937228ed1fb
Subproc. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group

Could you please try with LibreOffice 5.4.0.3 from http://dev-builds.libreoffice.org/pre-releases/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 3 Gene Kohlenberg 2017-07-28 10:30:52 UTC
Created attachment 134926 [details]
Church News Letter

I uploaded the wrong ODT file yesterday.
Comment 4 Gene Kohlenberg 2017-07-28 10:39:00 UTC
Created attachment 134927 [details]
PDF file generated using Libreoffice 5.3.4.2

The August clip art on the first page and the black and white church image on the last page appear normally in the 5.3.4.2 PDF export.
Comment 5 Gene Kohlenberg 2017-07-28 10:42:56 UTC
Created attachment 134928 [details]
PDF file generated using Libreoffice 5.4.0.1

The August clip art on the first page has a black background and the black and white image of the church is garbled.
Comment 6 Gene Kohlenberg 2017-07-29 15:23:24 UTC
I just exported the PDF using 5.4.0.3 and the two graphics are still corrupted.
Comment 7 Aron Budea 2017-07-29 15:45:18 UTC
Thanks for the details! I can see the issue with the two images in 5.3.4.2 as well, but only if OpenGL rendering is enabled in Tools -> Options...; View -> Use OpenGL for all rendering.

Not in 5.3.0.3, though, so it does appear to be a regression.
Comment 8 Aron Budea 2017-07-29 20:43:43 UTC
Actually it's there even in older versions when OpenGL is enabled (in 5.1.0.3 for example), no idea what's up with 5.3.0.3.
Comment 9 QA Administrators 2018-08-30 02:51:11 UTC Comment hidden (obsolete)
Comment 10 gui 2018-11-13 11:47:38 UTC
Created attachment 146590 [details]
PDF from Libreoffice with 256 colors per pixel PNG corrupted

Libreoffice WRITER error attaching 256 colors per pixels PNG images to PDFs remaining in version 6.1.1.2 (x64) from a Window 7x64 Pro
Comment 11 gui 2018-11-13 11:52:18 UTC
As per today, the only walkthrough to this bug is transform 256 color (8bpp) PNG images to higher color resolutions (say 16.4M colors - 24bpp)
Comment 12 Luboš Luňák 2019-03-27 13:12:57 UTC
Will be fixed by a fix for bug #116888 as well.

*** This bug has been marked as a duplicate of bug 116888 ***