Bug 110353 - No theme Oxygen and no replacement for it
Summary: No theme Oxygen and no replacement for it
Status: CLOSED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 111744 (view as bug list)
Depends on:
Blocks: KDE Icon-Themes
  Show dependency treegraph
 
Reported: 2017-07-29 17:06 UTC by tagezi
Modified: 2017-08-16 07:42 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Oxigen (336.26 KB, image/png)
2017-07-31 12:20 UTC, tagezi
Details
version (33.52 KB, image/png)
2017-08-01 03:00 UTC, tagezi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tagezi 2017-07-29 17:06:33 UTC
The theme has been removed since version 5.4. When installed on top of the old version, panels display tips of prompts instead of icons. When trying to find a theme in the settings, the Oxygen theme or its corresponding color raster and size can not be found.

Kubuntu 16.04
DE: KDE 5.18.0
The main theme of the icons is Oxygen
Comment 1 Yousuf Philips (jay) 2017-07-29 17:24:52 UTC
Oxygen was removed with this patch - https://gerrit.libreoffice.org/#/c/38289/

Cant remember which design meeting we had that we decided to remove oxygen in, assume it was sometime last year or the year before, but with it being incomplete and no designers available to work on completing it, it needed to be removed, just like we removed Crystal in 5.0.
Comment 2 Heiko Tietze 2017-07-31 08:01:40 UTC
The icon theme was removed after thoroughly discussion. What is the issue here?
Comment 3 Yousuf Philips (jay) 2017-07-31 11:08:27 UTC
(In reply to tagezi from comment #0)
> Kubuntu 16.04
> DE: KDE 5.18.0
> The main theme of the icons is Oxygen

Breeze was made the default icon theme in Ubuntu 16.04[1] and Breeze is the default icon theme for KDE 5, so not sure what is meant by 'The main theme of the icons is Oxygen'.

[1] https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1506544
Comment 4 tagezi 2017-07-31 12:20:13 UTC
Created attachment 135017 [details]
Oxigen

See scrinshot
Comment 5 Yousuf Philips (jay) 2017-07-31 19:51:43 UTC
(In reply to tagezi from comment #4)
> Created attachment 135017 [details]
> Oxigen

That isnt a screenshot of default Kubuntu 16.04, this is[1]. Are you running Kubuntu 14.04?

[1] http://download.softwsp.com/sites/10/2016/05/kubuntu-16-04-011.jpg
Comment 6 tagezi 2017-08-01 03:00:54 UTC Comment hidden (abusive)
Comment 7 V Stuart Foote 2017-08-01 04:47:11 UTC
As indicated, Oxygen was dropped as incomplete and unsupported for lack of dev maintenance. Its gone... move on to a different icon set/theme.

=-ref-=
ESC announced UX decision 2016-02-11
http://nabble.documentfoundation.org/minutes-of-ESC-call-tc4175249.html

Pretty sure it was a topic at the 2016-02-05 Design hangout, but the minutes omit discussion (they were published late for that meeting) but Kendy took it to ESC.
Comment 8 Yousuf Philips (jay) 2017-08-01 17:21:09 UTC
Blog post published on how to get oxygen in 5.4.

https://dnimruoynepo.blogspot.ae/2017/08/how-to-add-oxygen-icon-set-to.html
Comment 9 kompilainenn 2017-08-01 17:25:40 UTC Comment hidden (abusive)
Comment 10 Yousuf Philips (jay) 2017-08-01 18:29:21 UTC
(In reply to tagezi from comment #6)
> I indicated the version in the first post. Do you really think that everyone
> around is stupid? And if you do not know, very few people use KDE with the
> default settings, as it is tuning very fine to their needs even in today's
> form.

No i dont think everyone around is stupid, which is why i asked for clarification, but i doubt you'll find many Kubuntu 16.04 users running a KDE 4 desktop.

For completeness, here is Andreas's message from telegram: "as I'm the maintainer of the origin oxygen kde icons, the icon theme is DEAD since 8 years."
Comment 11 tagezi 2017-08-01 18:47:07 UTC
(In reply to Yousuf Philips (jay) from comment #10)
> (In reply to tagezi from comment #6)
> > I indicated the version in the first post. Do you really think that everyone
> > around is stupid? And if you do not know, very few people use KDE with the
> > default settings, as it is tuning very fine to their needs even in today's
> > form.
> 
> No i dont think everyone around is stupid, which is why i asked for
> clarification, but i doubt you'll find many Kubuntu 16.04 users running a
> KDE 4 desktop.
> 
> For completeness, here is Andreas's message from telegram: "as I'm the
> maintainer of the origin oxygen kde icons, the icon theme is DEAD since 8
> years."

I do not use KDE 4!!! I use Oxygen. See screenshot.
Comment 12 Yousuf Philips (jay) 2017-08-02 14:23:22 UTC
(In reply to tagezi from comment #11)
> I do not use KDE 4!!! I use Oxygen. See screenshot.

Okay i now get that you are using oxygen icons on KDE 5 and as such want to also have oxygen icons in LO. So my statement in comment 10 should have been "i doubt you'll find many Kubuntu 16.04 users using Oxygen." Whatever the case be, oxygen wont be coming back to LO by default and you've published a workaround to solve it for yourself and others.
Comment 13 V Stuart Foote 2017-08-02 14:47:47 UTC
@Jay, *

It would be appropriate here to comment on why Oxygen has been dropped. 

Andreas K. affiliated with the project (Mar 2015)  and has contributed majority of icon design work to make the Breeze icon set complete for use on LibreOffice. He opted not to continue to work on Oxygen icon icons which required the same effort to bring current for our use--i.e. they are abandoned for additional development.

Meaning Oxygen icon theme in its current state is incomplete and is not appropriate to use with LibreOffice--too many icons fall back to Galaxy which also has commissions. In short the Breeze, Sifr, Tango alone are actively being developed, Galaxy is in maintenance mode.

Using Oxygen is not advised and has been removed from the TDF provided builds.

Users that choose to use the incomplete icon theme from where ever they choose to obtain it. But such use is unsupported by the project and going forward suitability of Oxygen will continue to degrade.
Comment 14 tagezi 2017-08-03 02:55:48 UTC
(In reply to V Stuart Foote from comment #13)
> Meaning Oxygen icon theme in its current state is incomplete and is not
> appropriate to use with LibreOffice--too many icons fall back to Galaxy
> which also has commissions. In short the Breeze, Sifr, Tango alone are
> actively being developed, Galaxy is in maintenance mode.

What you say is known to Oxygen users. And it is used not only for KDE, but, as it became known, on Windows and Macs too. Jay mentioned that oxygen users are 8%. It's really strange that almost one tenth of the users does not matter.
Although of course, Meritocracy is such a thing, if you push more bugs in the project, you and are right, those who really care about the project, have no voice.
Comment 15 V Stuart Foote 2017-08-03 03:32:30 UTC
(In reply to tagezi from comment #14)
> (In reply to V Stuart Foote from comment #13)
> > Meaning Oxygen icon theme in its current state is incomplete and is not
> > appropriate to use with LibreOffice--too many icons fall back to Galaxy
> > which also has commissions. In short the Breeze, Sifr, Tango alone are
> > actively being developed, Galaxy is in maintenance mode.
> 
> What you say is known to Oxygen users. And it is used not only for KDE, but,
> as it became known, on Windows and Macs too. Jay mentioned that oxygen users
> are 8%. It's really strange that almost one tenth of the users does not
> matter.

No one said it does not matter, just that it would not be supported. Move on to one of the other icon themes the project does support.

> Although of course, Meritocracy is such a thing, if you push more bugs in
> the project, you and are right, those who really care about the project,
> have no voice.

No, if you rally your fellow users of Oxygen theme and find a competent designer willing to resume support of the medium, when it again reaches some level of completeness and suitability for inclusion in LibreOffice it might regain inclusion to core. Although probably a better chance implementing an icon theme extension.

Othewise no point to continuing this--the primary designer of Oxygen theme art already has said he won't continue to develop it as his efforts and KDE interests have shifted to Breeze.

It is up to you and fellow enthusiasts for Oxygen to resurrect it, or to allow it to slip away into UI oblivion. Complaining about it here is just noise--the essence of WONTFIX.
Comment 16 Yousuf Philips (jay) 2017-08-03 13:17:20 UTC
(In reply to tagezi from comment #14)
> What you say is known to Oxygen users. And it is used not only for KDE, but,
> as it became known, on Windows and Macs too. Jay mentioned that oxygen users
> are 8%. It's really strange that almost one tenth of the users does not
> matter.

The survey didnt show that any Mac users used Oxygen. 16 users on Linux/KDE, 3 users on Linux/Other and 4 users on Windows. What i said on telegram

philipz: the design team did a survey in 2014 about which icon themes were used by users, and oxygen received 8%. - https://wiki.documentfoundation.org/Design/Meetings/2014-11-12

philipz: of course then, kde 4 was still the dominant kde platform and breeze wasnt created

philipz: and that doesnt change the fact that oxygen icons havent been updated in 8 years and are no longer used on kde desktops
Comment 17 Jean-Baptiste Faure 2017-08-12 20:26:46 UTC
*** Bug 111744 has been marked as a duplicate of this bug. ***
Comment 18 Wolf Seiboth 2017-08-12 22:13:45 UTC
I also miss frequently the Oxygen Icon Theme in LO.
I see no reason for deleting something. You guys ship an (unpacked) software package of about 260MB and you must delete an icon theme? And then you replace it by 2! horrible breeze themes? This is not understandable.
It tooks me hurs to get rid of Breeze looking and feeling things on KDE and then came LO 5.4 with breeze and breeze dark. Grrr...
Please let users decide what they want. Not everyone participates in survey's.

@Heiko Tietze
The issue is: You guy"s are doing a lot for nothing and give us software for free. So why spending soo much time in deleting something? Just do KAIZEN. Improving things step by step in SMALL Steps. In Lean Production an important issue. 

@ Yousuf Philips (jay) 2017-08-03 13:17:20 UTC

>The survey didnt show that any Mac users used Oxygen. 16 users on Linux/KDE, 3 >users on Linux/Other and 4 users on Windows. What i said on telegram

I didn't participate in this survey because I didn't aware of it. So I'm the forth user who uses Oxygen on Linux and on Windows.
I know in China at least 10 Colleagues of mine who use Oxygen on Windows as well.
On Wikipedia:
>The Document Foundation estimated in September 2011, that there were 10 million users worldwide who had obtained LibreOffice via downloads or CD-ROMs.<
Did you ask them all?
Forget your survey.
Don't delete soo much. It takes too much time for you who are doing actually a great job.

Thanks to you for LO!
Comment 19 John L. ten Wolde 2017-08-13 18:35:00 UTC
I'm the reporter of the duplicate Bug 111744, and frankly gentleman, I am extremely disappointed and saddened to learn that the Oxygen icons are "dead".

I wasn't aware of any surveys being conducted either (and see that, according to the minutes linked in comment 16, there was another concerning the Calc toolbar as well).  So how does one learn about these things?  Subscribe to a mailing list?  If you want general user feedback you may want to draw more attention to the fact.  An announcement on the downloads page perhaps?

And where does one find out about the state of the icon sets anyhow?  How many icons is Oxygen lacking?  If someone could provide a link, that would be great.


P.S.  I describe my own workaround at my bug report above.
Comment 20 Yousuf Philips (jay) 2017-08-14 01:37:27 UTC
(In reply to John L. ten Wolde from comment #19)
> And where does one find out about the state of the icon sets anyhow?  How
> many icons is Oxygen lacking?  If someone could provide a link, that would
> be great.

There are over 2.5k icons in an icon theme and i believe atleast half of them are missing from Oxygen. You can see in attachment 135017 [details], that 8 icons in the Calc toolbar are Tango icons, while others are being pulled from the deprecated crystal icon theme, and even others are poorly designed.

The only way the Oxygen theme can be reinstated is if a designer is ready to step up and take on the challenge to work on it, which nobody in the KDE community has been willing to do. I personally had worked on the icon theme by creating icons by mixing two available oxygen icons together, as well as pulling other oxygen icons from the original icon theme into LO, but that can only go so far and would be a waste of time if an icon designer familiar with the oxygen theme isnt ready assist.
Comment 21 Adolfo Jayme 2017-08-16 00:06:06 UTC
Everybody decries how we’ve removed an old icon theme but it’s only talk, talk, talk… If those efforts were instead towards contributing the actual work, this would be a different story. That icon theme wasn’t maintained neither here nor at upstream KDE, and it was bitrotting, so we’ve dropped it after several discussions.

I’m unsatisfied with the tone of the discussion, and have flagged some comments as abusive. Keep it civil, people! And above all, keep in mind that LibreOffice is built by volunteers, especially in the UI department. It’s no secret we haven’t any paid graphic designer in the staff. We would welcome help in this (and every) area, and I’m always happy to review icon submissions to the Git repo, even if I’m not always responsive.
Comment 22 Heiko Tietze 2017-08-16 06:51:22 UTC
(In reply to John L. ten Wolde from comment #19)
> And where does one find out about the state of the icon sets anyhow?

Not really up to date but at least and from a different point of view but at least it gives an impression https://community.kde.org/KDE_Visual_Design_Group/LibreOffice_Breeze
Comment 23 andreas_k 2017-08-16 07:42:22 UTC
remove stuff is always not easy, not only for the users, also for the developers.

So I would recommand the following solution. Instead of a lot of discussion in the bugtracker and somewhere else, add to the extension webpage the option to have there icon themes available for the users to download. Like in the kde store.

The good thing is that users can use outdated icon themes and thy can also update them. In addition I know a lot of popular icon developers (La Capitaine, Papirus, Arc icon theme, ...) they would like to extend there icon themes for LibreOffice, but have them all in the core libreoffice repository isn't a good solution. So extend the extension manager of libreoffice for icon themes would solve this problem and could improve the situation to find new designers how will work on the icon themes. As an icon theme is only a single zip file (and maybe an description file) no compiling is needed and so make an extension wouldn't be a big deal (I think) instead of answer bug reports of removing outdated icon themes.