Bug 110744 - Writer only prints landscape, will not reset to portrait mode (preview shows correctly).
Summary: Writer only prints landscape, will not reset to portrait mode (preview shows ...
Status: RESOLVED DUPLICATE of bug 86838
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.4.2 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-31 23:22 UTC by Mike Protenic
Modified: 2017-08-03 06:25 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Protenic 2017-07-31 23:22:10 UTC
Description:
When choosing to print documents on Writer, the page is oriented portrait and print preview parallels the portrait orientation. However, the print dialog box orients the page to landscape and prints it that way. Noticed the reverse was true in another bug that was fixed, so now Portrait appears only in Landscape.

Steps to Reproduce:
1.Prepare Writer document for printing
2.Select Print from File Menu
3.Print document - will print in Landscape mode.

Actual Results:  
Copy and paste, or type, text into Writer document. Text is in portrait orientation, as preferred. If Print Preview is chosen, document appears correctly. Select Print from file menu, and the print dialog box appears with page in landscape mode, with no choice to re-orient the page. I use a template form most times, but problem is also in any Writer document.

Expected Results:
Expect portrait mode to print portrait, as shown on screen. 


Reproducible: Always

User Profile Reset: Yes - did not change print dialog error.

Additional Info:
Does not occur in other text apps.Tried printing in Apple's TextEdit and Growly Write, and both print correctly, so does not appear to be system issue.

NOTE: this version is appearing as 5.4.3, not 5.4.0.3


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36 OPR/46.0.2597.57
Comment 1 Alex Thurgood 2017-08-03 06:25:02 UTC
@Mike : Are you sure about the version number ?

There is currently no version 5.4.3.

In my download from the TDF website, I see version 5.4.0.3 in the About dialog.

I also have a separate installation of LibreOffice 5.3.4.2 - perhaps it is this version you are referring to ?

In version 5.3.4.2, the incorrect orientation when printing bug was already known. Marking this report as a duplicate of that bug.

*** This bug has been marked as a duplicate of bug 86838 ***