Download it now!
Bug 86838 - Letter page format size prints portrait pages as landscape on OS X (Brother and HP printers)
Summary: Letter page format size prints portrait pages as landscape on OS X (Brother a...
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: All Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 107432 110744 (view as bug list)
Depends on:
Blocks: Print
  Show dependency treegraph
 
Reported: 2014-11-29 01:35 UTC by Al Maloney
Modified: 2017-09-27 21:23 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer document (13.56 KB, application/vnd.oasis.opendocument.text)
2014-11-30 12:24 UTC, Al Maloney
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Al Maloney 2014-11-29 01:35:10 UTC
When attempting to print a Writer portrait document, it prints rotated 90 degrees (= landscape).
This occurs in 4.4.0 and in 4.5.0
It does not occur in 4.3.5.1
It does not occur in Calc.
A landscape document prints correctly.
Comment 1 Alex Thurgood 2014-11-30 10:58:52 UTC
Version: 4.5.0.0.alpha0+
Build ID: 1386c348f81738a9966d1217db89d1f603466317
Locale: fr_


Can not confirm on own master build osx 10.10.1
Tested printing a4 letter default page style portrait - printed in portrait mode as expected
Two different printers : Samsung CLX 3170 and Kyocera FS C5150
Comment 2 Alex Thurgood 2014-11-30 10:59:35 UTC
Please provide test document displaying issue.
Comment 3 Al Maloney 2014-11-30 12:24:19 UTC
Created attachment 110264 [details]
Writer document
Comment 4 Al Maloney 2014-11-30 12:25:04 UTC
Alex
I note that you used OS X 10.10
Please try it using OS X 10.9

Al Maloney
Comment 5 Alex Thurgood 2014-11-30 20:59:28 UTC
Unlikely, as I don't have it.
Comment 6 Al Maloney 2014-12-08 02:10:44 UTC
Furthermore - it appears that the problem is related to the Paper size selection.

If I switch from Letter to A4 (or any size other than Letter) the document prints correctly.
When I revert to Letter size the problem recurs.

Al Maloney
Comment 7 Tree 2015-02-05 23:10:36 UTC
I have seen this bug occur in LibreOffice 4.3.5.2

I am on Mac OS 10.9.5

I did not have this issue until I upgraded LO to this version. I previously had LO 4.2.6 installed. I can confirm that when I change the page size to A4, the page no longer rotates in the Print dialog, but switching back to Letter size causes page rotation. My workaround has been to use LO's feature to generate a PDF directly, and then print that PDF, as the PDF does not have the rotation error.
Comment 8 Tree 2015-07-28 18:47:57 UTC
(In reply to Tree from comment #7)
> I have seen this bug occur in LibreOffice 4.3.5.2
> 
> I am on Mac OS 10.9.5
> 
> I did not have this issue until I upgraded LO to this version. I previously
> had LO 4.2.6 installed. I can confirm that when I change the page size to
> A4, the page no longer rotates in the Print dialog, but switching back to
> Letter size causes page rotation. My workaround has been to use LO's feature
> to generate a PDF directly, and then print that PDF, as the PDF does not
> have the rotation error.

Further information: A co-worker has a computer that is the same in terms of hardware as mine, and is also on Mac OS 10.9.5. We have the same print drivers installed. We both had LO 4.3.5.2 installed. Yet somehow, he did not experience this bug, while I consistently do!

I have upgraded to LO 4.4.4.3, and have renamed the "user" folder in Application Support in order to force the creation of a new user profile. The issue persists.

In lieu of using A4 paper size, I have seen that by changing the page size slightly (10.98" instead of 11.0") forces LO to use a custom page size, and this behaves properly. Only Letter size paper in portrait orientation fails, and for some reason only on my machine, not on any of the other computers in my office (a mix of Mac OS 10.10 and 10.6.8 machines).
Comment 9 Al Maloney 2015-08-09 16:47:30 UTC
Given Tree's experience, is this issue confined to OS X 10.9? to a specific machine?

Also, when the version moves from Dev to Fresh, the problem is resolved.
Comment 10 Pat Coyne 2015-08-10 03:21:32 UTC
Collabora's LibreOffice Vanilla
Version: 4.4.4.4
Build ID: c48f1e6c124552218cb7c1250af8e340029b989c
Locale: en.UTF-8
OS X 10.10.4
i'm a regular user, not a coder.
confirming this rotation issue.
intermittent and elusive.
By fiddling with and toggling the printing switches on the More tab, I was able to reset something and the preview on the left rotates back to portrait position.  It then printed as desired.  I cannot reliably reproduce it.

Using a Brother MFC-7460DN printer, manufacturer's drivers.
Attempting to print in Writer also, launched from email attachment.
Comment 11 Alex Thurgood 2015-08-10 16:31:43 UTC
Multiple independent confirmation ==>> NEW

I have removed 10.9 from the bug title as the same problem is reported against 10.10.4 in comment 10

#Al, and @Tree : could you indicate which printers you are using where you experience the problem ? Just in case we can nail it down to a page format problem with one particular brand/model of printer ?

Brother printers are known to have caused issues with some LibreOffice versions (or vice-versa) in the past.
Comment 12 Alex Thurgood 2015-08-10 16:46:31 UTC
_If_ this is a similar manifestation of the bug that affects envelope printing on Brother printers (of which there are already a few), then it will take someone with a debug build on OSX and a Brother printer to nail down. I have a debug OSX build, but no Brother printer.

It would also be interesting to know whether this affects other OSes.
Comment 13 Alex Thurgood 2015-08-10 16:51:46 UTC
Also, please let us know whether, in the OSX Print Dialog that opens when you Cmd-P from within LibreOffice, you have ticked/unticked "Use printer preferences" option.
Comment 14 Alex Thurgood 2015-08-10 16:54:19 UTC
@Al : when I open your test document, I see that the page format is set to Letter, but the print preview in the OSX print dialog remains in portrait orientation. This is with both my Samsung CLX 3715 and my Kyocera C5150CDN networked printers.
Comment 15 Alex Thurgood 2015-08-10 17:34:26 UTC
In comment 7, reported against 4352, resetting version to earliest reported per QA policy.
Comment 16 Al Maloney 2015-08-10 17:52:47 UTC
(In reply to Alex Thurgood from comment #14)
> @Al : when I open your test document, I see that the page format is set to
> Letter, but the print preview in the OSX print dialog remains in portrait
> orientation. This is with both my Samsung CLX 3715 and my Kyocera C5150CDN
> networked printers.

Alex
I am using two Brother computers: Brother MFC-9970CDW CUPS and Brother MFC-5370DW CUPS
I cannot find a "Use printer preferences" option.
The "Use only paper tray from printer preferences" option is NOT checked.

To-morrow I hope to have access to an HP machine and, possibly, a Kyocera printer.

Al Maloney
Comment 17 Al Maloney 2015-08-11 00:07:05 UTC
Using LibreOfficeDev 5.0.1 - the 90 degree rotation problem persists.

I have just downloaded LibreOffice 5.0.1.1 (RC1) - the problem has resolved!

So, if it is a printer problem, it was corrected within LibreOffice.

What has happened between these two versions to correct the problem?
Comment 18 Alex Thurgood 2015-08-11 09:29:10 UTC
It would be helpfult if Tree and Pat could also test with 5.0.1 rc to check whether it is also resolved for them, that way we could set this bug to worksforme.
Comment 19 tommy27 2015-08-29 11:33:29 UTC
I received a mail from Al Maloney telling he's using an HP LaserJet P2055dn via USB.

so I'm adding HP to the summary with Brother as well (see comment 10)
Comment 20 Al Maloney 2015-08-29 14:54:51 UTC
tommy27

If the problem lies with the printers, how does one explain the behaviour in my comment 17?

Using both the Brother and the HP printers, the problem is resolved in the release version but persists in the Dev version.
Comment 21 tommy27 2015-08-29 17:56:21 UTC
Please download the latest daily build and tell if the issue is still there
Comment 22 Al Maloney 2015-08-29 23:03:44 UTC
on Mac OS X 10.9.5


The problem exists with
Version: 5.0.2.0.0+
Build ID: 47fb13510fe249bdc0c0b3bb8d9d5d8009a8974b
TinderBox: MacOSX-x86_64@49-TDF, Branch:libreoffice-5-0, Time: 2015-08-29_05:47:31
Locale: en-US (en.UTF-8)


It also exists with
Version: 5.0.1.0.0+
Build ID: c0b75759ace5d0aca033504bc1cb2179fcce47d1
TinderBox: MacOSX-x86_64@49-TDF, Branch:libreoffice-5-0, Time: 2015-08-07_08:05:34
Locale: en-US (en.UTF-8)

It does not exist with
Version: 5.0.1.2
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: en-CA (en.UTF-8)
Comment 23 tommy27 2015-08-30 18:44:17 UTC
thanks for the new tests... the situation you describe is quite strange...
is there any other Mac user that can take a look at it?
Comment 24 Alex Thurgood 2015-11-02 10:23:42 UTC
*** Bug 95453 has been marked as a duplicate of this bug. ***
Comment 25 steve -_- 2016-03-05 15:53:57 UTC
adding keyword "regression". OP wrote this is working as expected in 4.3.5.1.

Version: 5.2.0.0.alpha0+
Build ID: 7ccdb94e2c5774f924bf89b34387c7d41e2e4c30
CPU Threads: 4; OS Version: Mac OS X 10.11.3; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-03-03_02:42:27
Locale: de-DE (de.UTF-8)

    Works as expected.

Version: 5.0.2.2
Build-ID: ab9e2a14cfa5edd30bd74f156cfba09bfd5be3a0
Gebietsschema: de-DE (de.UTF-8)

    Works as expected.

OS X 10.11.3. Printer: brother 7055w.

→ ANY AFFECTED USERS: Please give exact OS X + printer you are seeing this issue with.
Comment 26 steve -_- 2016-03-05 15:59:28 UTC
Setting to NEEDINFO until we have more details.

Also any affected user: please try the latest master and see if you still can reproduce the problem.
http://dev-builds.libreoffice.org/daily/master/MacOSX-x86_64@49-TDF/
Comment 27 Al Maloney 2016-03-05 16:29:22 UTC
Version: 5.2.0.0.alpha0+
Build ID: 31e037c348ef0e04393926891617fde1b0051a35
CPU Threads: 4; OS Version: Mac OS X 10.11.3

Brother MFC9970cdw

Problem persists
Comment 28 steve -_- 2016-03-05 16:47:21 UTC
back to NEW I guess. even when changing to Letter format, this still prints correctly here.

So I wonder if this is a problem with only a few specific printer models?

@Al: Do you have MS Word or Apple Pages installed? Do they behave correctly? Do you see the problem already in the printing preview dialog or only once the paper comes out of your printer?
Comment 29 Yousuf Philips (jay) (retired) 2016-03-05 18:09:47 UTC
Going through the reviews on the mac app store, many users are facing this same issue.

https://itunes.apple.com/us/app/libreoffice-vanilla/id921923693?mt=12

One of the reviews also stated that it also happens in Calc.

http://i.imgur.com/XgtMqVj.png
http://i.imgur.com/9G7CHjj.png

Would be good for the Mac users who are affected by this to see if changing any of the LibreOffice settings in the print dialog under the 'Show details' button corrects this behaviour.
Comment 30 Al Maloney 2016-03-05 19:39:32 UTC
@Steve
The problem does not exist with
Version: 5.1.1.1
Build ID: c43cb650e9c145b181321ea547d38296db70f36e
CPU Threads: 4; OS Version: Mac OS X 10.11.

It seems that the problem occurs with LibreOfficeDev and is not present in the LibreOffice RC1 version.

The problem does not exist in Apple Pages 5.6.1

@Yousuf (Jay)
see comment 6
Also, if I change any dimension of the US Letter size by a fraction of a centimetre, the problem does not occur.
Comment 31 Yousuf Philips (jay) (retired) 2016-03-05 20:18:13 UTC
(In reply to Al Maloney from comment #30)
> The problem does not exist with
> Version: 5.1.1.1
> Build ID: c43cb650e9c145b181321ea547d38296db70f36e
> CPU Threads: 4; OS Version: Mac OS X 10.11.
> 
> It seems that the problem occurs with LibreOfficeDev and is not present in
> the LibreOffice RC1 version.

So the problem has been solved in release versions, but is broken in daily builds? Is it possible for you to check the latest 5.0 release to see if is broken there for you?

(In reply to Al Maloney from comment #30)
> @Yousuf (Jay)
> see comment 6
> Also, if I change any dimension of the US Letter size by a fraction of a
> centimetre, the problem does not occur.

Yes i had seen that comment and was just asking to double check any of the other settings, as i would assume modifying the size of the Letter wouldnt be a suitable fix for this.

@Bubli: Would it be possible to we have a Mac exclusive fix that Letter page size is slightly different from what it should be?
Comment 32 Al Maloney 2016-03-05 20:40:15 UTC
@yousuf (Jay) re comment 31

The problem does not exist with
Version: 5.0.4.2
Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
Comment 33 Yousuf Philips (jay) (retired) 2016-03-05 21:55:38 UTC
(In reply to Al Maloney from comment #32)
> @yousuf (Jay) re comment 31
> 
> The problem does not exist with
> Version: 5.0.4.2
> Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78

What about the version on the Mac app store?
Comment 34 Al Maloney 2016-03-05 23:28:02 UTC
Using LibreOffice Vanilla from the AppStore
Version: 5.0.2.2
Build ID: ab9e2a14cfa5edd30bd74f156cfba09bfd5be3a

The problem exists.
Comment 35 steve -_- 2016-03-06 09:33:47 UTC
Al, thanks for all the testing and feedback. The more we can narrow this down, the sooner devs will be able to fix it.

Since I can't reproduce it on my osx system, can you answer, if you already see the wrong landscape format in the print preview dialog (when printing portrait) or is all that correct, but the paper still comes out of your printer in the wrong format?
Comment 36 Al Maloney 2016-03-06 15:07:49 UTC
(In reply to steve -_- from comment #35)
> Al, thanks for all the testing and feedback. The more we can narrow this
> down, the sooner devs will be able to fix it.
> 
> Since I can't reproduce it on my osx system, can you answer, if you already
> see the wrong landscape format in the print preview dialog (when printing
> portrait) or is all that correct, but the paper still comes out of your
> printer in the wrong format?

In all cases I see the wrong landscape format in the print preview dialog and in the print copy.

Al
Comment 37 steve -_- 2016-03-10 09:56:57 UTC
Could you try LO 5.1 which is now available in the MAS and report back.
Comment 38 Al Maloney 2016-03-10 12:18:52 UTC
(In reply to steve -_- from comment #37)
> Could you try LO 5.1 which is now available in the MAS and report back.

It does not happen with
Version: 5.1.1.3
Build ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
CPU Threads: 4; OS Version: Mac OS X 10.11.3

It did happen with the Dev versions of 5.1
(I always run a Dev version in parallel)

It did not happen with the RC versions of 5.1

It does happen with
Version: 5.2.0.0.alpha0+
Build ID: 50336412f775af154509d67b1ebbdb4b5feb147b
CPU Threads: 4; OS Version: Mac OS X 10.11.3; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-03-10_08:05:10
Locale: en-CA
Comment 39 tommy27 2016-03-11 05:40:57 UTC
(In reply to Al Maloney from comment #38)
> ....
> 
> It does not happen with
> Version: 5.1.1.3

so it's a WORKSFORME in latest 5.1.1 official release.

> It did happen with the Dev versions of 5.1
> (I always run a Dev version in parallel)

which 5.1 Dev version do you refer? Future 5.1.2.x ?
please copy and paste build ID and Tinderbox time.

we need to know if there a regression in the 5.1.x codeline after the 5.1.1.3 release.

> It did not happen with the RC versions of 5.1

I guess you refer to 5.1.1 RC1 which makes sense since final 5.1.1.3 shows no bug.

> It does happen with
> Version: 5.2.0.0.alpha0+
> Build ID: 50336412f775af154509d67b1ebbdb4b5feb147b
> CPU Threads: 4; OS Version: Mac OS X 10.11.3; UI Render: default; 
> TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-03-10_08:05:10
> Locale: en-CA

so this implies there's a regression in the 5.2.0.0 codeline
Comment 40 tommy27 2016-03-11 05:41:45 UTC
also, what about latest 5.0.5.2 ?
is the bug still present in the 5.0.x codeline?
Comment 41 Al Maloney 2016-03-11 19:31:58 UTC
(In reply to tommy27 from comment #40)
> also, what about latest 5.0.5.2 ?
> is the bug still present in the 5.0.x codeline?

The problem does NOT occur in
Version: 5.0.5.2
Build ID: 55b006a02d247b5f7215fc6ea0fde844b30035b3
Locale: en-CA (en.UTF-8)


It seems that the problem exists in the LibreOfficeDev  5.0 and 5.1 versions and that it is resolved in the transition to the RC1, RC2, RC3, and Final versions

Thinking the problem lay in my setup, I have changed both the ~/Library/Application Support/LibreOffice and  ~/Library/Application Support/LibreOfficeDev directories. This had no effect on the problem.
Comment 42 steve -_- 2016-03-11 21:48:49 UTC
Taking the liberty to close this as WORKSFORME (as we have no commit fixing this).

Al, it would be great if you could leave a review on the MAS to let other users know, this no longer is a problem. There were quite a few reviews complaining about this issue.

If humans are still running into this, please re-open and let us know!

Have a great weekend everybody (:
Comment 43 steve -_- 2016-03-11 21:54:31 UTC
And not to be forgotten: Al thanks for your continuous help again and again testing stuff and contributing feedback!
Comment 44 Alex Thurgood 2017-04-28 08:14:02 UTC
Re-opening in view of bug 107432, which affects LibreOffice Vanilla from the AppStore, in the same way as reported here in comment 34
Comment 45 Alex Thurgood 2017-04-28 08:14:17 UTC
*** Bug 107432 has been marked as a duplicate of this bug. ***
Comment 46 Alex Thurgood 2017-04-28 08:16:28 UTC
@Andras : are you still looking at the Collabora-specific release bugs ?
Comment 47 Al Maloney 2017-07-26 11:20:53 UTC
The problem has returned in 5.3.5.X and 4.4.0.x
Using macOS 10.12.6 on a MacBook Pro
It does not happen with 5.2.7, nor with 5.3.4

Version: 5.4.0.3
Build ID: 92c2794a7c181ba4c1c5053618179937228ed1fb
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-CA (en_US.UTF-8); Calc: group

Version: 5.3.5.1
Build ID: 020db1aa8142e57290f8a21e4df31185392d0e38
CPU Threads: 4; OS Version: Mac OS X 10.12.6; UI Render: default; Layout Engine: new; 
Locale: en-CA (en_US.UTF-8); Calc: group
Comment 48 Al Maloney 2017-07-26 23:26:47 UTC
(In reply to Al Maloney from comment #47)
> The problem has returned in 5.3.5.X and 4.4.0.x
> Using macOS 10.12.6 on a MacBook Pro
> It does not happen with 5.2.7, nor with 5.3.4
> 
> Version: 5.4.0.3
> Build ID: 92c2794a7c181ba4c1c5053618179937228ed1fb
> CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
> Locale: en-CA (en_US.UTF-8); Calc: group
> 
> Version: 5.3.5.1
> Build ID: 020db1aa8142e57290f8a21e4df31185392d0e38
> CPU Threads: 4; OS Version: Mac OS X 10.12.6; UI Render: default; Layout
> Engine: new; 
> Locale: en-CA (en_US.UTF-8); Calc: group

In the first line 4.4.0.x should be 5.4.0.x
Comment 49 Al Maloney 2017-07-28 13:19:31 UTC
(In reply to Al Maloney from comment #48)
> (In reply to Al Maloney from comment #47)
> > The problem has returned in 5.3.5.X and 4.4.0.x
> > Using macOS 10.12.6 on a MacBook Pro
> > It does not happen with 5.2.7, nor with 5.3.4
> > 
> > Version: 5.4.0.3
> > Build ID: 92c2794a7c181ba4c1c5053618179937228ed1fb
> > CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
> > Locale: en-CA (en_US.UTF-8); Calc: group
> > 
> > Version: 5.3.5.1
> > Build ID: 020db1aa8142e57290f8a21e4df31185392d0e38
> > CPU Threads: 4; OS Version: Mac OS X 10.12.6; UI Render: default; Layout
> > Engine: new; 
> > Locale: en-CA (en_US.UTF-8); Calc: group
> 
> In the first line 4.4.0.x should be 5.4.0.x

The problem is resolved in
Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-CA (en_US.UTF-8); Calc: group
Comment 50 Alex Thurgood 2017-07-31 08:26:49 UTC
Per comment 49, setting as WFM
Comment 51 Al Maloney 2017-07-31 11:00:20 UTC
re comment 49

I thought the problem had been resolved in the "fresh" release of 5.4.0.
However this is partially true - it depends upon which of my templates I am using (of 40 or so templates).

When I check File->Properties for an affected template and for an unaffected template, I can find no difference.
So…I do not know where to go from here.

For a given affected document, switching page size to anything other than Letter resolves the problem until I return to Letter size.

The problem does not occur in 5.3.4. 

Al Maloney
Comment 52 tommy27 2017-07-31 11:56:05 UTC
I think it's better to start a new clean bug report about residual issues.

try to identify the "offending" template and upload it to the new bug report along with a "non offending" template.

maybe devolopers may investigate deeper and find what triggers the bug
Comment 53 Alex Thurgood 2017-08-03 06:25:02 UTC
*** Bug 110744 has been marked as a duplicate of this bug. ***
Comment 54 nshani 2017-08-18 18:24:28 UTC
Similar behaviour noticed with 5.4.0.3 which I just started using last week.

All other applications (Preview, Text Edit) work fine and show the page orientation icons, but not this application and version. Looks like I'll have to revert to 5.3.5 as that one didn't show this quirk.
The issue is shown on 2 Macs, all running the same versions of OS and applications.
Comment 55 nshani 2017-08-18 18:42:27 UTC
Issue still present with 5.4.0.3 on MacBook Air running MacOS 12.6
Haven't tried re-sizing the page (as suggested above - will try it later) but can confirm that changing to A4 does resolve the issue. So this is a 'feature'? ;-)
Comment 56 Ken Weiss 2017-09-27 16:56:22 UTC
I am running Mac OS Sierra 10.12.6 and LibreOffice 5.4.1.2 on an iMac (3.1 GHz Core i7).

The landscape printing problem still occurs on single page documents (letter portrait format) but oddly enough does not occur on a multipage document formatted the same way.

It may or may not be relevant that the multipage document is a newsletter with pages formatted as two columns and using a variety of fonts.