Bug 82370 - PRINTING: incorrect orientation of #10 envelope (Brother printer)
Summary: PRINTING: incorrect orientation of #10 envelope (Brother printer)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 81848 84204 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-08 21:29 UTC by konsultor
Modified: 2016-03-12 13:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description konsultor 2014-08-08 21:29:31 UTC
Problem description: 
Printing envelopes, the return address always falls in what would be the upper left corner of a portrait letter page, not on the envelope and not rotated.  Have tried all the config variations in the Brother driver for the HL-3179cdw printer:  paper type, paper size, orientation, etc.

I am using LibreOffice 4.1.6.2 (the latest in the openSuse 13.1repository) with KDE.  Document is save in Word 95/2003 DOC format (but that gets imported to the ODT format as I understand it).  

Steps to reproduce:
1. Insert envelope in LibreOffice document.
2. Add graphic (jpg) and text for return address.
3. Print p. 1 of the document and the return address falls off the left side of the envelope at the leading edge.

Current behavior:
Text prints horizontally at top of letter size page.

Expected behavior:
Text prints vertically, centered on printer.

Report from tech support at Brother:
I understand that envelope printing is not correct. The image prints at the top of the page. I was able to recreate the issue also. I was thinking that it was a CUPS driver issue so I downloaded open office on a windows pc and a Macintosh pc. The windows pc using Open office printed correctly. This helped me to continue thinking that we have CUPS issue. I printed using Open office from my Macintosh and the issue was the same. So again I was thinking that the issue was the CUPS drivers. So in the from the Mac pc I use word for Mac and I was able to print fine. So that mean now that CUPS work fine. I would have to conclude that it is an issue within Open\Libreoffice. I would have to refer to support for the application.

 
              
Operating System: openSUSE
Version: 4.1.6.2 release
Comment 1 Yousuf Philips (jay) (retired) 2014-08-09 03:51:38 UTC
Hi Konsultor,

Thank you for reporting the bug. Can you see if bug 77277 is similar to your problem so that i can report your bug as a duplicate of that one.
Comment 2 konsultor 2014-08-10 02:42:44 UTC
Good suggestion jay.  They could be related though the behavior is not exactly the same.  Could it be that  LO doesn't report the envelope size or orientation properly to CUPS?
[NOTE:  I'm not a coder, so this is a philosophical statement  :-) ]
Comment 3 Yousuf Philips (jay) (retired) 2014-08-10 04:50:17 UTC
(In reply to comment #2)
> Good suggestion jay.  They could be related though the behavior is not
> exactly the same.

What exactly is different in your view?

> Could it be that  LO doesn't report the envelope size or
> orientation properly to CUPS?
> [NOTE:  I'm not a coder, so this is a philosophical statement  :-) ]

Yes i think there must be some problem between CUPS and the printer driver which is causing this issue.
Comment 4 konsultor 2014-08-12 15:01:42 UTC
Difference from other bug:  I don's see a change in size for the envelope, as in 
"when the envelope is inserted into the document, the size will change from a #10 envelope to a 6 x 9 custom envelope. "
Comment 5 Yousuf Philips (jay) (retired) 2014-08-13 07:44:25 UTC
The user who reported the issue was mistaken with those words and further clarified that the 6 x 9 only showed up in the print dialog.
Comment 6 tommy27 2014-09-26 20:29:54 UTC
please take a look at Bug 81848

do you think these are duplicates?
Comment 7 konsultor 2014-09-26 23:23:53 UTC
Yes, 81848 sounds very similar.  I seem to get portrait when I think I want want landscape.  That is, my printer inserts the envelope left to right but the image prints top to bottom.  (Is that clear?)
Comment 8 tommy27 2014-10-27 19:24:46 UTC
*** Bug 81848 has been marked as a duplicate of this bug. ***
Comment 9 tommy27 2014-10-27 19:31:03 UTC
*** Bug 84204 has been marked as a duplicate of this bug. ***
Comment 10 tommy27 2014-10-27 19:40:14 UTC
I set status to NEW because of the existence of duplicates (both on Linux and at least one with a Brother printer too) and I edited summary notes as well.
Comment 11 tommy27 2015-08-28 07:18:03 UTC
issue was confirmed under Windows as well.

see: https://bugs.documentfoundation.org/show_bug.cgi?id=93718#c0 

hardware --> ALL
Comment 12 konsultor 2015-09-23 17:31:39 UTC
Now on openSuse 13.2 and LibreOffice 4.4.5.2 but the problem persists with the Brother printer.  I can print envelopes on an old HP LJ2100 but I'd like to include a color logo in the return address.  When I get to select, I pick postscript as the printer language for both printers.
Comment 13 tommy27 2016-03-12 01:04:12 UTC
please retest with 5.0.5.2 or 5.1.1.3 and tell if anything changed
Comment 14 konsultor 2016-03-12 05:02:56 UTC
Glory be! 

Two files, in .odt and .doc (2007-2003), worked as expected.  These same files were the ones which failed to print #10 envelopes properly. 

Now using the HP LJ-2100 and Brother HL-3170cdw with LibreOffice 5.4.0.2 on openSuse 42.1 with KDE.

Thank you for the follow up.
Comment 15 tommy27 2016-03-12 13:52:55 UTC
nice to hear that. RESOLVED WORKSFORME