Bug 77277 - PRINTING: #10 Envelope changes to 6 x 9 envelope (Brother printers)
Summary: PRINTING: #10 Envelope changes to 6 x 9 envelope (Brother printers)
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: x86-64 (AMD64) All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 64966 75449 93718 (view as bug list)
Depends on:
Blocks: Envelope
  Show dependency treegraph
 
Reported: 2014-04-10 17:07 UTC by art guerra
Modified: 2021-12-03 04:30 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Print diolog box (34.26 KB, image/png)
2014-06-25 02:49 UTC, art guerra
Details
Screenshot of Envelope insert defaulting to C5 (103.72 KB, image/png)
2014-07-12 19:16 UTC, rhanksjr
Details
Screen grab of #10 envelope (224.69 KB, image/png)
2014-07-14 13:47 UTC, Marc Pare
Details
Samsung printer 1 driver (102.08 KB, image/png)
2014-07-15 06:22 UTC, Marc Pare
Details
Samsung printer 2 driver (100.34 KB, image/png)
2014-07-15 06:22 UTC, Marc Pare
Details
BrotherHL2040 printer 1 driver (102.08 KB, image/png)
2014-07-15 06:23 UTC, Marc Pare
Details
BrotherHL2040 printer 2 driver (100.34 KB, image/png)
2014-07-15 06:23 UTC, Marc Pare
Details

Note You need to log in before you can comment on or make changes to this bug.
Description art guerra 2014-04-10 17:07:08 UTC
When I try to insert a #10 envelope into a writer document, Writer will insert a custom 6x9 envelope in the document instead.

To replicate this error:

SELECT INSERT
CLICK ON ENVELOPE

select #10 envelope from the list
enter addressee and delivery address
select insert to document

when the envelope is inserted into the document, the size will change from a #10 envelope to a 6 x 9 custom envelope. 

I am currently using windows 8.1 along with a Brother MFC-295 inkjet printer.

At this time I am unable to print envelopes because of this error. Please fix asap.
Comment 1 art guerra 2014-04-17 02:39:18 UTC
Confirmed fixed in Apache Openoffice 4.1
Comment 2 Yousuf Philips (jay) (retired) 2014-06-05 05:08:58 UTC
I tested LibreOffice 4.2.4 on Linux Mint and Windows 7 and it looks the same as OpenOffice 4.1, so please upgrade to the latest version and verify if it has been corrected for you.
Comment 3 art guerra 2014-06-25 02:47:30 UTC
This error is still present in Libreoffice 4.2.5. See attachment.
Comment 4 art guerra 2014-06-25 02:49:29 UTC
Created attachment 101713 [details]
Print diolog box

This is a screenshot of the print dialog box showing a 6x9 envelope when #10 was originally selected.
Comment 5 Yousuf Philips (jay) (retired) 2014-06-25 06:28:38 UTC
Hi Art,

I went into the print dialog and it shows me 8.27in x 5.83in for PrimoPDF, but if i select Fax or Microsoft XPS Document Writer, it shows me 9.50in x 4.13in. So i believe your brother printer is changing the size.
Comment 6 art guerra 2014-06-25 16:58:38 UTC
Jay,

I will check to see if my printer is the issue. However I am not the only one who is having this issue. Please see the following bug reports:

64966
52926
75449 (using LO 4.3)
Comment 7 Yousuf Philips (jay) (retired) 2014-06-26 05:22:43 UTC
Hi Art,

Your initial bug report stated it was inserted into the document with the wrong size. If this is the issue, please do a print screen of how it looks in the window. If its an issue of printing the document in your printer, that is most likely being changed by your printer.
Comment 8 rhanksjr 2014-07-12 19:16:25 UTC
Created attachment 102681 [details]
Screenshot of Envelope insert defaulting to C5
Comment 9 rhanksjr 2014-07-12 19:20:17 UTC
Comment on attachment 102681 [details]
Screenshot of Envelope insert defaulting to C5

I am having this same issue. OS Linux Mint 17; Libreoffice Version: 4.2.5.2
Build ID: 420m0(Build:2)
Comment 10 Yousuf Philips (jay) (retired) 2014-07-13 15:33:57 UTC
@Art: Any updates?

@rhanksjr: how does it look when you select the CUPS pdf printer?
Comment 11 art guerra 2014-07-14 01:49:12 UTC
Hey Jay,

I tried working with my printer settings as well as the libreoffice settings and nothing worked to fix the problem. I tried changing to a different envelope size and got the same error. Finally, I tried changing my printer from my current printer to a paperport pdf printer and the issue remained. 

Thanks

Art
Comment 12 Yousuf Philips (jay) (retired) 2014-07-14 02:05:49 UTC
Hi Art,

As i dont use have a printer, i will be unable to verify this issue, but i've asked individuals in the QA team who have a printer to do so. Hopefully we can get this verified by one of them and fixed soon.

If you wouldnt mind, could you test that the behaviour is there in version 3.3.0. You wont need to install it, as there is a portable version at this link < http://downloadarchive.documentfoundation.org/libreoffice/old/3.3.0.4/portable/ >.
Comment 13 Marc Pare 2014-07-14 13:47:43 UTC
Created attachment 102773 [details]
Screen grab of #10 envelope
Comment 14 Marc Pare 2014-07-14 13:49:58 UTC
Hi Art and all,

I saw the request to verify on the QA list.

It looks OK on my setup. attachment up above this comment. 

LibreOffice 4.3.02, MageiaLinux4, Brother Print HL2040
Comment 15 Yousuf Philips (jay) (retired) 2014-07-14 14:36:27 UTC
Thanks Marc for checking it, but you have to go into the print dialog to test this, as shown in attachment 101713 [details] and attachment 102681 [details].
Comment 16 art guerra 2014-07-15 01:06:14 UTC
Jay,

I tried it using 3.3.0.4 as you suggested and received the same error. I did notice that if you click on envelope on the bottom of the screen, it will bring up the envelope style screen. On this screen, the page setup shows a user defined page instead of a #10 envelope. If I change this to #10 the correct size will appear on writer but the text boxes will be off due to the previous settings from the insert envelope screen.

Thanks 

Art
Comment 17 Marc Pare 2014-07-15 06:22:09 UTC
Created attachment 102814 [details]
Samsung printer 1 driver
Comment 18 Marc Pare 2014-07-15 06:22:34 UTC
Created attachment 102815 [details]
Samsung printer 2 driver
Comment 19 Marc Pare 2014-07-15 06:23:04 UTC
Created attachment 102816 [details]
BrotherHL2040 printer 1 driver
Comment 20 Marc Pare 2014-07-15 06:23:21 UTC
Created attachment 102817 [details]
BrotherHL2040 printer 2 driver
Comment 21 Marc Pare 2014-07-15 06:29:22 UTC
Hi everyone and Jay, here are 4 screenshots with the measurements.. 

Something strange, my Mageia system will sometimes pick out 2 instances of the same printer/network printer. But in this case, it looks like one driver is creating a #10 envelope size to correct dimensions and the second driver for the same printer is creating a #10 envelope with the wrong size. Have a look at my drivers for my Brother HL4020 and my Samsung SCX-4200.

Maybe this could be one of the problems with the bug. The #10 evenlope size and dimensions are being skewed by the printer driver?

Marc
Comment 22 Yousuf Philips (jay) (retired) 2014-08-10 04:46:28 UTC
*** Bug 75449 has been marked as a duplicate of this bug. ***
Comment 23 Yousuf Philips (jay) (retired) 2014-08-10 04:47:25 UTC
*** Bug 64966 has been marked as a duplicate of this bug. ***
Comment 24 William C. 2014-10-14 19:56:54 UTC
I'm using LibreOffice 4.3.2.2 on opensuse Factory (13.2). I've been experiencing the same problem with ubuntu 14.04, kubuntu 14.04, opensuse 12.3 & 13.1, beginning with LibreOffice version 4.2.1. Currently using Brother MFC-9340CDW laser all-in-one.
Comment 25 Chad Condon 2014-10-26 21:31:19 UTC
Cannot reproduce in 4.2.6.3 on ubuntu 14.04.
Comment 26 tommy27 2014-10-27 06:28:12 UTC
this bug seems related to the use of a Brother printer (adding it to summary)

@Marc Pare
so do you reproduce the bug with a Brother printer but not with a Samsung printer, is that correct?

@Chad Condon
please define your printer brand and model
Comment 27 tommy27 2015-08-28 07:15:23 UTC
*** Bug 93718 has been marked as a duplicate of this bug. ***
Comment 28 tommy27 2015-08-28 07:16:36 UTC
(In reply to tommy27 from comment #27)
> *** Bug 93718 has been marked as a duplicate of this bug. ***

issue was confirmed under Windows as well. 
hardware --> ALL
Comment 29 tnpel2925 2016-01-25 22:22:18 UTC
Libre 5 on Linux 32 bit Brother printer - page layout would not change from C6. Saved as a .doc and opened on Libre 5 Linux 64 and envelope displayed and printed as a #10 as originally requested on 32 bit machine.
Comment 30 QA Administrators 2017-03-06 14:03:49 UTC Comment hidden (obsolete)
Comment 31 QA Administrators 2019-12-03 14:15:31 UTC Comment hidden (obsolete)
Comment 32 QA Administrators 2021-12-03 04:30:41 UTC
Dear art guerra,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug