Download it now!
Bug 52926 - Format changes from "#10 Envelope" to "User" with different height, margin-top, and offset (Canon & Brother printers)
Summary: Format changes from "#10 Envelope" to "User" with different height, margin-to...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Envelope
  Show dependency treegraph
 
Reported: 2012-07-29 22:13 UTC by Tim
Modified: 2020-02-11 14:23 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim 2012-07-29 22:13:35 UTC
Problem description: 

Steps to reproduce:
1. Insert
2. Envelope
3. New Doc. or Insert

Current behavior:
For #10 envelope, when the envelope is inserted into document or created as new document, the formatting changes as follows:
Name of format changes from "#10 Envelope" to "User"
Height changes from 4.13" to 6.31"
Margin-top changes from 0 to 2.19"
Offsets from anchor point are increased by 2.18" vertical
Expected behavior:
Expect to format as previewed
Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 JD 2012-11-26 05:09:13 UTC
I can confirm this exact problem while using Version 3.6.3.2 (Build ID: 58f22d5)
Windows 7 64-bit
Canon MG5320 printer

Standard LO installation - all defaults, templates, etc.
Comment 2 nyar 2013-04-12 20:24:41 UTC
Hi, 

I am seeing this exact behavior as well on Ubuntu 12.04 with this LO build info:

LibreOffice 3.5.7.2 
Build ID: 350m1(Build:2)
Comment 3 Jorendc 2013-06-28 17:56:42 UTC
Confirmed twice -> NEW.

Kind regards,
Joren
Comment 4 junk 2013-11-26 17:51:18 UTC
I can confirm this problem with ver 4.1.3.2 using a Canon MF4370dn printer using the UFRII-LT ver 2.5 drivers. It appears that the printer driver specifies an unprintable area that intwerferes with LibreOffice's envelope definitions.
Comment 5 junk 2013-12-05 19:08:15 UTC
This also occurs for Canon UFRII Drivers version 2.70.
LibreOffice Version: 4.1.3.2
Build ID: 410m0(Build:2)
Linux 3.2.0-57-generic #87-Ubuntu SMP
Ubuntu 12.04 LTS
Comment 6 Yousuf Philips (jay) (retired) 2014-07-11 08:28:22 UTC
Dear Tim,

Thank you for take the time to report this bug. Someone has reported a similar issue with their brother printer in bug 77277. Can you see if any of the information in that bug helps your situation.
Comment 7 Owen Genat (retired) 2014-09-06 02:52:04 UTC
Edited summary for clarity.
Comment 8 tommy27 2014-10-27 06:25:26 UTC
this seems a Canon specific issue (added to summary notes)
Comment 9 nyar 2014-10-27 16:38:37 UTC
Hi - I have observed this issue with a Brother HL-2040 printer, so not restricted to Canon
Comment 10 tommy27 2014-10-27 16:42:57 UTC
@nyar
thanks, just corrected summary notes.
please take a look at Bug 77277 and tell me if it looks to you that it's the same issue.

we should investigate if Canon and Brother printers have similar drivers or other components.

there are multiple envelope bugs which seem specific to these 2 brands.
Comment 11 nyar 2014-10-27 16:47:02 UTC
Hi Tommy,

Yes, Bug 77277 is similar, if not identical.  The steps to reproduce are the same for my issue.  

However, if I go to Printer Settings first and select #10 as the paper size, the new document is created with the proper (#10 envelope) size and margins.
Comment 12 QA Administrators 2016-09-20 09:42:20 UTC Comment hidden (obsolete)
Comment 13 Darrell 2018-01-11 17:42:22 UTC
The problem as described occurs for me in 5.4.4.2,  Build ID: 1:5.4.4~rc2-0ubuntu0.16.04.1~lo1. It is not restricted to Canon and Brother printers; it occurs for me with an HP LaserJet Pro 200 Color, using a print queue configured for #10 envelopes. Specifically, in the Envelope dialog Format:Size:Format is set to #10 Envelope with Width 9.5" and Height 4.13" and Printer:Current Printer is a print queue with media type #10 Envelope. Clicking on Insert results in creation of an envelope image that is much too tall for a #10 envelope, and selecting File: Print shows "C5 Envelope" in the Print dialogue.
Comment 14 Darrell 2018-01-11 18:57:03 UTC
Tested on 6.0.0.1 (x64) on Windows 10.0. Results are largely the same, except that switching among the various print destinations available under Windows results in various paper sizes in the Print dialogue:

Print to file, Microsoft Print to PDF, Send To OneNote 2016: B5 (JIS)
Fax: A4
LaserJet 200: C5 Envelope
Microsoft XPS Document Writer: 6.31"x9.50", no media type shown
Comment 15 QA Administrators 2019-01-17 04:03:04 UTC Comment hidden (obsolete)
Comment 16 Buovjaga 2019-10-17 09:01:03 UTC
ecomer could still repro in https://bugs.documentfoundation.org/show_bug.cgi?id=99968#c14 so moving them here from that particular report, which is now closed as WFM by the original reporter

Note that in bug 99968, it was revealed that for some printers, the generic Windows driver causes the problem, while using the official driver from the manufacturer works fine.
Comment 17 ecomer 2019-10-17 13:53:23 UTC
I have changed printer since my original post, although it is also a Brother. I still see the same problem where #10 envelope opens as a "User" size instead of the #10 envelope.

My current LibreOffice about box is:
Version: 6.3.2.2
Build ID: 6.3.2-2
CPU threads: 2; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.utf8); UI-Language: en-US
Calc: threaded

lpinfo --make-and-model "Brother MFC-L2710DW series" -m
driverless:ipp://BRW485F9924BB66.local:631/ipp/print Brother MFC-L2710DW series, driverless, cups-filters 1.25.11
everywhere IPP Everywhere

$ uname -a
Linux asrock 5.3.6-1-MANJARO #1 SMP PREEMPT Sat Oct 12 09:30:05 UTC 2019 x86_64 GNU/Linux

$ lsb_release -a
LSB Version:	n/a
Distributor ID:	ManjaroLinux
Description:	Manjaro Linux
Release:	18.1.1
Codename:	Juhraya
Comment 18 Larry Fahnoe 2020-02-03 18:57:56 UTC
Confirming the same behavior with MacOS and Brother MFC-L5700DW series-AirPrint.

Version: 6.3.4.2
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU threads: 4; OS: Mac OS X 10.13.6; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

--Larry
Comment 19 ecomer 2020-02-11 14:23:30 UTC
Fixed for me thanks to a suggestion posted on ask.libreoffice.org:
https://ask.libreoffice.org/en/question/165141/wrong-default-envelope-size-impossible-to-correct/

Went to /home/user/.config (dotfile folder where config files are kept). Deleted the libreoffice folder. Reopened writer, went through the insert - envelope routine. Set format for #10 envelope. WORKED PROPERLY.

That fixed it for me also. Apparently some junk leftover from version upgrades was breaking the envelope size/print function.