Bug 99968 - The format for an envelope does not get passed to the print function, Print is still set to 11.0" x 8.5"...
Summary: The format for an envelope does not get passed to the print function, Print ...
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevAdvice
Depends on:
Blocks: Envelope
  Show dependency treegraph
 
Reported: 2016-05-20 15:40 UTC by Kenr
Modified: 2019-10-17 09:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screen shot of page from format screen an 2 shot is from print function page format (441.84 KB, application/vnd.oasis.opendocument.text)
2016-05-21 01:37 UTC, Kenr
Details
Screenshots (431.90 KB, image/png)
2016-05-26 13:30 UTC, Buovjaga
Details
driver window (90.65 KB, image/png)
2018-03-30 19:11 UTC, christopher.ryba
Details
Screenshot-03-31-18 References a PDF file, the Linux driver is a PPD file. Is this an issue? (17.76 KB, image/png)
2018-03-31 14:57 UTC, Kenr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kenr 2016-05-20 15:40:23 UTC
Whether you create a new #10 envelope for for printing or use a saved copy from prior release of Writer, the envelope page format does not get passed to the print function.  The print function continues to reflect a page format of 8.50" x 11.0" and there is not way to reset the format to envelope in the print function as the change page format is disabled.
Comment 1 Theodore Matula Jr. 2016-05-20 23:27:04 UTC
Can you post a screenshot of what you are seeing?
Comment 2 Kenr 2016-05-21 01:37:05 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2016-05-26 13:30:19 UTC
Created attachment 125297 [details]
Screenshots

Saved screenshots from document and put them together
Comment 4 Buovjaga 2016-05-26 13:33:22 UTC
I don't reproduce.

Reporter uses Samsung M283x series printer.

My printer is Konica-Minolta 1600W.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: 60041cb237ea73c2c1885dd6afd99d88780c2dfc
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on May 26th 2016
Comment 5 Kenr 2016-05-27 20:25:35 UTC
When action attempted on Ubuntu 15.10 using LibreOffice ver. 5.1.3.x the same result is displayed in the setup for the Samsung M2283x printer.

The same action when attempted on a Ubuntu 14.04 using LibreOffice 4.2.8.2 the result is correctly setup as a #10 envelope with same Samsung M283x printer.
Comment 6 christopher.ryba 2018-03-30 19:10:06 UTC
This is reproducible on both my debian, win7 & win10 systems, and I fought with this for the last 2 days.  I discovered that if I allowed the windows 10 automagically installed Canon MFC driver to be in place, it does not have envelope presets that correlate with a #10 envelope sized document.  

When I attempt to print (either an envelope wizard output or static document on a #10 (on my Windows 10, Canon MF634Cdw laser combo) here, the print dialog apparently tries the next closest sized paper setup (which on the Canon XPS default driver provided by Win 10 or canon's XPS subsystem) is C5 - which then results in skewed formatting and out of bounds printing.  The driver does not present a #10 envelope preset to the LO print dialog.  The default driver provided me with 6 paper sizes, device specific presented 17 (with #10 as an option)

If you install the recommended Canon MFC driver (from the manufacturer website), and then override driver selection in the printer device manager page (control panel - devices - printer properties - advanced - driver), and then try to print the document, I get a correctly formatted and laid out envelope. 

this does not appear to be an LO bug, more like a shortfall at the device driver level.  I reproduced the "#10 to C5" issue on Debian Linux (using generic & then a more device specific PPD), Windows 7, and Windows 10 using generic, catchall, and device specific drivers.
Comment 7 christopher.ryba 2018-03-30 19:11:41 UTC
Created attachment 140989 [details]
driver window

tl:dr,

print subsystem is not presenting LO w/ correct papersizes, #10 gets changed to c5...
Comment 8 Buovjaga 2018-03-31 06:50:37 UTC
(In reply to christopher.ryba from comment #6)
> If you install the recommended Canon MFC driver (from the manufacturer
> website), and then override driver selection in the printer device manager
> page (control panel - devices - printer properties - advanced - driver), and
> then try to print the document, I get a correctly formatted and laid out
> envelope. 
> 
> this does not appear to be an LO bug, more like a shortfall at the device
> driver level.  I reproduced the "#10 to C5" issue on Debian Linux (using
> generic & then a more device specific PPD), Windows 7, and Windows 10 using
> generic, catchall, and device specific drivers.

This is very interesting. As you can see, we have several of these types of issues: https://bugs.documentfoundation.org/showdependencytree.cgi?id=110434&hide_resolved=1

So you were able to get the correct result on Linux as well?
I wonder what Kenr should try with his Samsung M283x.
Comment 9 Kenr 2018-03-31 14:57:39 UTC
Created attachment 141002 [details]
Screenshot-03-31-18 References a PDF file, the Linux driver is a PPD file. Is this an issue?

Rechecked that driver in Ubuntu is loaded.
Comment 10 Buovjaga 2018-04-01 13:55:11 UTC
(In reply to Kenr from comment #9)
> Created attachment 141002 [details]
> Screenshot-03-31-18 References a PDF file, the Linux driver is a PPD file.
> Is this an issue?

No, it just means the PDF standard is used as opposed to Postscript.
Comment 11 ecomer 2018-09-07 19:16:31 UTC
I have the same problem. #10 envelope opens as a "User" size instead of the #10 envelope.
Screenshots are at: 
https://www.flickr.com/gp/celem/j3ee9N

My system is: Linux asrock 4.18.5-1-MANJARO #1 SMP PREEMPT Fri Aug 24 16:36:58 UTC 2018 x86_64 GNU/Linux

My LibreOffice version is: Version: 6.1.0.3, Build ID: 6.1.0-2
CPU threads: 2; OS: Linux 4.18; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.utf8); Calc: group threaded

Driver info:
$ lpinfo --make-and-model "HL-2140" -m
foomatic:Brother-HL-2140-hl1250.ppd Brother HL-2140 Foomatic/hl1250
[NOTE] the hl1250 driver is recommended for the HL2140.
Comment 12 RichardR369 2018-10-14 19:14:48 UTC
I have the same exact issue.  Printing to HP 8600 and #6 envelope settings won't transfer to printer.  Prints to 8x11.
Comment 13 QA Administrators 2019-10-15 02:28:29 UTC Comment hidden (obsolete)
Comment 14 ecomer 2019-10-15 14:45:59 UTC
Tested today (15 October 2019) and problem still present.
Version: 6.3.2.2
Build ID: 6.3.2-2
CPU threads: 2; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 15 Kenr 2019-10-15 15:31:50 UTC
Updates and changes to software since problem was first reported have corrected the issue.  No longer need to keep this open.
Comment 16 Buovjaga 2019-10-15 16:11:46 UTC
Kenr: as ecomer was still able to reproduce this, I think we should investigate a bit more. Can you paste here the contents of your Help - About window?

Richard, Christopher: do you still reproduce this problem with LibreOffice 6.3.x?

We probably have to open a new report for ecomer at least.
Comment 17 christopher.ryba 2019-10-15 23:51:39 UTC
I was.  If I open a saved envelope (#10) .odt and use the win10 generic driver via  FILE ->  PRINT SETTINGS, then FILE -> PRINT...the print dialog immediately formats the page to be printed to 8.27 x 5.83 in, and skews half of the text to out-of-bounds.  

If I take the same document, change the printer via the PRINT SETTINGS dialog and apply, then attempt to print, the printer dialog box reflects a correctly formatted #10 envelope with all text in bounds.

The drivers in question are the windows 10 generic driver that is auto-detected, and the Canon device specific UFR II V4 drivers loaded from their website - and updated regula...when I remember to.
Comment 18 Buovjaga 2019-10-17 09:01:35 UTC
As ecomer is a Brother user, I Cc'd them to bug 52926. Let's keep this closed.