Download it now!
Bug 94280 - Writer doesn't print all text when image is printed with Letter page format and HP printer
Summary: Writer doesn't print all text when image is printed with Letter page format a...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-16 14:53 UTC by John
Modified: 2018-08-06 17:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
File experiencing the bug. (605.25 KB, application/vnd.oasis.opendocument.text)
2015-09-16 14:53 UTC, John
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John 2015-09-16 14:53:56 UTC
Created attachment 118774 [details]
File experiencing the bug.

In a document with both text and an image, some text is ignored in printing following the image, which is attached to the page. The image does not overlap the text at all. Moving the image up on the page results in more text printing, but still not all of it. Unchecking the print image checkbox in the printing dialog results in all the text being printed.
Comment 1 Alex Thurgood 2015-09-17 07:57:00 UTC
On

Version: 5.1.0.0.alpha1+
Build ID: af433b6fff17e4e835043797063061055643b614
Locale : fr-FR (fr.UTF-8)

if I set the page to A4 in the Page properties of the document, it prints the whole page.

Please provide details of your printer, there is a known issue with portrait/landscape printing and Letter page defined documents - your problem could be similar.

Also, please indicate where you got your LibreOffice application from : the AppStore or TDF download page ?
Comment 2 Alex Thurgood 2015-09-17 08:00:03 UTC
Please provide us a screenshot of what you expect to see, and what you actually get. I can also print the Letter page configured document just fine on my Kyocera network printer, without changing the page size configuration to A4.
Comment 3 John 2015-09-17 15:27:54 UTC
Downloaded LibreOffice from download page, not the Store.

Printing Letter format to an HP LaserJet P1006.

Not at work where the printer is, so I can't get a screen shot right now.

However, of the text below the image in the attached document the only part that's printed is the first column and the last row (which has only a single item in it). In the print dialog, the LibreOffice preview looks complete, but the bigger preview on the left looks like the output. If I change settings, that preview on the left does not change, while the LibreOffice preview does (which is another issue, I suppose).
Comment 4 Dana Bell 2015-09-30 02:41:52 UTC
The text following an image does not print to PDF. The text was what I used for a caption. 

This applies to version 5.0.??; going back to 4.4 it works okay.
I'm not reinstalling 5.0 to duplicate, but anticipate the following steps will reproduce it.

Create a document
Create a style for the caption at 10pt, with color and centered.
Insert image anchored to paragraph (Position Vertical from Top by .08" to Margin, Wrap Spacing Top: .01", Bottom: .08"; Border 2pt, Spacing to Content .02"
In the following paragraph add the caption using the style created. Spacing Above Paragraph .01, Below .07")
Add another paragraph of text or whatever.
Print the document to PDF.
The image prints but the caption doesn't.

This affected essentially all images in a 200 page book.
Comment 5 Alex Thurgood 2015-09-30 07:30:38 UTC
(In reply to Dana Bell from comment #4)
>

> In the following paragraph add the caption using the style created. Spacing
> Above Paragraph .01, Below .07")
> Add another paragraph of text or whatever.
> Print the document to PDF.
> The image prints but the caption doesn't.
> 
> This affected essentially all images in a 200 page book.

This would be a different, althoug similar problem to what the original reporter mentioned. In his problem, only part of the text following the image was printed, but not the remainder. In your problem, you state that the caption isn't printed.

Please open a separate bug report for this.
Comment 6 Alex Thurgood 2015-09-30 07:33:55 UTC
(In reply to Alex Thurgood from comment #5)
> (In reply to Dana Bell from comment #4)
> >
> 
> > In the following paragraph add the caption using the style created. Spacing
> > Above Paragraph .01, Below .07")
> > Add another paragraph of text or whatever.
> > Print the document to PDF.
> > The image prints but the caption doesn't.
> > 
> > This affected essentially all images in a 200 page book.
> 
> This would be a different, althoug similar problem to what the original
> reporter mentioned. In his problem, only part of the text following the
> image was printed, but not the remainder. In your problem, you state that
> the caption isn't printed.
> 
> Please open a separate bug report for this.

Additionally, your problem relates to printing, or exporting, to PDF, which is different from the problem originally reported.
Comment 7 Alex Thurgood 2015-09-30 07:54:32 UTC
Looking at bug 47153, if you change the anchoring of the image in your document to "as character", does that then allow you to successfully print out the entire document contents ?

For QA to confirm this bug, we need someone from QA with the same setup to confirm. That would imply a north american user (as Letter is the default page setting) on OSX.
Comment 8 John 2015-09-30 13:29:52 UTC
No change for me using "as character".
Comment 9 Dana Bell 2015-09-30 15:47:52 UTC
(In reply to Alex Thurgood from comment #6)
> (In reply to Alex Thurgood from comment #5)
> > (In reply to Dana Bell from comment #4)
> > >
> > 
> > > In the following paragraph add the caption using the style created. Spacing
> > > Above Paragraph .01, Below .07")
> > > Add another paragraph of text or whatever.
> > > Print the document to PDF.
> > > The image prints but the caption doesn't.
> > > 
> > > This affected essentially all images in a 200 page book.
> > 
> > This would be a different, althoug similar problem to what the original
> > reporter mentioned. In his problem, only part of the text following the
> > image was printed, but not the remainder. In your problem, you state that
> > the caption isn't printed.
> > 
> > Please open a separate bug report for this.
> 
> Additionally, your problem relates to printing, or exporting, to PDF, which
> is different from the problem originally reported.

In my problem, the part that was not printed was one line of text that I use as a caption, not the LO image caption (which I don't use). If I had more than one line of text, it probably would have printed part of it.

The fact that the problem exists with a PDF as well as a hard printer could help in tracking down the problem in the code; and may also indicate that it was not a printer driver problem.
Comment 10 Alex Thurgood 2015-10-01 13:17:32 UTC
(In reply to Dana Bell from comment #9)
>

@Dana

> In my problem, the part that was not printed was one line of text that I use
> as a caption, not the LO image caption (which I don't use). If I had more
> than one line of text, it probably would have printed part of it.
> 
> The fact that the problem exists with a PDF as well as a hard printer could
> help in tracking down the problem in the code; and may also indicate that it
> was not a printer driver problem.

Thanks for clearing that up. The whole LO printer configuration, OSX CUPS, and printer driver stack is a bit of a mess when it comes to LO at the moment, as the other similar bugs under "See also" indicate.

As you have provided separate confirmation, am confirming the report. Unfortunately, this may take a while before anything happens to sort it out, if the similar bug reports are anything to go by.
Comment 11 QA Administrators 2016-11-08 10:31:33 UTC Comment hidden (obsolete)
Comment 12 John 2016-11-08 16:57:24 UTC
Still happening for me with Mac OS X.11.6 and LibreOffice  5.1.6.2. Now only the first column of the text below the image is printed out on my HP 1006. Same issue with the previews as previously described.
Comment 13 tommy27 2017-07-31 10:33:01 UTC
@John 
did you try 5.3.4.2?
Comment 14 QA Administrators 2018-08-01 02:50:11 UTC Comment hidden (obsolete)
Comment 15 John 2018-08-06 17:05:46 UTC
The file I posted as an example now works for me on LO v. 6.0.5.2 with an HP LaserJet Pro 200 color printer. I no longer have the P1006 I first reported this for, so I can't test that. MacOS 10.13.6.