Bug 110752 - UI: In the auto-correct language drop down menu contains {bs}, {ca-FR} and {ca-IT} instead of a descriptive name
Summary: UI: In the auto-correct language drop down menu contains {bs}, {ca-FR} and {c...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Not-Localizable
  Show dependency treegraph
 
Reported: 2017-08-01 08:52 UTC by Telesto
Modified: 2019-08-19 06:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (79.70 KB, image/jpeg)
2017-08-01 08:53 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-08-01 08:52:55 UTC
Description:
In the auto-correct language drop down menu contains {bs}, {ca-FR} and {ca-IT} instead of a descriptive name

Steps to Reproduce:
1. Open Writer
2. Tools -> Autocorrect -> AutoCorrect Options
3. Select the replacements and exceptions for language drop down menu and scroll up. Notice that the list contains {bs}, {ca-FR} and {ca-IT}

Actual Results:  
The list contains {bs}, {ca-FR} and {ca-IT}

Expected Results:
A proper descriptive name


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 4; OS: Windows 6.2; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Telesto 2017-08-01 08:53:11 UTC
Created attachment 135043 [details]
Screenshot
Comment 2 Xisco Faulí 2017-08-01 09:03:51 UTC
In my case, I only see { es-US }

Version: 6.0.0.0.alpha0+
Build ID: e0b6a4a2d2dec4e9614f27fc03f84b1c578028ec
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 3 Xisco Faulí 2017-08-01 09:13:28 UTC
It seems it's done on purpose. Please see: https://cgit.freedesktop.org/libreoffice/core/commit/?id=bde834ee6b0cb43cebece47cac55cc9b80aadc24
Closing as RESOLVED NOTABUG
Comment 4 Telesto 2017-08-01 09:43:35 UTC
(In reply to Xisco Faulí from comment #3)
The commit does explain why the "programmatical name" is used and the position of it in the drop down menu. It's a known limitation/bug:

/* TODO: pulling descriptive names (language, script, country, subtags)
+     * from liblangtag or ISO databases might be nice, but those are English
+     * only. Maybe ICU, that has translations for language and country. */
+    return "{" + rBcp47 + "}";

Related to Comment 2: any clue why there is a difference? The "programmatical name" is only used if the visible description string is empty. So I would expect that the missing descriptive names are the same on Win Mac and Linux. Or I'm I missing something?
Comment 5 Aron Budea 2017-08-01 09:55:56 UTC
I believe there should be language names if UI language is English, the mentioned commit/comment is only relevant for other languages if translations are missing.
Comment 6 QA Administrators 2019-08-19 06:59:07 UTC
Dear Telesto,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug