Bug Hunting Session
Bug 110794 - Slower LO redraw speed with big Writer table since 5.3 (DirectWrite)
Summary: Slower LO redraw speed with big Writer table since 5.3 (DirectWrite)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks: DirectWrite-Regression
  Show dependency treegraph
 
Reported: 2017-08-01 11:47 UTC by Ingo Belka
Modified: 2017-11-27 11:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
file with table for counting votes (33.55 KB, application/vnd.oasis.opendocument.text)
2017-08-01 11:47 UTC, Ingo Belka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ingo Belka 2017-08-01 11:47:36 UTC
Created attachment 135045 [details]
file with table for counting votes

My current Version Version: 5.4.0.3 (x64) Build-ID: 556cbc6811c9d992f4064ab9287069087d7f62c CPU-Threads: 4; Betriebssystem:Windows 6.1; UI-Render: Standard; Gebietsschema: de-DE (de_DE); Calc: group

I noticed the behaviour with version 5.4.0, steped back to version 5.3.4 and the again revers to 5.4.0.

I can't process the attached file. I did worked on this file round about one year ago with LO and I had not any problems. 
Now, while loading the file LO Writer freezes and no interaction is possible anymore. 

The file contains table(s) for counting votes of an election. 

Loading in Word doesn't make any problems.

Any help is appreciated.

kind regards Ingo
Comment 1 Xisco Faulí 2017-08-01 13:52:40 UTC Comment hidden (obsolete)
Comment 2 Ingo Belka 2017-08-01 15:36:55 UTC
Thank you for your reply.

I started with a fresh user profile. It seems to me, that it does help only a little. The system needs more than 5 minutes to load the file, and while working there are a lots of stops and in the LO window headline comes constantly "no repsond". So it is impossible to work with this file. Each other file makes no problems. I started to create a new file with this content step by step, and as more I inserted LO became slower and slower. I can't see, what is bringing LO stuttering.

kind regards Ingo
Comment 3 Timur 2017-08-01 16:55:44 UTC
Freeze repro in Win with 6.0+ 32-bit and 5.4.0 64-bit. Slow also in 5.3. Looks better in 5.2.7 although not ideal.
Simple test is to restore down/resize LO window to 1/4 of size and then maximize and than again. 5.2.7 somewhat slow, 5.3.4 rather slow, 

PS I had assertion on resize.
Comment 4 bordfeldt 2017-08-01 18:28:34 UTC
Hi Timur and Ingo,

I can confirm this behaviour of writer handling documents with tables since version 5.3.3.2. Opening, scrolling and redrawing documents with tables in writer is very slow. It's sometimes so slow that working with it is nearly impossible. And this on a fast machine (Surface Pro 4 with i5 an 8GB RAM and SSD).
Ingo's example file opens so slow on my machine and scrolling is very slow too. Editing this document is impossible.
Comment 5 Ingo Belka 2017-08-03 04:56:39 UTC
As an additional informaton:

I tested the file on my privat Linux-only-pc with:

Version: 5.3.4.2, Build-ID: 1:5.3.4-0ubuntu0.14.04.1~lo0, CPU-Threads: 2; BS-Version: Linux 3.13; UI-Render: Standard; VCL: gtk2; Layout-Engine: neu;
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

There the file is loading well - not really fluent - but I can work very much better on it. It looks like as it is a greater problem on Windows and a smaller one on Linux.

kind regards Ingo
Comment 6 bordfeldt 2017-08-05 16:00:21 UTC
Today working on some documents containing tables (simple documents, only one page, simple table, containing only text, without any formatting) writer works very slowly. Simple operations like deleting and inserting rows are extremly slow. So working on those documents is very painful. So I think the importance of this bug should be set to "major".
Comment 7 Timur 2017-10-04 08:47:07 UTC
Looks like another one related to Bug 112486.
In 5.3.7 will be reverted as it was before. Can be tested with 6.0+ master libo-master~2017-10-03_23.43.39_LibreOfficeDev_6.0.0.0.alpha0_Win_x86 and later.

As I wrote, resize/maximize redraw was somewhat slow even before in 5.2 and it'll stay like that.
Comment 9 Ingo Belka 2017-11-27 10:19:03 UTC
My current version is:

Version: 5.4.3.2 (x64)
Build-ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU-Threads: 4; Betriebssystem:Windows 6.1; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group

With this version the problem is solved, thank you for your efforts.
Kind regards Ingo
Comment 10 Timur 2017-11-27 11:21:37 UTC
Thank you for testing.