Bug 110988 - Middle click does not paste primary selection
Summary: Middle click does not paste primary selection
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.1
Keywords: bibisected, bisected, regression
: 111339 112072 (view as bug list)
Depends on:
Blocks: Paste
  Show dependency treegraph
 
Reported: 2017-08-01 13:17 UTC by kyrimis
Modified: 2017-08-28 20:20 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kyrimis 2017-08-01 13:17:01 UTC
When I select some text on a terminal window and then middle click inside a LibreOffice window, the selected text is not pasted into the document. This used to work in previous versions of LibreOffice.

Tools->Options->View->Middle mouse button is set to "Paste clipboard".

Tested under OpenSUSE Tumbleweed, using both the OpenSUSE and the official builds.
Comment 1 Aron Budea 2017-08-01 13:53:18 UTC
Confirmed with LO 5.4.0.3 / Ubuntu 17.04.
Works with 5.3.1.2. => regression
Comment 2 Aron Budea 2017-08-01 14:41:23 UTC Comment hidden (bibisection)
Comment 3 Aron Budea 2017-08-01 14:42:36 UTC
This seems to be a fallout from the commit referenced below. Noel, could you please take a look?

https://cgit.freedesktop.org/libreoffice/core/commit/?id=65b7b6322b662785bf032e66c76abc36c9a2bb0e
author		Noel Grandin <noel.grandin@collabora.co.uk>	2017-02-08 08:40:28 (GMT)
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2017-02-08 12:42:52 (GMT)

"loplugin:unusedenumconstants read-only constants in vcl"
Comment 4 Aron Budea 2017-08-04 13:53:24 UTC
*** Bug 111339 has been marked as a duplicate of this bug. ***
Comment 5 Aron Budea 2017-08-13 04:05:50 UTC
Noel, would selectively reverting 65b7b6322b662785bf032e66c76abc36c9a2bb0e be the fix here? Evidently PasteSelection in MouseMiddleButtonAction was used.

Possibly the middle-mouse-button-related setting somewhere here could be changed to actually refer the enum value:
https://opengrok.libreoffice.org/xref/core/cui/source/options/optgdlg.cxx#827
Comment 6 Commit Notification 2017-08-13 19:38:50 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5b3b0a91edc4c468c7c9c132cd066c0d25de9706

tdf#110988 Middle click does not paste primary selection

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Cor Nouws 2017-08-14 07:00:43 UTC
please also backport :) thanks!
Comment 8 Rene Engelhard 2017-08-14 07:17:07 UTC
yes, please. see also https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=871588
Comment 9 kyrimis 2017-08-15 06:39:48 UTC
Just checked the daily builds.

The problem is fixed in master~2017-08-14_23.23.22_LibreOfficeDev_6.0.0.0.alpha0_Linux_x86-64

It is not fixed in
libreoffice-5-4~2017-08-14_06.48.40_LibreOfficeDev_5.4.2.0.0_Linux_x86-64

Please consider backporting to 5.4.
Comment 10 Xisco Faulí 2017-08-15 11:34:14 UTC
Cherry-picked in gerrit:
https://gerrit.libreoffice.org/#/c/41151/1
https://gerrit.libreoffice.org/#/c/41133/1
Comment 11 Commit Notification 2017-08-17 11:55:54 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a0636486e54bf9c8cf35657368e2779792da8b6d&h=libreoffice-5-4

tdf#110988 Middle click does not paste primary selection

It will be available in 5.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2017-08-22 20:58:10 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-5-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=28ed0ea234a80474065592726e05967540e8db2e&h=libreoffice-5-4-1

tdf#110988 Middle click does not paste primary selection

It will be available in 5.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Aron Budea 2017-08-28 20:20:13 UTC
*** Bug 112072 has been marked as a duplicate of this bug. ***