Bug 111341 - Writer freezes when opening DOC file with header&footer and picture
Summary: Writer freezes when opening DOC file with header&footer and picture
Status: RESOLVED DUPLICATE of bug 96840
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace
Depends on:
Blocks:
 
Reported: 2017-08-04 13:57 UTC by Jonathan Haas
Modified: 2021-06-09 11:13 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
bt with debug symbols (10.31 KB, text/plain)
2017-08-06 16:04 UTC, Julien Nabet
Details
bt at random with debug symbols (18.04 KB, text/plain)
2017-08-10 20:35 UTC, Julien Nabet
Details
Document that causes hang (822.50 KB, application/msword)
2019-12-11 09:50 UTC, Jonathan Haas
Details
Document reduced - 2 pages DOC (93.00 KB, application/msword)
2019-12-11 13:13 UTC, Timur
Details
Flamegraph (183.05 KB, application/x-bzip)
2020-01-27 21:00 UTC, Julien Nabet
Details
Document reduced - 2 pages DOCX (64.06 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-10-08 09:26 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Haas 2017-08-04 13:57:44 UTC
Description:
Writer freezes when opening the following file: http://nerz-ev.de/download/software-dokumente/02500-03_ArS/TAnf_Ars_FREI_V3.0_D2009-11-23.doc

Steps to Reproduce:
1. Open http://nerz-ev.de/download/software-dokumente/02500-03_ArS/TAnf_Ars_FREI_V3.0_D2009-11-23.doc


Actual Results:  
1. Warning about macros
2. Freeze after clicking OK

Expected Results:
1. Warning about macros
2. Document opened


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.78 Safari/537.36
Comment 1 MM 2017-08-04 22:40:45 UTC
Confirmed with Version: 5.1.6.2
Build ID: 07ac168c60a517dba0f0d7bc7540f5afa45f0909
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: single


Confirmed with Version: 6.0.0.0.alpha0+
Build ID: e0bafa78e3ad0df397d78cd65ad19bd5b07dc5f2
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-07-20_22:42:49
Locale: en-US (en_US.UTF-8); Calc: single

Somehow the 'Warning about macros' isn't shown on v6, just a freeze.
Comment 2 Julien Nabet 2017-08-06 15:39:27 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

I noticed this trace on console:
warn:legacy.osl:5840:1:vcl/source/window/errinf.cxx:177: Error not handled
Comment 3 Julien Nabet 2017-08-06 16:04:41 UTC
Created attachment 135194 [details]
bt with debug symbols

I attached a bt from the console trace I got (see my previous comment) + some gdb
Comment 4 Julien Nabet 2017-08-06 16:05:51 UTC
Let's increase a bit the importance since:
- it concerns all envs
- it prevents people from opening the file

a bit because seems only specific on a file.
Comment 5 Timur 2017-08-08 10:49:41 UTC
Looks inherited. This is lazy man reporting and confirming.. we should try to make a minimum test case by reducing this doc. 
At least it doesn't hang if header is removed. 
I wouldn't be surprised if it were similar to Bug 65881 or Bug 37146.
Comment 6 Julien Nabet 2017-08-10 20:35:00 UTC
Created attachment 135434 [details]
bt at random with debug symbols

I attached bt from a random break during hanging.

It seems a layout issue.
Comment 7 Julien Nabet 2017-08-10 21:37:58 UTC
Michael: on a gdb session, I noticed I'm stuck here:
     44         while ( pTmp && pTmp != pObj )
     45             pTmp = pTmp->GetPrev();
which corresponds to frame 1 of my 2nd bt attached.
I don't know if it's layout or cache related but thought you might be interested in this one.
Comment 8 QA Administrators 2018-08-11 02:36:46 UTC Comment hidden (obsolete)
Comment 9 Timur 2018-08-14 13:08:27 UTC Comment hidden (obsolete)
Comment 10 Timur 2019-12-11 09:48:14 UTC Comment hidden (obsolete)
Comment 11 Jonathan Haas 2019-12-11 09:50:56 UTC
Created attachment 156473 [details]
Document that causes hang

Attached.

Also can still reproduce with libreoffice-writer-6.3.3.2-7.fc31.x86_64
Comment 12 Timur 2019-12-11 13:13:03 UTC Comment hidden (obsolete)
Comment 13 Julien Nabet 2020-01-27 21:00:30 UTC
Created attachment 157466 [details]
Flamegraph
Comment 14 Xisco Faulí 2020-01-30 11:16:28 UTC
Although it's a hang, it's just happening with a particular file + Inherit from OOo. Decreasing importance
Comment 15 Xisco Faulí 2020-01-30 11:39:07 UTC
Actually it opens after

real	8m0,484s
user	7m55,930s
sys	0m1,484s


Version: 7.0.0.0.alpha0+
Build ID: 447e4209fa16e765d9cba9f1c80bf10e8901204c
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Noel, I thought you might be interested in this issue...
Comment 16 Timur 2020-10-08 09:26:01 UTC
Created attachment 166179 [details]
Document reduced - 2 pages DOCX

(In reply to Timur from comment #12)
> Created attachment 156488 [details]
> Document reduced - 2 pages DOC

> Note: DOCX opens as 260 pages in 7.0+, but with differences and already reported
> pagination issue.

I attach here MSO created DOCX (3 pages in MSO) which now opens in LO 7.1+.
DOC repro 7.1+, so bug remains for DOC.
Comment 17 Timur 2021-06-09 10:27:56 UTC
Original DOC attachment 156473 [details] fixed in 7.2+:

commit ba698a8561700f503cdd7a5cb0bc83d6eaf4222b
Date:   Fri May 21 08:16:39 2021 +0200
    source sha:798b69087119c01a3b51e0bb3240ef35cfededeb
    previous sha:fb5247bf587518eaa01cf5d54dceddf73827d740

author	Daniel Arato (NISZ) <arato.daniel@nisz.hu>	2021-03-24 20:18:16 +0100
committer	László Németh <nemeth@numbertext.org>	2021-05-21 08:00:33 +0200
commit 798b69087119c01a3b51e0bb3240ef35cfededeb (patch)
tree a498de98b34bacf760b208d3cc650c2a2f68ae58
parent fb5247bf587518eaa01cf5d54dceddf73827d740 (diff)
tdf#104254 sw DOCX import: fix text wrapping in headers

LO opens 92 pages and MSO 82 pages (content is not in this bug, can be compared and specific differences searched in other bugs).

Also fixed reduced 2 page DOC attachment 156488 [details].

*** This bug has been marked as a duplicate of bug 96840 ***