Download it now!
Bug 111431 - Create Form with tabs (dialog in notebook style)
Summary: Create Form with tabs (dialog in notebook style)
Status: RESOLVED DUPLICATE of bug 37134
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-07 10:03 UTC by c.buhtz
Modified: 2019-03-12 16:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description c.buhtz 2017-08-07 10:03:45 UTC
When creating a Form for a table/view it would be nice to have "tabs" (sometimes it is called notebook) here.
Some tables are quite wide so not all fields fitting to one screen. Sometimes scrolling is not the wish. So tabs would be a nice solution.

MS Access support this.
Comment 1 Alex Thurgood 2017-08-09 14:55:30 UTC
FileMakerPro also offers this, as did Lotus Approach (Bento for MacOS did as well) - it seems to be quite a common UI paradigm. 

My understanding was that this something similar to what you want is already possible via the Basic IDE using the controls available there, but that is not the same things as a multi-tabbed form.

The problem is that a form is a Writer document, irrespective of whether it is stored within an ODB file or outside thereof. As Writer documents don't support multi-tab views, it seems unlikely that what you want is ever going to happen.

I am personally in favour of such a possibility, but as I'm not a coder, I won't be the one making it happen, nor do I have much idea of what kind of investment (in terms of coding, respect for ODF format obligations, etc) implementing your suggestion would represent.
Comment 2 Alex Thurgood 2017-08-09 15:02:15 UTC
Seems that what you would like, or at least something very similar, has already been requested (thought so, as I used to use Lotus Smartsuite and missed this feature too) - see bug 33173 - marking this as a duplicate of that.

*** This bug has been marked as a duplicate of bug 33173 ***
Comment 3 V Stuart Foote 2019-03-12 16:48:44 UTC
QA housekeeping adjusting the duplicate to bug 37134 from bug 33173

*** This bug has been marked as a duplicate of bug 37134 ***