Bug 111739 - Selecting a custom character as a bullet symbol inserts the symbol into the document
Summary: Selecting a custom character as a bullet symbol inserts the symbol into the d...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0 target:6.1.0
Keywords: bibisected, bisected, difficultyBeginner, easyHack, regression, skillCpp
: 112222 (view as bug list)
Depends on:
Blocks: Bullet-Numbering-Dialog Special-Character
  Show dependency treegraph
 
Reported: 2017-08-12 18:01 UTC by Tamás Zolnai
Modified: 2017-11-29 16:24 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2017-08-12 18:01:14 UTC
Description:
We can specify any character as bullating symbol on Customize tab page of bulleting character. The issue is that when I click to select such a character, the Special Character dialog comes up where the selected character can be applied by clicking on Insert button. With clicking the insert button the bullet symbol is set, but also the selected sybmol is inserted into the document.

Steps to Reproduce:
1. Open Impress
2. Click into title shape
3. Open numbering dialog (context menu -> Bullets and Numbering... -> Customize)
4. Click on custom character selection button (Characeter: Selection...)
5. Select a character and click insert

Actual Results:  
Not only the bullet symbol is selected but also the selected character is inserted into the document.

Expected Results:
The uselss insertion of the special character should be avoided.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.90 Safari/537.36
Comment 1 Xisco Faulí 2017-08-15 17:43:58 UTC
Reproduced in

Version: 6.0.0.0.alpha0+
Build ID: ef2e6260fad38e26c8591ea88ded348db618270d
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.10; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)
Comment 2 Xisco Faulí 2017-08-16 00:27:22 UTC
Regression introduced by:

author	Akshay Deep <akshaydeepiitr@gmail.com>	2017-05-11 07:57:38 (GMT)
committer	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2017-06-19 12:36:32 (GMT)
commit	710a39414569995bd5a8631a948c939dc73bcef9 (patch)
tree	e3da87fd9012713605004e8bd20ca2b98df45ac5
parent	cacb75aa0bea36d4e5fc083a75a8b376133d3d65 (diff)
GSoC: Glyph View and Recent Characters Control in Special Characters dialog

Bisected with bibisect-linux64-6.0

Adding Cc: to Akshay Deep
Comment 3 Tamás Zolnai 2017-08-24 17:55:20 UTC
Let's turn this into an easy hack. The code is here:
cui/source/dialogs/cuicharmap.cxx
InsertClickHdl might be a good starting point.

Check also the commit which caused this regression:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=710a39414569995bd5a8631a948c939dc73bcef9

I guess it would also be good to change the 'Insert' button's text to 'OK', when the dialog is opened from bullets and numbering dialog and the symbol is not inserted into the document.
Comment 4 Regina Henschel 2017-09-05 15:03:42 UTC
*** Bug 112222 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2017-09-25 23:08:41 UTC
Daniel committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4020945651b4f3c636980e2103db440b5c55459c

tdf#111739 fix Selecting a custom character as a bullet symbol insertion

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2017-11-29 16:24:58 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=67eeab179a7e1d8b479d08a38093172531d4c3c9

Related tdf#111739: Don't insert special character into the document

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.