Bug Hunting Session
Bug 111859 - FILESAVE: errors when saving to PPT/X - shrink text to fit box attribute lost
Summary: FILESAVE: errors when saving to PPT/X - shrink text to fit box attribute lost
Status: RESOLVED DUPLICATE of bug 90407
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:ppt, filter:pptx
Depends on:
Blocks: PPTX PPT
  Show dependency treegraph
 
Reported: 2017-08-16 11:49 UTC by Elmar
Modified: 2018-08-09 17:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ppt textbox not shrinking (489.00 KB, application/vnd.ms-powerpoint)
2018-05-30 05:15 UTC, Elmar
Details
odp source file (for reference) (297.15 KB, application/vnd.oasis.opendocument.presentation)
2018-05-30 05:16 UTC, Elmar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elmar 2017-08-16 11:49:45 UTC
See Bug 111848
Has example files attached

When shrink text to fit box, this is lost in PPTX 

To fix, I choose appropriate Master page (in Powerpoint), then they all come right when I click on the box in one of the slides.
Comment 1 Xisco Faulí 2017-08-16 16:54:18 UTC
Thank you for reporting the bug.
Unfortunately without clear steps to reproduce it, we cannot track down the origin of the problem.
Please provide a clearer set of step-by-step instructions on how to reproduce the problem.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the steps are provided
Comment 2 Elmar 2017-08-17 05:40:42 UTC
1. Create presentation in Impress.
2. Save to PPT
3. Save to PPTX
4. Open PPT with Powerpoint, slide 13 has lost setting to shrink text on overflow
5. View Master
6. Both Slide Title and text box are "do not autofit"
7. Set both to "shrink"
8. close master
9. happiness restored

10. open PPTX in Powerpoint
11. The "shrink" was not lost.
12. select one of the "unshrunk" slides (e.g. 10)
13. apply master to it
14. all the slides come right.
(This may be a powerpoint problem and not Impress)
Comment 3 Elmar 2017-08-19 06:30:30 UTC
Have verified that get same result in LO v6
Version: 6.0.0.0.alpha0+
Build ID: 79611a44fac472dfa5f0a01c051c314078f798b9
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-08-17_22:53:56
Locale: en-ZA (en_ZA.UTF-8); Calc: group
Comment 4 Jacques Guilleron 2017-08-20 10:31:45 UTC
Hi elmar,

Autofit isn't set when PPT and PPTX versions of your file are open with MS wiewer or Powerpoint.
Tried saving with
LO 6.0.0.0.alpha0+ Build ID: 88179e3de8865ea07d5017ca0723afd10ad44ba7
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-08-06_23:49:25
Locale: fr-FR (fr_FR); Calc: group
and
LO 5.4.0.3 (x64) Build ID: 92c2794a7c181ba4c1c5053618179937228ed1fb
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: single
Reopened with LibreOffice, all is fine.
Comment 5 Elmar 2018-05-30 05:07:16 UTC
I have added a new example file.

When I open it in LO (now 6.1 alpha) it displays fine. But when I open it in MSPowerpoint the shrink text is lost.

However, if I save the LO file to PPTX, then the shrink text is working.
Comment 6 Elmar 2018-05-30 05:15:42 UTC
Created attachment 142394 [details]
ppt textbox not shrinking
Comment 7 Elmar 2018-05-30 05:16:52 UTC
Created attachment 142395 [details]
odp source file (for reference)
Comment 8 Elmar 2018-05-30 05:17:48 UTC
Note: if you open the PPT with Impress, then the text does shrink.
Comment 9 Timur 2018-08-09 17:00:50 UTC
Looks like duplicate of Bug 90407
Same results, in MSO PPT not shrinking and PPTX shrinking too much.
If you consider this not a duplicate, please explain.

*** This bug has been marked as a duplicate of bug 90407 ***