Bug 111878 - LO5403rel&5411rc1: In Calc localized function descriptions and data types are in English
Summary: LO5403rel&5411rc1: In Calc localized function descriptions and data types are...
Status: RESOLVED DUPLICATE of bug 109258
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-17 08:59 UTC by Martin Srebotnjak
Modified: 2017-08-25 19:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
English strings instead of Slovenian ones displayed (55.67 KB, image/png)
2017-08-17 09:03 UTC, Martin Srebotnjak
Details
Cell data types in English (32.39 KB, image/png)
2017-08-17 09:04 UTC, Martin Srebotnjak
Details
Function wizard (44.60 KB, image/png)
2017-08-25 19:21 UTC, Jacques Guilleron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2017-08-17 08:59:22 UTC
Description:
In Calc on OSX even though it is 100 % localized in Slovenian there are data types (like General, Number etc.) displayed in English, and all the function descriptions are in English (if you invoke the funcition dialog).
Also some dialogs have English titles.
But Calc and LO is 100 % localized in Slovenian.

Steps to Reproduce:
1. Open Calc
2.
3.

Actual Results:  
In English.

Expected Results:
In Slovenian.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:54.0) Gecko/20100101 Firefox/54.0
Comment 1 Martin Srebotnjak 2017-08-17 08:59:59 UTC
I hope someone will look into this.
Comment 2 Martin Srebotnjak 2017-08-17 09:03:00 UTC
Created attachment 135610 [details]
English strings instead of Slovenian ones displayed

As you can see, English strings are shown instead of Slovenian ones.
I guess this is from helpcontent2, from calc/01.po, which is fully localized and was updated just a week or two before the release.
But data types strings are from other po files, so there might be some other issue at hand.
Comment 3 Martin Srebotnjak 2017-08-17 09:04:45 UTC
Created attachment 135611 [details]
Cell data types in English

These should be in Slovenian (as they were still in 5.4 beta 2).
Comment 4 Alex Thurgood 2017-08-17 11:14:12 UTC

*** This bug has been marked as a duplicate of bug 111332 ***
Comment 5 sophie 2017-08-17 11:45:25 UTC
Hi Alex, I'm reopening the bug because it's not a duplicate, we are currently investigating where the problem is. Sophie
Comment 6 sophie 2017-08-17 11:55:09 UTC
Changing status - Sophie
Comment 7 Jacques Guilleron 2017-08-25 19:15:56 UTC
Hi miles,

I get the same issues you show in your sreenshots with LO 5.4.0.3 on Windows 7.
These are corrected in LO 5.3.6.1 available at
http://dev-builds.libreoffice.org/pre-releases/
Can you try it?
I join a sreenshot taken in slovenian UI on LO 5.3.6.1 Windows 7 

Jacques
Comment 8 Jacques Guilleron 2017-08-25 19:21:22 UTC
Created attachment 135800 [details]
Function wizard
Comment 9 Martin Srebotnjak 2017-08-25 19:23:05 UTC
Hi, the reason for this is now known, as it is described more widely in bug 109258.
It is not corrected in 5.3.6.1, as those po files did not massively change until the 5.4 was released. So it will be fixed, presumably, with 5.4.1.2.
So I am closing this bug as a duplicate of bug 109258.

*** This bug has been marked as a duplicate of bug 109258 ***