Bug Hunting Session
Bug 111980 - ActiveX radio buttons' group is not imported from DOCX file
Summary: ActiveX radio buttons' group is not imported from DOCX file
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0 target:6.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-23 09:17 UTC by Tamás Zolnai
Modified: 2018-10-11 07:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
radioButtons_duelingGroupBoxes.xlsx: GroupBoxes affecting form radiobuttons (9.81 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-09-29 13:01 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2017-08-23 09:17:09 UTC
Description:
With the commit added for Bug 91384 ActiveX buttons are imported now as LO form controls, but the radio button grouping is not imported, so when selecting one item of a group others are not unchecked.

Steps to Reproduce:
1. Open attachment 115706 [details] from Bug 91384
2. Design mode should be disabled (Edit -> Design mode)
3. Click on radion buttons in the same group (page 5)

Actual Results:  
Radio buttons are not grouped so user can select more radio buttons at the same time in the same group.

Expected Results:
Group should be preserved.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.101 Safari/537.36
Comment 1 Timur 2017-08-23 09:49:31 UTC
Similar with DOCM attachment 127385 [details] from Bug 102243. So New.
Comment 2 Tamás Zolnai 2017-08-24 17:37:31 UTC
ActiveX handling code is here:
oox/source/ole/axcontrol.cxx
AxOptionButtonModel is the class which handles radio buttons.
Comment 3 Commit Notification 2017-08-26 16:32:56 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e463c96092e108a8fad3b9a91b693457f3c26545

tdf#111980: DOCX: Handle ActiveX radio button group

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Timur 2017-08-28 12:57:57 UTC Comment hidden (me-too)
Comment 5 Timur 2017-09-21 16:59:09 UTC Comment hidden (obsolete)
Comment 6 Tamás Zolnai 2017-09-21 19:29:43 UTC
(In reply to Timur from comment #5)
> Tamas was not in CC nor Assignee so I repeat:
> Please consider to backport this fix and from Bug 91384.

Hi Timur,
I reported the bug, so I saw your comment. I considered to backporting my ActiveX control related changes, but it seemed too risky to do that. For example an issue already came up related to my changes (bug 112519).
Comment 7 Commit Notification 2018-09-28 07:58:26 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9f969799629fe6bdf8b922d8cb922846aa646ece

tdf#111980 oox: connect empty radio groups

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Justin L 2018-09-29 13:01:20 UTC
Created attachment 145264 [details]
radioButtons_duelingGroupBoxes.xlsx: GroupBoxes affecting form radiobuttons

The first created box seems to win out. https://gerrit.libreoffice.org/61131
Comment 9 Tamás Zolnai 2018-09-29 13:07:58 UTC
(In reply to Justin L from comment #8)
> Created attachment 145264 [details]
> radioButtons_duelingGroupBoxes.xlsx: GroupBoxes affecting form radiobuttons
> 
> The first created box seems to win out. https://gerrit.libreoffice.org/61131

Hi Justin,

It would be good to create a separate bug for the issue you are workging on. On this way it's a bit confusing what is your patch is about. I mean this bug was already closed as fixed and this bug was about groups specified for ActiveX radio buttons. As I see you working on ungrouped buttons. I think it would be good to create a separate bug for it with an own test document etc, so later it will be easier to see what the issue was and what the fix was about.
Comment 10 Justin L 2018-09-29 17:23:50 UTC
(In reply to Tamás Zolnai from comment #9)
These are direct followups and some of it exactly applies to the original bug report. For example a blank group is still a group for MSWord/Excel (even for ActiveX), but it isn't in LO. Whether it is ActiveX or Form, to an end user a radio button is a radio button, so it seemed to make sense to lump it all together since only technicalities make it different. Take out the words ActiveX and DOCX and all of this fits perfectly.

On top of that, at minimum you should be aware of this work, and ideally you would be reviewing the patches since you probably are the most qualified based on your past work.
Comment 11 Tamás Zolnai 2018-09-29 17:27:17 UTC
(In reply to Justin L from comment #10)
> (In reply to Tamás Zolnai from comment #9)
> These are direct followups and some of it exactly applies to the original
> bug report. For example a blank group is still a group for MSWord/Excel
> (even for ActiveX), but it isn't in LO. Whether it is ActiveX or Form, to an
> end user a radio button is a radio button, so it seemed to make sense to
> lump it all together since only technicalities make it different. Take out
> the words ActiveX and DOCX and all of this fits perfectly.
> 
> On top of that, at minimum you should be aware of this work, and ideally you
> would be reviewing the patches since you probably are the most qualified
> based on your past work.

Ok, you do whatever you want. In general we like to create separate bugs for separate use cases to make tracking issues easier.
Comment 12 Tamás Zolnai 2018-09-29 17:35:11 UTC
https://wiki.documentfoundation.org/QA/BugReport#Submitting_a_bug

First sentence: "File a separate bug report for each bug you run into, even if the symptoms from a user’s point of view seem identical."
Comment 13 Commit Notification 2018-09-29 18:27:10 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a7756236858788b11816cbaba433768ba4ccc72a

tdf#111980 sc optionbutton autoGroups different for form/activeX

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2018-10-11 07:48:42 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=048b8e45813f6a19a4ff56e1d676fe9450325cd2

tdf#111980 oox optionbutton autoGroup inside GroupBox

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.