Bug Hunting Session
Bug 112056 - EDITING: When replacing a word which is partly formatted, the formatting at the end of the word is used and not that of the beginning
Summary: EDITING: When replacing a word which is partly formatted, the formatting at t...
Status: RESOLVED DUPLICATE of bug 107857
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-27 10:15 UTC by Telesto
Modified: 2017-08-28 09:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example file (9.68 KB, application/vnd.oasis.opendocument.text)
2017-08-27 10:15 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-08-27 10:15:14 UTC
Description:
When replacing a word which is partly formatted, the formatting at the end of the word is used and not that of the beginning. This is different compared to MS Word or Google Docs and at least unexpect and more or less illogical: why should I use start a Word in the formatting used at the ending of the previous one?

The textbox variant behaves a little bit better (bit is also inconsistent)

Steps to Reproduce:
1. Open the attached file 
2. Select 'AAABBB' and replace it. Bold formatting will be lost
3. Select 'AAACCC' and replace it. Notice that the formatting will be pink, cursive and bold
4. Select 'AAADDD ' including the spacing). Start typing: text will be green

5. Repeat step for the textbox variant; notice a different behavior

Actual Results:  
The formatting at the ending of a Word is used, not that of the beginning

Expected Results:
Use the formatting at the beginning of the replaced Word. Like other applications do.


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 6.0.0.0.alpha0+
Build ID: 02c53f744ed23e2149fc7c83d67cb7d8aa5eb0ed
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-08-24_05:48:55
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Telesto 2017-08-27 10:15:35 UTC
Created attachment 135818 [details]
Example file
Comment 2 Regina Henschel 2017-08-27 13:20:05 UTC
Likely duplicate to bug 107857.
Comment 3 Telesto 2017-08-28 07:14:12 UTC
Didn't think about that one :-)

*** This bug has been marked as a duplicate of bug 107857 ***