Bug 112117 - Hyperlink dialog window is too wide
Summary: Hyperlink dialog window is too wide
Status: RESOLVED MOVED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: easyHack
: 112875 (view as bug list)
Depends on:
Blocks: Hyperlink-Dialog
  Show dependency treegraph
 
Reported: 2017-08-30 21:29 UTC by lukash256
Modified: 2019-02-04 16:24 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
ScreenShot of Huperlink form (3.07 MB, image/png)
2017-09-01 13:02 UTC, lukash256
Details
Shows previously selected link that may cause the long form size. (278.59 KB, image/png)
2017-11-14 13:25 UTC, Buck
Details
Dialog Hyperlink by default (40.85 KB, image/png)
2018-11-15 06:24 UTC, Roman Kuznetsov
Details
Screenshot with size info (66.62 KB, image/png)
2018-11-15 08:03 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lukash256 2017-08-30 21:29:42 UTC
Description:
From version to version this bug exists.
I am using two monitors(1280x1024 on left and 1920x1200 on right) arranged horizontally. Hyperlink form from Insert > Hyperlink... always opens toooo wide and there is no chance to make it narrowly. Very uncomfortable.

Steps to Reproduce:
0.connect two monitors 
1.Open LibreOffice writer
2.Start new doc
3.do Insert > Hyperlink

Actual Results:  
form Hyperlink opens too wide and there is no opportunity to make it narrowly.

Expected Results:
to have a possibility to make this this form narrowly.


Reproducible: Always

User Profile Reset: No

Additional Info:
x86_64 Centos 7.3


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36
Comment 1 Jean-Baptiste Faure 2017-08-31 07:14:39 UTC
What is "too wide" ? Could you give more precise data?
A screen copy could be fine.

Set status to NEEDINFO, please set it back to UNCONFIRMED once requested
informations are provided.

Best regards. JBF
Comment 2 lukash256 2017-09-01 13:02:39 UTC
Created attachment 135928 [details]
ScreenShot of Huperlink form

LibreOffice is in fullscreen mod on the left monitor at 1280x1024 and hyperlink form is in the minimum size.
Comment 3 Buovjaga 2017-09-10 17:33:50 UTC
Weird.. does this only occur with 2 monitors plugged in?
For me it appears in the minimum size and I can drag it to be wider.
However, I do note that the min. width is smaller in a master build.

So you might want to try a daily build from here (the quickest way): http://libreoffice.soluzioniopen.com/

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.1.2.0+
Build ID: 5.4.1-1
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: 09122a537318f7ada075820f3b1ef83a64e56751
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on September 10th 2017
Comment 4 lukash256 2017-09-11 14:19:50 UTC
Thanks for sunday reply! 
I tried to use daily builds 5.4.1.1 and 6.0.0.0.alpha0+, as you advised and this trouble is gone. I found that daily builds use different locations to store there settings and I removed my local settings from ~/.config/libreoffice/4. This bug is gone.

thank you and have a nice day.
Comment 5 Adolfo Jayme 2017-10-09 22:23:51 UTC
*** Bug 112875 has been marked as a duplicate of this bug. ***
Comment 6 Buck 2017-11-14 13:25:51 UTC
Created attachment 137748 [details]
Shows previously selected link that may cause the long form size.

I had this problem with an earlier release. At that time the dialog box was even longer than this one extending past the edge of both monitors.  I don't know how it resolved itself.

However, this morning, the problem returned. When I started to add a new link, I noticed that a previous link I used was very long.  I am assuming that the dialog minimum length is set to the length required to show the longest link it remembers. 

As I am writing this, I am realizing that the two shown links are the only two links I have used since updating to this version: 5.2.7.2.  So, I think the resolution to the oversized box came with the update wiping out the history. (Or I may have wiped out the history with CCleaner.)

I have attached an image that shows the long and shorter links.  When I entered the shorter link a few days ago, I did not have this problem.  However, when I opened it today, after having inserted the longer link before, there it is again.
Comment 7 Buovjaga 2017-11-14 14:06:47 UTC
Buck: use version 5.4 and do a profile reset https://wiki.documentfoundation.org/UserProfile
Comment 8 Yousuf Philips (jay) (retired) 2017-11-14 14:23:19 UTC
I see this with the master updater build, with a profile that i've only been using for the last 3 months, so this is an issue that needs to be addressed.

Version: 6.0.0.0.alpha1+
Build ID: 9050854c35c389466923f0224a36572d36cd471a
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 9 QA Administrators 2018-11-15 03:43:52 UTC Comment hidden (obsolete)
Comment 10 Roman Kuznetsov 2018-11-15 06:23:12 UTC
by default dialog Hyperlink has size 1472x512 px in LO 6.2. 
For some monitors (with 1024x768 or 1366x768) it's very wide size.

I offer make dialog less wide, may be 1000x512. I think it will be easy.

Heiko, what do you think?
Comment 11 Roman Kuznetsov 2018-11-15 06:24:17 UTC
Created attachment 146643 [details]
Dialog Hyperlink by default
Comment 12 Heiko Tietze 2018-11-15 08:03:49 UTC
Created attachment 146647 [details]
Screenshot with size info

Sounds like a familiar issue. And in fact the dialog looks good on my system with 793x467px. Typically dialogs resize depending on the content, meaning if a control in another tab requires 2000px the whole dialog gets this size. 

Version: 6.1.3.2
Build ID: 6.1.3-1
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: de-DE (en_US.UTF-8); Calc: group threaded
Comment 13 Xisco Faulí 2018-11-15 10:51:14 UTC
@Caolán, is it possible to limit the max size of a dialog to avoid this kind of problems?
Comment 14 Roman Kuznetsov 2018-11-15 11:25:48 UTC
(In reply to Roman Kuznetsov from comment #10)
> by default dialog Hyperlink has size 1472x512 px in LO 6.2. 
> For some monitors (with 1024x768 or 1366x768) it's very wide size.
> 
> I offer make dialog less wide, may be 1000x512. I think it will be easy.
> 
> Heiko, what do you think?

but after deleting of user profile I can't repro it in 6.2, dialog looks relative compact
Comment 15 Caolán McNamara 2018-11-15 13:15:32 UTC
Does anyone have a route to reproduce ?, shouldn't be too hard to limit the width of the widget that's over-growing, but a quick attempt doesn't reproduce
Comment 16 Dieter 2019-02-02 16:26:46 UTC
Width has changed:

LO 6.1.5.2   22 cm
LO 6.3.0.0   16 cm

Is this the solution? Bug 123123 argues, that it is too small. Perhaps we can merge the two bug reports, because they're dealing with the same topic: find the best width.
Comment 17 Heiko Tietze 2019-02-04 16:24:58 UTC
(In reply to Dieter Praas from comment #16)
> Width has changed:
> 
> LO 6.1.5.2   22 cm
> LO 6.3.0.0   16 cm
> 
> Is this the solution? Bug 123123 argues, that it is too small. Perhaps we
> can merge the two bug reports, because they're dealing with the same topic:
> find the best width.

Good idea. Ideally we have a sane default (no idea about cm but 600px with 96dpi sounds reasonable), allow to resize and remember the last height/width.