Bug 112153 - macOS 10.13 High Sierra - all buttons are blue ("default")
Summary: macOS 10.13 High Sierra - all buttons are blue ("default")
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0 target:6.0.0 target:5.4.5
Keywords:
: 113910 115145 (view as bug list)
Depends on:
Blocks: MacOS-UI
  Show dependency treegraph
 
Reported: 2017-08-31 20:35 UTC by Pete K.
Modified: 2018-01-25 09:28 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
About box on 10.13 (72.69 KB, image/png)
2017-08-31 20:35 UTC, Pete K.
Details
About box on 10.12 (working ok) (117.07 KB, image/png)
2017-08-31 20:36 UTC, Pete K.
Details
Buttons blue in all menus (67.81 KB, image/png)
2017-09-15 16:55 UTC, impreza233
Details
Patch proposal (590 bytes, text/plain)
2018-01-17 15:34 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pete K. 2017-08-31 20:35:55 UTC
Created attachment 135917 [details]
About box on 10.13

Overview:  When running on macOS 10.13 ("High Sierra") beta, all buttons in modal dialog boxes are highlighted in blue (as if they are *all* default buttons).

Steps to Reproduce:  

1.  Run macOS 10.13 beta.
2.  Launch LibreOffice.
3.  Choose "About LibreOffice" from the LibreOffice menu.

Actual Results:

Three buttons at bottom of panel are all blue.  See attached screenshot "about-box.png".

Expected Results:

One button ("Close") should be blue; the rest should be uncolored.  See attached screenshot "about-box-ok.png" from same LibreOffice version running on macOS 10.12.6 ("Sierra").

Additional Information:

Note that the "About" box is used only as an example; several other modal dialogs exhibit same behavior.
Comment 1 Pete K. 2017-08-31 20:36:25 UTC
Created attachment 135918 [details]
About box on 10.12 (working ok)
Comment 2 Pete K. 2017-08-31 20:37:09 UTC
Note:  Version is actually 5.4.1.2, but this is not an option in the selector.
Comment 3 Alex Thurgood 2017-09-04 08:13:10 UTC
I don't test with Mac OS betas, so am unable to reproduce.
Comment 4 impreza233 2017-09-15 16:55:11 UTC
Created attachment 136269 [details]
Buttons blue in all menus
Comment 5 impreza233 2017-09-15 16:56:23 UTC
Buttons are blue in all menus, not only in "About" menu. I can confirm this behaviour, in the same version of Libreoffice (5.4.1.2).
Comment 6 Alex Thurgood 2017-09-29 14:03:32 UTC
Confirming with HighSierra GA :

Version: 5.4.1.2
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU threads: 4; OS: Mac OS X 10.13; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group
Comment 7 Alex Thurgood 2017-09-29 14:06:01 UTC
It is even worse than reported.

When switching contexts (eg. Spaces), the buttons are initially coloured grey, and then within a few microseconds all become deep blue.
Comment 8 Alex Thurgood 2017-09-29 14:08:26 UTC
And...it really contrasts with the Finder dialog, in which only one button is pre-selected (and is blue), whereas the other buttons in the dialog are white...
Comment 9 mynothaur 2017-10-23 10:51:38 UTC
confirm this bug on high sierra
Comment 10 mynothaur 2017-10-23 10:52:43 UTC
same bug on libreoffice 5.3.6.1
Comment 11 Xisco Faulí 2017-11-15 22:08:34 UTC
also reproduced in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 8; OS Version: Mac OS X 10.13.1; UI Render: default; 
Locale: en-US (en_ES.UTF-8)
Comment 12 Telesto 2017-11-15 23:28:18 UTC
Is this really a regression? I would expect a regression to be an issue caused by a change in the LibO code.. A regression caused by some sort of incompatibility with High Sierra is not a regression in the sense of the keyword meaning; i think.
Comment 13 Telesto 2017-11-18 15:29:59 UTC
*** Bug 113910 has been marked as a duplicate of this bug. ***
Comment 14 Telesto 2017-11-18 15:36:36 UTC
@Xisco
I might have a solution. Moving "case ButtonValue::DontKnow:" (
https://opengrok.libreoffice.org/xref/core/vcl/osx/salnativewidgets.cxx#113) between the current lines 108-109 -> resulting in return kThemeButtonOff; will resolve the issue.
Comment 15 Xisco Faulí 2017-11-18 16:16:53 UTC
(In reply to Telesto from comment #14)
> @Xisco
> I might have a solution. Moving "case ButtonValue::DontKnow:" (
> https://opengrok.libreoffice.org/xref/core/vcl/osx/salnativewidgets.cxx#113)
> between the current lines 108-109 -> resulting in return kThemeButtonOff;
> will resolve the issue.

Could you please submit a patch to Gerrit as described here:
https://wiki.documentfoundation.org/Development/gerrit/SubmitPatch?
Comment 16 Xisco Faulí 2018-01-13 17:44:40 UTC
*** Bug 114989 has been marked as a duplicate of this bug. ***
Comment 17 clemens.brunner 2018-01-16 09:15:03 UTC
Any chance this will get integrated into LO 6? I just tested this with 6.0.0RC2 and the  issue hasn't been fixed.

Version: 6.0.0.2
Build ID: 06b618bb6f431d27fd2def25aa19c833e29b61cd
CPU threads: 8; OS: Mac OS X 10.13.2; UI render: GL; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 18 Telesto 2018-01-17 15:34:58 UTC
Created attachment 139153 [details]
Patch proposal

Same as comment 14. Working as expect with Sierra and High Sierra
Comment 19 Xisco Faulí 2018-01-17 15:37:11 UTC
(In reply to Telesto from comment #18)
> Created attachment 139153 [details]
> Patch proposal
> 
> Same as comment 14. Working as expect with Sierra and High Sierra

Hi Telesto,
Please submit the patch to gerrit for review ;-)
Comment 20 Alex Thurgood 2018-01-22 11:02:20 UTC
*** Bug 115145 has been marked as a duplicate of this bug. ***
Comment 21 Tor Lillqvist 2018-01-22 14:53:41 UTC
I submitted it for Telesto: https://gerrit.libreoffice.org/#/c/48334/

Thanks! This misfeature has been annoying me for a while whenever I run LO on my Mac.
Comment 22 Commit Notification 2018-01-23 08:21:04 UTC
Telesto committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=44af50465a02b6f5566be45913a34fdbdba90133

tdf#112153: Set button theme properly

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2018-01-23 13:15:33 UTC
Telesto committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2b6db99279fcfbbe3ba3720f92c36b8ecd49635a&h=libreoffice-6-0

tdf#112153: Set button theme properly

It will be available in 6.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Telesto 2018-01-23 19:09:09 UTC
Maybe also a backport to 6.0 and 5.4.5?
Comment 25 Tor Lillqvist 2018-01-23 19:25:40 UTC
Awaiting review in gerrit...
Comment 26 Commit Notification 2018-01-23 21:50:12 UTC
Telesto committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=10763c32352af5e9998e430d4069fa26e087ec18&h=libreoffice-5-4

tdf#112153: Set button theme properly

It will be available in 5.4.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 steve -_- 2018-01-24 09:41:04 UTC
verified. important fix, thanks telesto!

Version: 6.1.0.0.alpha0+
Build ID: 6fc9d4a482ab50a1bf8fefb1dae2a6ded3c7e3dd
CPU threads: 4; OS: Mac OS X 10.13.3; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-01-24_04:46:24
Locale: de-DE (de_DE.UTF-8); Calc: group threaded
Comment 28 Jonathan Levi 2018-01-24 14:58:11 UTC
When will one of the "target" versions containing the fix become available? Any chance of a backport to 5.4.4 or 5.3.7 in the meantime?
Comment 29 Tor Lillqvist 2018-01-24 15:19:36 UTC
What would such a "backport" mean? The versions you mentioned have already been released.
Comment 30 Commit Notification 2018-01-24 15:40:05 UTC
Telesto committed a patch related to this issue.
It has been pushed to "libreoffice-6-0-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8fce4b9b76b1d5e3611c1dd05a1bcdcd84fb0474&h=libreoffice-6-0-0

tdf#112153: Set button theme properly

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 31 steve -_- 2018-01-25 09:03:10 UTC
@jonathan: a backport is done already. 6.0 and 5.4.5 will include the fix. You can always see that in the top of a bug in the "whiteboard" target info.
Comment 32 Tor Lillqvist 2018-01-25 09:28:06 UTC
@Jonathan: if you want 5.4.4, 5.3.7, or some other already released version, but with just this patch additionally applied, then you have to build a such yourself, or ask/pay somebody else to do it.