Bug 112207 - Allow assigning macros and styles to UI elements
Summary: Allow assigning macros and styles to UI elements
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Muhammet Kara
URL:
Whiteboard: target:6.0.0 target:6.1.0 target:6.0.0.1
Keywords: bibisected, bisected, regression
: 112303 (view as bug list)
Depends on:
Blocks: Customize-Dialog
  Show dependency treegraph
 
Reported: 2017-09-04 11:07 UTC by Muhammet Kara
Modified: 2017-12-04 11:56 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Mockup of styles/macro integration (56.91 KB, image/png)
2017-10-16 12:00 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Muhammet Kara 2017-09-04 11:07:05 UTC
Currently the new customization dialog does not allow assigning Styles and Macros to the menus and toolbars. They were kept out because of the uncertainty about the way to present them in the new UI.

One suggestion is to present them in separate lists (categories) with names like "LibreOffice Macros | Access2Base | Application". But it might be too long for a name. Maybe we can use only the tale? (Like "Access2Base | Application")

Suggestions/ideas?
Comment 1 Xisco Faulí 2017-09-05 15:18:23 UTC
Assigning it to yourself...
Comment 2 Katarina Behrens (CIB) 2017-09-10 17:27:37 UTC
*** Bug 112303 has been marked as a duplicate of this bug. ***
Comment 3 Yousuf Philips (jay) 2017-09-11 16:35:22 UTC
(In reply to Muhammet Kara from comment #0)
> One suggestion is to present them in separate lists (categories) with names
> like "LibreOffice Macros | Access2Base | Application". But it might be too
> long for a name. Maybe we can use only the tale? (Like "Access2Base |
> Application")

It isnt to long in my view, but it needs to be shrunk, then simply remove "LibreOffice" from the beginning like so "Macros | Access2Base | Application", as we dont append libreoffice infront of "Styles".
Comment 4 Justin L 2017-10-09 15:00:28 UTC
regression from author	Muhammet Kara 2017-09-04 20:39:45 (GMT)
commit	d69f9436b59e249af8dcac88ccadf09b920b1bab
Convert UI of Customize Dialog to the new design
Comment 5 Heiko Tietze 2017-10-16 12:00:29 UTC
Created attachment 137011 [details]
Mockup of styles/macro integration

Since Bubli rightly refused the patch with flattened styles and macros we need another approach. Discussed with Muhammet what can be done in the short term and the idea is to have the commands as designed, and to switch to a different view for styles and macros. Different view means the left list is exchanged internally to another control, i.e. the one we have currently for styles. The 'switching' could done per radio buttons or per dropdown (I prefer radio buttons just for the visual balance). 

To keep the two lists vertically aligned I moved the former category filter below the left list and labeled it 'Filter'. That's a minor tweak, however.
Comment 6 Yousuf Philips (jay) 2017-10-16 19:39:53 UTC
Spoke with Heiko and we agreed that when Styles and Macros is selected in the category drop down list, a tree-view control would appear instead of the listbox. It would look similar to variant 1 in the google doc[1], without the shortcut column.

So for example, when Styles are selected the tree would look like so.

> Character
  - Bullets
  - Caption Characters
  - ...
> Paragraph
  - Addressee
  - Bibliography 1
  - ...
> Pages
> Frame
> Numbering
> Table

[1] https://docs.google.com/document/d/1IPXkYMmyXQzoVUdMpnBeoQdf-LNp5_oNaqfW6OFhxqA/edit#heading=h.hg47wx32ro8y
Comment 7 Heiko Tietze 2017-10-16 19:46:29 UTC
Comment on attachment 137011 [details]
Mockup of styles/macro integration

No need for an extra control to switch between views as styles and macros are items under the current category dropdown. In case of 'All categories' we still show only commands, meaning to access styles and macros the user has to intentionally select this item. To illustrate the difference it would be nice to separate the two filter options from the other.
Comment 8 Thomas Lendo 2017-11-08 22:21:14 UTC
(In reply to Heiko Tietze from comment #7)
> In case of 'All categories'
> we still show only commands, meaning to access styles and macros the user
> has to intentionally select this item. To illustrate the difference it would
> be nice to separate the two filter options from the other.
It's not plausible that styles and macros can be chosen in the category drop-down list like all other entries but their elements can't be chosen when using 'All categories'. That's not consistent. I would suggest to show all style and macro elements in the full list as well. Why not? All should mean all.
Comment 9 Commit Notification 2017-11-22 11:01:51 UTC
Muhammet Kara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3b4d2cfaaf2a6088304d65a608a9034df701537b

tdf#112207: Allow assigning styles to ui elements

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2017-12-04 08:28:46 UTC
Muhammet Kara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3f2915c40fcc42ac91f2019fd506bfbdd1e5933f

tdf#112207: Allow assigning macros to ui elements

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2017-12-04 11:56:33 UTC
Muhammet Kara committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3b12778af71951bfce321c73509e8b0c59b02853&h=libreoffice-6-0

tdf#112207: Allow assigning macros to ui elements

It will be available in 6.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.