Download it now!
Bug 112231 - Slow GUI
Summary: Slow GUI
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.0.0.beta1
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on: 95622
Blocks:
  Show dependency treegraph
 
Reported: 2017-09-05 11:43 UTC by l2683566
Modified: 2017-12-08 17:51 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description l2683566 2017-09-05 11:43:03 UTC
I have CPU i7-3700, Win7 64 sp1. Many last LO version is very slow GUI, other software is not affected (i.e. MS Office). I test x86-64, some x86 version, and 5.4, 5.4.1, 6.0alpha version. [5] [6]

I.e. 
* I call dialog "Help/About LO" is 2 sec, and get 50 % 1 of core.
* Moving in small table (Calc) from A:1 to X:60 is 2 sec.
* Remote desktop connection is to slow for basic working
* Maximize from taskbar (Calc) 2 sec.

Version 6.0alpha is small better, but this is not backway to normal.


[5] https://gerrit.libreoffice.org/gitweb?p=core.git&a=log&h=ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
[6] https://gerrit.libreoffice.org/gitweb?p=core.git&a=log&h=89c25a02ccf9bd5b4392ffd2d469dbcb4ae94bcb
Comment 1 Xisco Faulí 2017-09-05 12:06:07 UTC Comment hidden (obsolete)
Comment 2 Julien Nabet 2017-09-05 12:36:54 UTC
Also, do you have last driver for your graphic card? Indeed, by default LO tries to use OpenGL.
You may also disable OpenGL in options and give it a new try.
(of course after having followed Xisco's advice).
Comment 3 l2683566 2017-09-05 13:44:03 UTC
Thanks for fast reply.

I delete DIR "%APPDATA%\libreoffice\4\user", but bug is same.
I delete DIR "%APPDATA%\libreofficedev\4\user", but bug is same.

I have NVIDIA Quadro FX 380, latest driver WHQL 342.00.

I test some value of option:
Tools/Options: LO/View/Graphics Output
Tools/Options: LO/OpenCL

I test some combination of value, and off hardware support. But off hardware support make LO yet more slowly. Force value of acceleration is without effect.
Comment 4 bugzilla2 2017-09-25 13:24:38 UTC
Well, I can't confirm exactly the issues mentioned by "l2683566", but I can confirm, that LibO gets slower with every new mayor version. I mainly focus on the menus. See Bug 105863. I tested 5.2.7, 5.3.6.1 and 5.4.1.2 this weekend and I see decreasing performance...

5.2.7: Fast and not flickering
5.3.6.1: Flickering and noticeable slower (without OpenGL)
5.4.1.2: Flickering and MUCH SLOWER (without OpenGL)

Not to mention OpenGL, because its SOOOOOOO Slow and distorts the rendering.
Comment 5 l2683566 2017-10-02 08:43:03 UTC
I test now two version (CPU i7-3700, Win7 64 sp1, RAM 16 GB, SSD):
a) LO 5.3.6.1 x64
b) LO 5.4.0.3 x64
c) LO 5.4.1.2 x64
d) LO 5.4.2.2 x64

I move cursor position (key press ctrl+end) from cell A:1 -> Q:465 in table file (ODS and XLSX):
a) < 0,5 second  (and ease test menu response - normal)
b+c+d) 2-4 seconds (and ease test menu response - very slow; 2 second wait (black screen) on maximize from minimized window)


RESUME:
LO 5.3.6.1 OK, normal speed.
Comment 6 Thomas Bertels 2017-10-04 05:52:15 UTC
The slow about dialog is bug 95622.
Comment 7 Timur 2017-10-04 13:36:37 UTC
Please see if this is one of issues solved with Bug 112486 for 5.3.7 and later in 6.0: https://cgit.freedesktop.org/libreoffice/core/commit/?id=01f674a95ddec76dc4c8ecfccdca1773657e47cb.
Already in libo-master~2017-10-03_23.43.39_LibreOfficeDev_6.0.0.0.alpha0_Win_x86.
Comment 8 l2683566 2017-10-05 11:45:55 UTC
I test latest LO6 and confirm same state of bug.
I repeat, LO 5.3.6.1 x64 is not affected of this bug.

libo-master64~2017-10-05_04.22.45_LibreOfficeDev_6.0.0.0.alpha0_Win_x64.msi



(In reply to Timur from comment #7)
> Please see if this is one of issues solved with Bug 112486 for 5.3.7 and
> later in 6.0:
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=01f674a95ddec76dc4c8ecfccdca1773657e47cb.
> Already in
> libo-master~2017-10-03_23.43.39_LibreOfficeDev_6.0.0.0.alpha0_Win_x86.
Comment 9 Telesto 2017-11-04 20:01:37 UTC
@l2683566@mvrht.net
There where some improvements after the initial report. Please test daily (again)
http://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current/
Comment 10 regs 2017-11-10 11:47:35 UTC
Much better. I can scroll though simple documents now. With 5.2.4 it was a disaster. Any action was taking seconds on clocked 2500K and GTX 970.
Comment 11 Timur 2017-11-10 12:18:35 UTC
@ l2683566@mvrht.net please also confirm.
Comment 12 regs 2017-11-10 12:44:58 UTC
(In reply to regs from comment #10)
> Much better. I can scroll though simple documents now. With 5.2.4 it was a
> disaster. Any action was taking seconds on clocked 2500K and GTX 970.

5.4.2*
Comment 13 l2683566 2017-11-14 13:49:02 UTC
Very well! 
I tested LO 6.0 alfa 2017-11-07. I confirmed, that slow GUI bug was solved. I so confirmed GUI speedup opposite to LO 5.3.6.1.

http://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current/libo-master64~2017-11-07_00.30.02_LibreOfficeDev_6.0.0.0.alpha1_Win_x64.msi
Comment 14 l2683566 2017-11-28 16:34:02 UTC
I test BETA1 LO6. Bug "slow GUI" is back. :(

https://dev-builds.libreoffice.org/pre-releases/win/x86_64/LibreOfficeDev_6.0.0.0.alpha1_Win_x64.msi
Comment 15 Telesto 2017-12-07 13:29:22 UTC
(In reply to l2683566 from comment #14)
> I test BETA1 LO6. Bug "slow GUI" is back. :(
> 
> https://dev-builds.libreoffice.org/pre-releases/win/x86_64/LibreOfficeDev_6.
> 0.0.0.alpha1_Win_x64.msi

The given link is to Alpha1 not Beta1.
http://dev-builds.libreoffice.org/pre-
releases/win/x86_64/LibreOfficeDev_6.0.0.0.beta1_Win_x64.msi
 
For a recent 6.0 daily:
http://dev-builds.libreoffice.org/daily/libreoffice-6-0/Win-x86_64@42/current/
Comment 16 Xisco Faulí 2017-12-08 08:08:07 UTC
(In reply to Telesto from comment #15)
> (In reply to l2683566 from comment #14)
> > I test BETA1 LO6. Bug "slow GUI" is back. :(
> > 
> > https://dev-builds.libreoffice.org/pre-releases/win/x86_64/LibreOfficeDev_6.
> > 0.0.0.alpha1_Win_x64.msi
> 
> The given link is to Alpha1 not Beta1.
> http://dev-builds.libreoffice.org/pre-
> releases/win/x86_64/LibreOfficeDev_6.0.0.0.beta1_Win_x64.msi
>  
> For a recent 6.0 daily:
> http://dev-builds.libreoffice.org/daily/libreoffice-6-0/Win-x86_64@42/
> current/

Please, retest with the links provided by Telesto.
Comment 17 l2683566 2017-12-08 17:51:35 UTC
Yes, I used old link. I found it in ref img (this site top):
https://wiki.documentfoundation.org/images/8/8b/BHS_6.0.0_Beta1_large_test.png
there forward to:
https://wiki.documentfoundation.org/QA/BugHuntingSession/6.0.0Beta1#How_to_Test_it
there forward to:
http://dev-builds.libreoffice.org/pre-releases/win/x86/?C=M&O=D
and I select old alfa version.


Now I test LO6 beta 2 under this link:

http://dev-builds.libreoffice.org/daily/libreoffice-6-0/Win-x86_64@42/current/libo-60-64~2017-12-08_11.07.34_LibreOfficeDev_6.0.0.0.beta2_Win_x64.msi

I confirmed, that slow GUI bug was solved in Beta2. I am sorry for my link mistake with alfa.