Bug 95622 - About dialog slow to show up since version 5.0 because of SVG images
Summary: About dialog slow to show up since version 5.0 because of SVG images
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
: 97224 105591 (view as bug list)
Depends on:
Blocks: 112231
  Show dependency treegraph
 
Reported: 2015-11-05 22:28 UTC by Thomas
Modified: 2019-12-06 08:53 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Optimized about dialog SVG file (fully vectorized) (96.34 KB, image/svg+xml)
2019-12-06 08:22 UTC, Thomas Bertels
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas 2015-11-05 22:28:33 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build Identifier: LibreOffice 5.0.3.2

It takes nearly three seconds until the about dialog in any LibreOffice component shows up. This seems slow to me, especially for a computer with a SSD. 

The problem is trivial but I decided to report it anyway. It occurs since version 5.0.

Reproducible: Always

Steps to Reproduce:
1. Start any LibreOffice component, e.g. Writer
2. Click "Help"
3. Click "About LibreOffice"
Actual Results:  
2-3 seconds no response until the dialog is shown

Expected Results:  
Instant showing of the about dialog

Locale: de
OS: Arch Linux
OS is 64bit: yes


Reset User Profile?Yes
Comment 1 tommy27 2015-11-06 11:27:51 UTC
it takes 1.5 seconds under Win7x64 using LibO 5.0.3.1 and recent 5.1.0.0 daily builds
Comment 2 A (Andy) 2015-11-06 19:08:12 UTC
For me reproducible with LO 5.0.3.2, Win 8.1.

It takes around 2 to 2.5 seconds until the About LibreOffice dialog box is opened.
Comment 3 tommy27 2015-11-07 06:05:21 UTC
(In reply to tommy27 from comment #1)
> it takes 1.5 seconds under Win7x64 using LibO 5.0.3.1 and recent 5.1.0.0
> daily builds

it shows up instantly with LibO 4.4.5 so that's a regression and needs bibisecting
Comment 4 Robinson Tryon (qubit) 2015-12-14 05:32:44 UTC Comment hidden (obsolete)
Comment 5 Terrence Enger 2015-12-19 04:07:53 UTC Comment hidden (bibisection)
Comment 6 Thomas 2015-12-19 09:24:18 UTC
Where can I find this commit?

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e229217b7da6f5d9225edffd69287f33299c8684 returns nothing.
Comment 7 Terrence Enger 2015-12-19 13:32:06 UTC
Commit e229217 is the id of a binary in the daily debug util bibisect.
For the source code, look at the source hash.  The range
ba90813..fe88fe6 covers 95 commits.  (I have yet to learn how to limit
`git log` to commits to master.  Sigh.)
Comment 8 raal 2016-01-20 21:23:31 UTC
*** Bug 97224 has been marked as a duplicate of this bug. ***
Comment 9 Jean-Baptiste Faure 2016-04-23 23:48:29 UTC
For me it is not a bug because the current About dialog shows more informations than in previous versions. So it has more data to collect as showed by first "bad" commit.

Closing as NotABug and removing regression keyword. Please, feel free to reopen if you disagree.

Best regards. JBF
Comment 10 Thomas Bertels 2016-09-03 01:32:02 UTC
The culprit is this commit: https://cgit.freedesktop.org/libreoffice/core/commit/?id=8cfdd81b70ef37927b40497ffd10034f28335034

These two complex SVG files:
- flat_logo.svg (794 KB vs nothing)
- about.svg (676 KB vs 15 KB)
are the ones that slow down the About dialog. Removing them fixes the problem.

Either we use simpler SVG files or PNG files (like for the splash screen).

Adding bisected, regression and topicUI keywords.
Comment 11 Xisco Faulí 2016-09-26 15:58:40 UTC
Adding Cc: to Christian Lohmaier
Comment 12 Aron Budea 2016-12-07 22:55:55 UTC
Adding Christian, since he wasn't CC-ed before.

Christian, would it be possible to have PNGs shipped instead of those two big SVG files?
Comment 13 Telesto 2017-02-09 17:52:08 UTC
*** Bug 105591 has been marked as a duplicate of this bug. ***
Comment 14 Thomas Bertels 2017-10-04 06:09:09 UTC
Fixed in 6.0 by this commit: https://cgit.freedesktop.org/libreoffice/core/diff/?id=e1c89b12c94c06309032250da0ac7c84d3f96bb6
Comment 15 Thomas Bertels 2017-10-04 06:12:34 UTC
By the way, the previous logos (causing this bug) were PNG files encapsulated in SVG, thus their size.
Comment 16 Thomas Bertels 2018-07-11 09:45:55 UTC
Reopening because newer SVG logos still create a noticeable delay (albeit smaller than before) when opening the about dialog.
Using PNG images instead (like e.g. Firefox) would fix it.
Comment 17 Xisco Faulí 2018-07-12 15:26:12 UTC
Dear [user-name],
This bug has been in RESOLVED FIXED status for more than 1 months.
If the issue is still reproducible with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/, please report a new issue in https://bugs.documentfoundation.org/enter_bug.cgi providing, if     needed, the steps and documents to reproduce it.
Thanks for your understanding and collaboration.
Closing as RESOLVED FIXED
Comment 18 Thomas Bertels 2019-12-06 08:22:03 UTC
Created attachment 156344 [details]
Optimized about dialog SVG file (fully vectorized)

Here's an optimized version of the SVG file that slows down the about dialog.
Note that the encapsulated PNG file has been replaced by a proper vector version.
Optimized using https://kraken.io/web-interface
Comment 19 Julien Nabet 2019-12-06 08:27:42 UTC
Thomas: as Xisco indicated, please create a new bugtracker.