Bug Hunting Session
Bug 112280 - PPTX with spin animation gets corrupted upon roundtrip
Summary: PPTX with spin animation gets corrupted upon roundtrip
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0
Keywords: filter:pptx
: 106002 (view as bug list)
Depends on:
Blocks: PPTX-Corrupted
  Show dependency treegraph
 
Reported: 2017-09-07 16:26 UTC by Aron Budea
Modified: 2017-09-08 08:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample PPTX (29.60 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2017-09-07 16:26 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-09-07 16:26:22 UTC
Created attachment 136100 [details]
Sample PPTX

The attached presentation contains a shape with spin animation.
Save it as a new PPTX in Impress. The resulting file opens with repair in PowerPoint.

Observed using LO master build (91d909ac8ec53ea135401babe8227f9c41b779b8) / Windows 7.
Comment 1 Jan Holesovsky 2017-09-07 18:07:22 UTC
*** Bug 106002 has been marked as a duplicate of this bug. ***
Comment 2 Commit Notification 2017-09-07 20:09:48 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f5fa86303f25dd271d9bbfa9fc25c1e21430910f

tdf#112280: Export spin animation in PPTX.

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2017-09-07 20:09:54 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d921d4fd24b6416e00069678886f9692ffb4a008

tdf#112280: Unit test.

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Jan Holesovsky 2017-09-08 08:13:13 UTC
Setting as fixed.