Bug Hunting Session
Bug 112393 - SvxEditModulesDlg::LangSelectHdl_Impl(ListBox const*) leaks memory
Summary: SvxEditModulesDlg::LangSelectHdl_Impl(ListBox const*) leaks memory
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-14 16:24 UTC by Telesto
Modified: 2017-10-07 16:57 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
BT & Few screenshots (665.36 KB, application/x-zip-compressed)
2017-09-14 16:24 UTC, Telesto
Details
BT & Few screenshots (2.07 MB, application/x-zip-compressed)
2017-09-29 08:25 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-09-14 16:24:05 UTC
Description:
SvxEditModulesDlg::LangSelectHdl_Impl(ListBox const*) leaks memory

Steps to Reproduce:
1. Start the Instruments
2. Choose Memory Leak profile tool
3. Select LibreOffice.app in instdir as target process
4. Click on the record button, LODev is started by the profiling tool
5. Wait for the StartCenter to load.
6. Go to LibreOffceDev -> Preferences 
7. Open LibreOffceDev ->Writing Aids
8. Writing add -> Edit
9. Close dialog
10. Close preference dialog
11. Stop recording.
12. Analyse the profile trace.

Actual Results:  
SvxEditModulesDlg::LangSelectHdl_Impl(ListBox const*) leaks memory

Expected Results:
Shouldn't leak


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 6.0.0.0.alpha0+
Build ID: e970395c692a5c315914ddf5b43cf01e590345ff
CPU threads: 4; OS: Mac OS X 10.12.4; UI render: default; 
Locale: en-US (en_US.UTF-8); Calc: group



User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Telesto 2017-09-14 16:24:20 UTC
Created attachment 136246 [details]
BT & Few screenshots
Comment 2 Julien Nabet 2017-09-14 21:12:44 UTC
Patch submitted to review here: https://gerrit.libreoffice.org/#/c/42308/
Comment 3 Commit Notification 2017-09-15 03:12:00 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2126e549623b4cbf8c8488e8f20c9a43609b3a44

tdf#112393: avoid leak in LangSelectHdl_Impl (cui)

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Julien Nabet 2017-09-15 05:09:55 UTC
Waiting for your feedback before cherry-picking the patch on 5.4
Comment 5 Telesto 2017-09-16 07:55:04 UTC
No repro with:
Version: 6.0.0.0.alpha0+
Build ID: e038dfdf05096edc0e9c38c9a686b5d23ba39352
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-09-14_23:35:41
Locale: nl-NL (nl_NL.UTF-8); Calc: group

This specific leak is gone; A few new have come up ;-). Can't give any symbols yet (using a daily for now)
* OlaExec_Impl(SfxRequest&)
* SvTreeListbox::Select
* SvLBoxButtonData::SvLBoxButtonData
Comment 6 Julien Nabet 2017-09-16 08:20:13 UTC
Thank you for your feedback!

Since some are a bit reluctant to backport fix for small leaks (see comments from https://gerrit.libreoffice.org/#/c/42324/), let's put this one to FIXED.
Of course, if the leak is not so small, don't hesitate to ask backport on 5.4.
Comment 7 Telesto 2017-09-29 08:25:05 UTC
Created attachment 136607 [details]
BT & Few screenshots

Sorry, Julien, there is still something wrong here. Not sure why I missed it in the first place.
Comment 8 Julien Nabet 2017-09-29 08:51:25 UTC
It seems to leak at another location, I'll give it a try.
Comment 9 Commit Notification 2017-09-30 09:33:36 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d784dc4fd4e7b8b1f7468dd3fe1c952f8ab7037f

Related tdf#112393: avoid leak in SvxEditModulesDlg::CreateEntry

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Julien Nabet 2017-10-07 16:57:44 UTC
Let's put this one to FIXED.