Bug Hunting Session
Bug 112394 - SvLBoxButtonData::InitData causes a leak
Summary: SvLBoxButtonData::InitData causes a leak
Status: RESOLVED DUPLICATE of bug 112392
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-14 16:29 UTC by Telesto
Modified: 2017-09-14 21:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
BT & screenshot (280.77 KB, application/x-zip-compressed)
2017-09-14 16:29 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-09-14 16:29:25 UTC
Description:
SvLBoxButtonData::InitData causes a leak

Steps to Reproduce:
1. Start the Instruments
2. Choose Memory Leak profile tool
3. Select LibreOffice.app in instdir as target process
4. Click on the record button, LODev is started by the profiling tool
5. Wait for the StartCenter to load.
6. Go to LibreOffceDev -> Preferences 
7. Open LibreOffceDev ->Writing Aids
8. Writing add -> Edit
9. Close dialog
10. Close preference dialog
11. Stop recording.
12. Analyse the profile trace.

Actual Results:  
Leak in std::__1::__split_buffer<Image, std::__1::allocator<Image>&>::__split_buffer(unsigned long, unsigned long, std::__1::allocator<Image>&) /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/../include/c++/v1/__split_buffer:169

Expected Results:
Shouldn't leak


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 6.0.0.0.alpha0+
Build ID: e970395c692a5c315914ddf5b43cf01e590345ff
CPU threads: 4; OS: Mac OS X 10.12.4; UI render: default; 
Locale: en-US (en_US.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Telesto 2017-09-14 16:29:50 UTC
Created attachment 136247 [details]
BT & screenshot
Comment 2 Julien Nabet 2017-09-14 21:20:29 UTC
According to the bt, it seems a dup of tdf#112392

Let's put this one to dup. Once the patch for tdf#112392 will be pushed (hope there'll be no pb), you may give it a try with a build including it.
Of course, if it still leaks, don't hesitate to reopen this tracker! :-)

*** This bug has been marked as a duplicate of bug 112392 ***