Bug Hunting Session
Bug 112487 - insert scan doesn't work anymore...
Summary: insert scan doesn't work anymore...
Status: RESOLVED DUPLICATE of bug 114635
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Scanning
  Show dependency treegraph
 
Reported: 2017-09-19 08:25 UTC by Dirk Schwanke
Modified: 2018-01-13 09:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Schwanke 2017-09-19 08:25:28 UTC
I cannot insert a scan since two updates... just no reaction when I click insert scan... you removed that function?
Comment 1 Jacques Guilleron 2017-09-19 11:02:07 UTC
Hi Dirk,

Always there for me in
LO  5.4.1.2 (x64) Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL
Do you see your scan in Select Source...?
Did you opt for a 64 bits LO version?
Comment 2 Dirk Schwanke 2017-09-19 11:50:03 UTC
(In reply to Jacques Guilleron from comment #1)
> Hi Dirk,
> 
> Always there for me in
> LO  5.4.1.2 (x64) Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
> Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
> Locale : fr-FR (fr_FR); Calc: CL
> Do you see your scan in Select Source...?
> Did you opt for a 64 bits LO version?

SORRY MY KNOWLEDGE ABOUT THIS IS MINIMUM...
I only know it worked fine with my WIN 10 32 and 64 until few weeks without any problems. It opened my epson scan system and just inserted the scanned picture. Now when I click insert no single movement. 
I have to scan into picture with epson scan and then I can insert that picture..
Comment 3 Jacques Guilleron 2017-09-19 12:31:00 UTC
Sorry Dirk,

When I want to insert an image from the scanner into Writer, I do:
Insert > Media > Scan
Here, I can select:
Select Source...
Request...
When I select "Select Source...", I get:
Epson Perfection 2480/2580 3.4 (32-32)
WIA-EPSON Perfection 2480/2580..., a Windows program 
Do you see at the same place your Epson scanner?
you have to use the Selection button at the right side.
Else, be sure the scanner is on and use the Selection button at the right side, until you get it.
Does this work for you?
Comment 4 Dirk Schwanke 2017-09-19 12:53:41 UTC
(In reply to Jacques Guilleron from comment #3)
> Sorry Dirk,
> 
> When I want to insert an image from the scanner into Writer, I do:
> Insert > Media > Scan
> Here, I can select:
> Select Source...
> Request...
> When I select "Select Source...", I get:
> Epson Perfection 2480/2580 3.4 (32-32)
> WIA-EPSON Perfection 2480/2580..., a Windows program 
> Do you see at the same place your Epson scanner?
> you have to use the Selection button at the right side.
> Else, be sure the scanner is on and use the Selection button at the right
> side, until you get it.
> Does this work for you?

thanks again... this was working very fine in the way you described and I made it nearly 100 times as I extra use this program as it has this function... but now, clicking that button, NOTHING HAPPENS, I cannot search media nor scan, the whole insert thing for scan is dead...
Comment 5 Regina Henschel 2017-10-01 17:54:39 UTC
Hi Dirk, there was a hint on Ask, that scan might need the 32-bit version of LibreOffice.
https://ask.libreoffice.org/en/question/112769/with-the-last-version-5342-no-possibility-to-select-scanner-and-scan-a-document/?answer=133450#post-id-133450

Do you have installed a 32-bit version of LibreOffice or a 64-bit version?
Comment 6 Regina Henschel 2017-10-01 17:58:54 UTC
See also bug 105762 and its duplicates.
Comment 7 Regina Henschel 2017-10-01 18:01:00 UTC
Bug 104999 might be related too.
Comment 8 Mike Kaganski 2018-01-11 18:41:01 UTC
(In reply to Jacques Guilleron from comment #1)
> Always there for me in
> LO  5.4.1.2 (x64) Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527

Hi Jacques,

I'm working on bug 114635. And I must say that scan should not have been possible from LibreOffice x64 on Windows. Unless you have:

1. 64-bit TWAINDSM.dll installed by some third party sowtware on your system;
2. True 64-bit TWAIN driver (possibly in form of special software that makes 32-to-64-bit translation, like VueScan).

Could you please describe if you have some of those, or maybe something other that I don't know about? That would be interesting to allow other 64-bit users to use their scanners, because scan is currently one of those few areas that have worse support in 64-bit LO than in 32-bit one.
Comment 9 Jacques Guilleron 2018-01-12 00:07:23 UTC
Sorry for the error, Mike,

This is not a 64 bits version. The Build ID is right and come from the 32 bits version of LO 5.4.1.2.
Comment 10 Mike Kaganski 2018-01-13 09:57:06 UTC

*** This bug has been marked as a duplicate of bug 114635 ***