Bug 112536 - soffice --help displays nothing (Windows command line)
Summary: soffice --help displays nothing (Windows command line)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-20 22:07 UTC by Aron Budea
Modified: 2019-01-14 10:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-09-20 22:07:34 UTC
I'm uncertain if I tried it after the fix to bug 111908 (possibly not), but now I get no results when calling "soffice --help" from the command line.
Works from Cygwin shell, but not from Windows command line.

Observed using 6.0 daily build from 2017-09-18.

Mike, are you able to reproduce it?
Comment 1 Mike Kaganski 2017-09-21 04:33:31 UTC
Cannot reproduce with master from tonight; OS is Windows 10 x64. Aron, could you please try debugging it? A codepointer is void displayCmdlineHelp(OUString const & unknown) in desktop/source/app/cmdlinehelp.cxx; supposedly some function in lcl_Console ctor doesn't return success?
Comment 2 Aron Budea 2017-09-21 21:40:49 UTC
Thanks for the code pointer!
What I see in lcl_Console constructor is that this is false:
if (GetStdHandle(STD_OUTPUT_HANDLE) == nullptr)

If I move into the 'if' in the debugger (set next statement), then it does display the help.
However, it's not correct, because 'soffice --help' returns immediately, so it's not holding an active console to print the text to, it just spews the text out while the user already has the console.
Comment 3 Mike Kaganski 2017-09-22 04:21:49 UTC
Aron, could you please check https://gerrit.libreoffice.org/42612?
Comment 4 Aron Budea 2017-09-23 14:47:37 UTC
With the current version of the patch, after this line:
HANDLE hOut = GetStdHandle(STD_OUTPUT_HANDLE);

hOut is 0x00000007, the big 'if' section is skipped and unfortunately nothing is output afterwards with the fprintf call.
Comment 5 Xisco Faulí 2017-12-25 14:43:45 UTC
Dear Mike Kaganski,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 6 Aron Budea 2018-02-20 05:54:35 UTC
I wonder why the return value is ERROR_ARENA_TRASHED.

It's really hard to find info on this, not sure if any of these forum threads make sense:
https://www.experts-exchange.com/questions/10008619/Why-can't-I-write-to-MFC-GUI-console.html
http://www.vbforums.com/showthread.php?730181-Console-Application-ReadConsoleOutputCharacter-or-NET-alternative
Comment 7 Commit Notification 2018-11-21 07:21:06 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/506173a7f42f34821238a63f3f8c7362c9fae9d9%5E%21

tdf#112536 related: make soffice.bin a proper console application on Win

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Luke 2018-12-11 04:14:09 UTC
The fix for this caused Bug 121685. When you have have Settings->Display->Scale=125%, both the UI and content become blurry and hard to read.