Bug Hunting Session
Bug 121685 - UI and document content appear blurry/out of focus on Windows with fractional scaling after upgrade
Summary: UI and document content appear blurry/out of focus on Windows with fractional...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.3.0
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2018-11-23 23:01 UTC by Luke
Modified: 2018-12-16 19:53 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparison of About dialog box (205.12 KB, image/png)
2018-11-23 23:01 UTC, Luke
Details
comparing lo 6.3 and lo 6.1.3.2 win 10 1920x1080, 125% (149.46 KB, image/jpeg)
2018-11-24 13:56 UTC, Oliver Brinzing
Details
Tinderbox vs Self-build (425.54 KB, image/png)
2018-11-25 22:37 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2018-11-23 23:01:03 UTC
Created attachment 146988 [details]
Comparison of About dialog box

In this range https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=0abce68927f45673b73d8f806e108a51a36fb543..e37b7e8a4730fad470b0b5daa0ab2bf905edc3a5

All UI and document content match the system scale factor. The problem is that text is overly blurry. 'e' are especially hard to read. While the icon scale is an improvement, the text should not be hard to read.
Comment 1 Oliver Brinzing 2018-11-24 13:55:49 UTC
confirming with win 10 (1920x1080, 125%), see attached screenshot
comparing lo 6.1.3.2 and lo 6.3
Comment 2 Oliver Brinzing 2018-11-24 13:56:34 UTC
Created attachment 146998 [details]
comparing lo 6.3 and lo 6.1.3.2 win 10 1920x1080, 125%
Comment 3 Luke 2018-11-25 22:37:52 UTC Comment hidden (obsolete)
Comment 4 Luke 2018-12-06 18:18:10 UTC
Ignore my last comment and my regression range in the description. 

I'm having trouble bisecting this regression. Not sure if I'm making mistakes, bug is profile dependent, or something else. I am sure the problem began around 11/21.
Comment 5 Roman Kuznetsov 2018-12-09 09:07:58 UTC Comment hidden (obsolete)
Comment 6 Roman Kuznetsov 2018-12-09 09:09:05 UTC Comment hidden (obsolete)
Comment 7 Miklos Vajna 2018-12-10 09:30:17 UTC Comment hidden (obsolete)
Comment 8 Luke 2018-12-11 04:12:23 UTC
So by doing a 'make clean' between each bisect, I was able to track this regression down to the exact cause

https://cgit.freedesktop.org/libreoffice/core/commit/?id=506173a7f42f34821238a63f3f8c7362c9fae9d9

    tdf#112536 related: make soffice.bin a proper console application on Win

Mike,
Could you please take a look at this?
Comment 9 Mike Kaganski 2018-12-11 05:55:53 UTC
(In reply to Luke from comment #8)

Thanks, Luke!

Yes, your bisection is right. The problem is that solenv/gbuild/platform/com_MSC_class.mk only applies solenv/gbuild/platform/DeclareDPIAware.manifest to applications with TARGETGUI. Will fix that soon.
Comment 10 Mike Kaganski 2018-12-11 06:10:09 UTC
https://gerrit.libreoffice.org/64915

Luke: could you please test if it fixes the problem for you?
Comment 11 Commit Notification 2018-12-11 07:18:16 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/7263d223ddf42cc39d10a501159c7b04ef48df96%5E%21

tdf#121685: also apply DeclareDPIAware manifest to console applications

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Luke 2018-12-11 23:45:03 UTC
Mike thanks for the quick fix on this! 

Verified FIXED in Version: 6.3.0.0.alpha0+
Build ID: fc1568d570a96bfa57013ae62adf3f9606639fd3
Comment 13 Luke 2018-12-16 19:53:49 UTC
The fix for this bug, https://cgit.freedesktop.org/libreoffice/core/commit/?id=7263d223ddf4

Is causing the core Unit Test CppunitTest_chart2_xshape to fail when you set,  Settings->Display->Scale=125%

Setting Scale=100% allows the build to pass with no errors. 

Build log:
https://pastebin.com/SpSiCm6u