Bug 112654 - DOC: Incorrect import of fontwork text
Summary: DOC: Incorrect import of fontwork text
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: DOC-Opening FontWork-WordArt
  Show dependency treegraph
 
Reported: 2017-09-26 03:46 UTC by Hawk
Modified: 2017-09-27 15:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This is how the logo looks when opened in 541 and 542. The text is out of the circle and not inside and rounded. (12.01 KB, image/jpeg)
2017-09-26 03:53 UTC, Hawk
Details
This is how it looks in 536.1 (11.85 KB, image/jpeg)
2017-09-26 06:45 UTC, Hawk
Details
The original document (15.87 KB, image/jpeg)
2017-09-26 17:12 UTC, Hawk
Details
original doc in odt (30.60 KB, application/vnd.oasis.opendocument.text)
2017-09-26 18:08 UTC, Hawk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hawk 2017-09-26 03:46:51 UTC
Description:
When I made my logo in writer in ver 536 it opened fine each time I opened it. It was a round circle with text inside in a circle and a graphic in the center. When I updated first to 541 and opened that logo, the text was in a straight line above the circle. Then I updated to 542 and the same thing happened. I went back to 536.1 and it opened fine.

Steps to Reproduce:
1.After designing my logo on a certificate
2.Then updating Libre to 541 then 542.
3.Then opening my certificate the logo is different.

Actual Results:  
The logo is distorted.

Expected Results:
Should have opened my logo as it  did in 536.1.


Reproducible: Always

User Profile Reset: No, how do you do that?

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36
Comment 1 Hawk 2017-09-26 03:53:08 UTC
Created attachment 136534 [details]
This is how the logo looks when opened in 541 and 542. The text is out of the circle and not inside and rounded.

The text should be inside the circle and in a half arc. Like I said, in version 536 the logo opens  fine.
Comment 2 Dieter 2017-09-26 05:54:22 UTC
Can you add also a picture how it looks in LO 5.3.6.1? I think without more detailed steps to reproduce of without the original document it is hardly possible to confirm your bug.

So I set the status to NEEDINFO. Please change it back to UNCONFIRMED after providing the requested informations.
Comment 3 Hawk 2017-09-26 06:45:21 UTC
Created attachment 136535 [details]
This is how it looks in 536.1
Comment 4 Dieter 2017-09-26 15:56:04 UTC
Now I can see the difference. Thank you. But without the original document or some steps to reproduce it won't be possible to confirm your bug.
Comment 5 Hawk 2017-09-26 17:12:48 UTC
Created attachment 136551 [details]
The original document

Here is the original document , but there are other documents with the same logo and when opened they all had the same error, also the lines I put for signatures on this document were slanted and would not stay straight after I straightened them when I reopened the document.
Comment 6 Dieter 2017-09-26 17:21:35 UTC
With "original document" I thought of an odt-document as attachment. Sorry for this misunderstanding.
Comment 7 Hawk 2017-09-26 18:08:36 UTC
Created attachment 136553 [details]
original doc in odt
Comment 8 Hawk 2017-09-26 18:12:16 UTC
I saved that document in MS DOC format, would that be the problem, shouldn't we be able to save in DOC format and it should be workable in Libre?
Thanks hope you find the problem.
Comment 9 Dieter 2017-09-26 18:39:43 UTC
I can reproduce this bug.

Steps to reproduce:
1. Open attachment from comment 7
2. Save as doc
3. Open in LO 5.2.7.2 => everything is fine (like attachment in comment 3)
4. Open in LO 5.4.2.1 => looks like in attachment from comment 1

=> Set to NEW and added keyword regression


Version: 5.4.2.1 (x64)
Build-ID: dfa67a98bede79c671438308dc9036d50465d2cb
CPU-Threads: 4; Betriebssystem:Windows 6.19; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: group


Version: 5.2.7.2 (x64)
Build ID: 2b7f1e640c46ceb28adf43ee075a6e8b8439ed10
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: de-DE (de_DE); Calc: CL
Comment 10 raal 2017-09-27 13:18:27 UTC
Please, could you test with dev version? I can not reproduce the bug in LO 6. 

http://dev-builds.libreoffice.org/daily/master/
Thank you
Comment 11 Hawk 2017-09-27 14:20:17 UTC
Greetings, thanks for checking on this bug, I am not sure what to check it in when you asked to check it in the dev version. If I may respectfully ask, did you try opening the document in 541 and 542? When I did it was distorted the way shown in what I sent you. It was in MS Doc format and not odt.
Thanks
Comment 12 Dieter 2017-09-27 14:50:56 UTC
(In reply to raal from comment #10)
> Please, could you test with dev version? I can not reproduce the bug in LO
> 6. 
> 
> http://dev-builds.libreoffice.org/daily/master/
> Thank you

You're right. I also couldn't reproduce with LO 6. So it seams to be only a LO 5.4 (and pershaps 5.3) issue. Is it usual to close this bug as WORKSFORME? I don't know

Version: 6.0.0.0.alpha0+ (x64)
Build ID: 465092047d5fa6ec6dd369372e712d76554570ff
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-09-26_23:16:01
Locale: de-DE (de_DE); Calc: group
Comment 13 raal 2017-09-27 15:07:27 UTC
(In reply to Dieter Praas from comment #12)
> (In reply to raal from comment #10)
> > Please, could you test with dev version? I can not reproduce the bug in LO
> > 6. 
> > 
> > http://dev-builds.libreoffice.org/daily/master/
> > Thank you
> 
> You're right. I also couldn't reproduce with LO 6. So it seams to be only a
> LO 5.4 (and pershaps 5.3) issue. Is it usual to close this bug as
> WORKSFORME? I don't know
> 
> Version: 6.0.0.0.alpha0+ (x64)
> Build ID: 465092047d5fa6ec6dd369372e712d76554570ff
> CPU threads: 4; OS: Windows 6.19; UI render: GL; 
> TinderBox: Win-x86_64@42, Branch:master, Time: 2017-09-26_23:16:01
> Locale: de-DE (de_DE); Calc: group

Thanks for checking. Closing as worksforme because bug is fixed in newer version.