Bug Hunting Session
Bug 112814 - Add commands that combine "Paste" and option "Shift cells"
Summary: Add commands that combine "Paste" and option "Shift cells"
Status: RESOLVED DUPLICATE of bug 39936
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: UNO-Command-New Paste
  Show dependency treegraph
 
Reported: 2017-10-02 09:55 UTC by Thomas Lendo
Modified: 2017-10-02 17:31 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of MS Word 2013 "Insert copied cells..." command in context menu (17.67 KB, image/png)
2017-10-02 09:55 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2017-10-02 09:55:44 UTC
Created attachment 136679 [details]
Screenshot of MS Word 2013 "Insert copied cells..." command in context menu

Add commands to Calc that combine
* "Paste" and the paste special option "Shift cells down" (at rows and a single cell) and
* "Paste" and the paste special option "Shift cells right" (at rows, columns and a single cell)
so that you can use it in context menus, menus, toolbars and for keyboard shortcuts.

Standard paste option doesn't shift any cell but in my experience in existing spreadsheets cells often will not be pasted to replace but to add cells/rows/columns and nothing should be overwritten. To make this possible now you have to work with the paste special dialog or with macros which both are not user-friendly solutions.

In MSO Excel this is called "Insert copied cells..." (translation done by me, I only know the German term "Kopierte Zellen einfügen..." for it) and it is the standard option when pasting cells over other cells regardless whether the target cells have content or not.

I find this very useful in MSO Excel--but only additionally to the normal paste command and not replacing it because it's inconvenient to paste and overwrite cells in MSO Excel similar to them that it's inconvenient to paste cells in Calc now if you don't want to overwrite existing cells.


As follow-up bugs I would also suggest to
* add these commands to Calc's context menus when right-clicking on cells, row headers and column headers,
* add such commands to Writer tables.
But that would need additional bug reports after fixing this enhancement request.
Comment 1 Timur 2017-10-02 17:31:46 UTC

*** This bug has been marked as a duplicate of bug 39936 ***