Bug Hunting Session
Bug 112847 - RTL: Arabic label text in various places appearing along with squares
Summary: RTL: Arabic label text in various places appearing along with squares
Status: RESOLVED DUPLICATE of bug 73494
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.6.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: RTL-CTL Font-Rendering
  Show dependency treegraph
 
Reported: 2017-10-02 19:44 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-06 00:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
places the squares are found (224.04 KB, image/png)
2017-10-03 16:17 UTC, Yousuf Philips (jay) (retired)
Details
squares showing in styles combobox on windows (24.05 KB, image/png)
2017-10-04 04:48 UTC, Yousuf Philips (jay) (retired)
Details
squares appearing in hebrew UI (146.41 KB, image/png)
2017-10-04 16:41 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-10-02 19:44:49 UTC
steps:
1. open writer in Arabic UI
2. open the options dialog, the styles toolbar combobox, or about dialog.

regression as this doesnt happen in 5.2.7. isnt a harfbuzz regression as using the old layout engine in 5.3 didnt solve the issue.

Version: 6.0.0.0.alpha0+
Build ID: a2a3e06a29077d4274dc15eea28a01afe22e3658
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Yousuf Philips (jay) (retired) 2017-10-02 19:50:32 UTC
Happens on windows as well in LO 5.4.1.2 but only in the styles toolbar combobox.
Comment 2 Xisco Faulí 2017-10-02 21:45:07 UTC
Could you please attach an screenshot ?
Comment 3 Yousuf Philips (jay) (retired) 2017-10-03 16:17:44 UTC
Created attachment 136738 [details]
places the squares are found
Comment 4 Xisco Faulí 2017-10-03 21:06:28 UTC
I can't reproduce it in

Version: 6.0.0.0.alpha0+
Build ID: fe301bbbfce1d11ab992c4ec2a3cb866629e5c04
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 5 Yousuf Philips (jay) (retired) 2017-10-04 04:36:24 UTC
@Khaled: Can you have a look at this. thanks.
Comment 6 Yousuf Philips (jay) (retired) 2017-10-04 04:48:54 UTC
Created attachment 136747 [details]
squares showing in styles combobox on windows

as previously mentioned, this also happens on windows.

إصدارة: 5.4.1.2
معرّف البناء: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
خيوط المعالج: 4; نظام التَّشغيل: Windows 6.2 (Windows 8.1); مصيّر الواجهة: المبدئيّ; 
المحليّة: en-US (en_US); Calc: group
Comment 7 Khaled Hosny 2017-10-04 11:34:19 UTC
I can reproduce this in the styles menu. My guess is it is a font fallback issue (these styles specify a font that does not support Arabic). What is your UI font in the about dialog case?

This might be a duplicate of bug 73494.
Comment 8 Yousuf Philips (jay) (retired) 2017-10-04 16:31:41 UTC
(In reply to Khaled Hosny from comment #7)
> I can reproduce this in the styles menu. My guess is it is a font fallback
> issue (these styles specify a font that does not support Arabic).

On linux, the font in the styles menu looks like Times New Roman from my tests. No idea what is being used on windows, but i'm on Windows 8.1.

> What is your UI font in the about dialog case?

The system font on Linux Mint 18 Mate is Noto Sans and on Ubuntu Mate 16.04 is Ubuntu, though the UI font looks identical in both systems, so i dont think it is using this font for the LO UI.
Comment 9 Yousuf Philips (jay) (retired) 2017-10-04 16:41:06 UTC
Created attachment 136762 [details]
squares appearing in hebrew UI
Comment 10 Khaled Hosny 2017-10-05 00:31:27 UTC
(In reply to Yousuf Philips (jay) from comment #8)
> (In reply to Khaled Hosny from comment #7)
> > I can reproduce this in the styles menu. My guess is it is a font fallback
> > issue (these styles specify a font that does not support Arabic).
> 
> On linux, the font in the styles menu looks like Times New Roman from my
> tests. No idea what is being used on windows, but i'm on Windows 8.1.
> 
> > What is your UI font in the about dialog case?
> 
> The system font on Linux Mint 18 Mate is Noto Sans and on Ubuntu Mate 16.04
> is Ubuntu, though the UI font looks identical in both systems, so i dont
> think it is using this font for the LO UI.

So all are fonts that lack Arabic support and the strings have mixed direction (e.g. numbers or English text next to the Arabic), which further suggests it is a duplicate.
Comment 11 Yousuf Philips (jay) (retired) 2017-10-05 11:59:29 UTC
(In reply to Khaled Hosny from comment #10)
> So all are fonts that lack Arabic support and the strings have mixed
> direction (e.g. numbers or English text next to the Arabic), which further
> suggests it is a duplicate.

The heading style names are not mixed numbers.
Comment 12 Khaled Hosny 2017-10-05 14:02:45 UTC
(In reply to Yousuf Philips (jay) from comment #11)
> (In reply to Khaled Hosny from comment #10)
> > So all are fonts that lack Arabic support and the strings have mixed
> > direction (e.g. numbers or English text next to the Arabic), which further
> > suggests it is a duplicate.
> 
> The heading style names are not mixed numbers.

Look again, عنوان رئيسي ١ is broken, while عنوان فرعي is OK.
Comment 13 Yousuf Philips (jay) (retired) 2017-10-05 16:06:44 UTC
(In reply to Khaled Hosny from comment #12)
> Look again, عنوان رئيسي ١ is broken, while عنوان فرعي is OK.

Yes you are right, i missed that you said numbers and only saw 'english text'. :D

I checked gtk3 and it doesnt have the problem in the styles menu, but has it in the styles combobox and options dialog.
Comment 14 Khaled Hosny 2017-10-06 00:12:53 UTC

*** This bug has been marked as a duplicate of bug 73494 ***