Download it now!
Bug 113003 - Crashes every time when checking for updates.
Summary: Crashes every time when checking for updates.
Status: RESOLVED DUPLICATE of bug 112414
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: Other Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Updates
  Show dependency treegraph
 
Reported: 2017-10-08 18:26 UTC by Benjamin Levi
Modified: 2017-11-16 09:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Copy of crash report generated by Mac High Sierra (80.78 KB, text/plain)
2017-10-08 18:31 UTC, Benjamin Levi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Levi 2017-10-08 18:26:48 UTC
Description:
Copy of report generated by Mac High Sierra sent as 'Add an Attachment'

Steps to Reproduce:
1.Open Libre Office
2.Click 'Help'
3.Click 'Check for Updates'

Actual Results:  
Program crashes immediately

Expected Results:
Program checks and notifies of any updates available


Reproducible: Always

User Profile Reset: Yes

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13) AppleWebKit/604.1.38 (KHTML, like Gecko) Version/11.0 Safari/604.1.38
Comment 1 Benjamin Levi 2017-10-08 18:31:55 UTC
Created attachment 136855 [details]
Copy of crash report generated by Mac High Sierra
Comment 2 Alex Thurgood 2017-10-09 09:25:19 UTC
No repro:

Version: 5.4.2.2
Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
CPU threads: 4; OS: Mac OS X 10.13; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group
Comment 3 Alex Thurgood 2017-10-09 09:28:45 UTC
@Benjamin : do you have a langpack installed, and if so, which one(s) ?
Comment 4 Alex Thurgood 2017-10-09 09:36:19 UTC
I can reproduce this with the FR langpack installed (but not in a default download without any langpacks).


Confirming.
The main windows closes abruptly (StartCenter, Writer, Calc, etc), leaving a partially drawn Update window and an overlaid white canvas which doesn't receive the focus to update its UI elements.

At a guess, this is a VCL/main thread/subthread redraw issue.

Putting Jan-Marek on CC.

@Jan-Marek : thought you might be interested by this.
Comment 5 Benjamin Levi 2017-10-09 11:01:14 UTC
Hi Alex,
No extensions  or Language Packs installed. It is a clean install.

Regards,
Ben
(In reply to Alex Thurgood from comment #3)
> @Benjamin : do you have a langpack installed, and if so, which one(s) ?
Comment 6 Benjamin Levi 2017-10-09 16:12:00 UTC
(In reply to Alex Thurgood from comment #3)
> @Benjamin : do you have a langpack installed, and if so, which one(s) ?


Just to clarify. The only extensions are the ones that were installed with the program.

1. English spelling dictionary, hyphenation rules and thesaurus, etc.
2. French spelling dictionary, hyphenation rules and thesaurus 6.0.3
3. Solver for Nonlinear Programming 0.9
4. Spanish spelling dictionary, hyphenation rules and thesaurus for Spain and Latin America 2.1

Re Item 1.
I cannot give you the full name/version as the tab covers half of it. If I try to close the extra tab (it won't usually let me) Libre will seize up or crash.

If you want a screen shot, let me know.

Ben
Comment 7 Jan-Marek Glogowski 2017-10-13 13:56:37 UTC
Thread 10 Crashed:
0   libsystem_c.dylib             0x00007fff75c223ea __abort + 177
1   libsystem_c.dylib             0x00007fff75c22339 abort + 142
2   libsystem_c.dylib             0x00007fff75bea380 __assert_rtn + 320
3   com.apple.AppKit              0x00007fff4c13e0da NSViewSetCurrentlyBuildingLayerTreeForDisplay + 255
4   com.apple.AppKit              0x00007fff4c13df4d NSViewBuildLayerTreeForDisplay + 50
5   com.apple.AppKit              0x00007fff4b9c8c45 -[NSWindow displayIfNeeded] + 264
6   libvcllo.dylib                0x000000010bb27c45 -[SalFrameWindow displayIfNeeded] + 117
7   com.apple.AppKit              0x00007fff4c1681fb ___NSWindowGetDisplayCycleObserver_block_invoke.5897 + 308
8   com.apple.AppKit              0x00007fff4b9c878a __37+[NSDisplayCycle currentDisplayCycle]_block_invoke + 695

So this thread hits an assertion inside some macOS code. It looks like GUI stuff in a non-main thread. Might be fixed by the patch for bug 99784. Please test master - I couldn't reproduce the crash.
Comment 8 Benjamin Levi 2017-10-23 09:11:58 UTC
Alex, Jan-Marek,
If it is any help, I had the same problem re checking for updates with the previous release of LibreOffice. But, no problems with earlier versions.
Comment 9 Xisco Faulí 2017-11-15 22:04:55 UTC
(In reply to Benjamin Levi from comment #8)
> Alex, Jan-Marek,
> If it is any help, I had the same problem re checking for updates with the
> previous release of LibreOffice. But, no problems with earlier versions.

Hi benjamin,
Could you please check with a master build from master build libreoffice ?
Comment 10 Benjamin Levi 2017-11-15 22:37:54 UTC
(In reply to Xisco Faulí from comment #9)
> (In reply to Benjamin Levi from comment #8)
> > Alex, Jan-Marek,
> > If it is any help, I had the same problem re checking for updates with the
> > previous release of LibreOffice. But, no problems with earlier versions.
> 
> Hi benjamin,
> Could you please check with a master build from master build libreoffice ?

I am happy to do this, but excuse my ignorance. How and where do I get a master build? 
Ben
Comment 11 Xisco Faulí 2017-11-15 22:40:44 UTC
> I am happy to do this, but excuse my ignorance. How and where do I get a
> master build? 
> Ben

oh sorry, I was on mac and I didn't use the correct key shortcuts from copy&paste. You can download it from http://dev-builds.libreoffice.org/daily/master/
Comment 12 Alex Thurgood 2017-11-16 09:15:33 UTC

*** This bug has been marked as a duplicate of bug 112414 ***