Bug Hunting Session
Bug 112414 - When checking for updates in macOS 10.13, screen hangs, and the program hangs
Summary: When checking for updates in macOS 10.13, screen hangs, and the program hangs
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.6.1 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
: 113003 114433 114624 114716 (view as bug list)
Depends on:
Blocks: MacOS-Performance
  Show dependency treegraph
 
Reported: 2017-09-15 19:33 UTC by impreza233
Modified: 2018-12-11 17:06 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
White Screen and Hanging of Libreoffice (106.63 KB, image/png)
2017-09-15 19:34 UTC, impreza233
Details
Screenshot of hang - white dialog windows (469.22 KB, image/png)
2017-09-29 14:16 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description impreza233 2017-09-15 19:33:48 UTC
Description:
Hang screen if I open the 'Check for Updates' dialog in macOS 10.13

Steps to Reproduce:
1. Open any program of Libreoffice
2. Toolbar, Check for Updates
3. Wait

Actual Results:  
The program hangs in the white screen.

Expected Results:
The software would check for updates correctly.


Reproducible: Sometimes

User Profile Reset: Yes

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13) AppleWebKit/604.1.38 (KHTML, like Gecko) Version/11.0 Safari/604.1.38
Comment 1 impreza233 2017-09-15 19:34:50 UTC
Created attachment 136272 [details]
White Screen and Hanging of Libreoffice

The white screen that I referred before in the bug description.
Comment 2 Alex Thurgood 2017-09-22 09:25:30 UTC
@impreza : just to be clear, are we talking about the :


Help > Check for updates

menu entry ?


You mention toolbar, but I see no button to click on any toolbar for an update, hence my question.

Setting to NEEDINFO
Comment 3 impreza233 2017-09-22 09:57:41 UTC
Yes, that's the menu entry Check for Updates on Help in the toolbar.
Comment 4 impreza233 2017-09-22 10:00:29 UTC
I was wrong about Toolbar. I was referring to this with the macOS top bar of menus.
Comment 5 Alex Thurgood 2017-09-29 14:10:19 UTC
No repro for me with

Version: 5.4.1.2
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU threads: 4; OS: Mac OS X 10.13; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group
Comment 6 Alex Thurgood 2017-09-29 14:10:54 UTC
The update check completes successfully and states that currently there are no updates.
Comment 7 Alex Thurgood 2017-09-29 14:15:28 UTC
However, I can completely reproduce this :

Version: 5.3.6.1
Build ID: 686f202eff87ef707079aeb7f485847613344eb7
Threads CPU : 4; Version de l'OS :Mac OS X 10.13; UI Render : par défaut; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group

Confirming, changing version to earliest reproduced
Comment 8 Alex Thurgood 2017-09-29 14:16:44 UTC
Created attachment 136623 [details]
Screenshot of hang - white dialog windows
Comment 9 Alex Thurgood 2017-09-29 14:17:21 UTC
Any idea what might be happening here ?
Comment 10 Xisco Faulí 2017-11-15 22:06:24 UTC
Alex,
is it the same as bug 113003 ?
Is it reproducible in a master build?
Comment 11 Alex Thurgood 2017-11-16 09:14:05 UTC
(In reply to Xisco Faulí from comment #10)
> Alex,
> is it the same as bug 113003 ?
> Is it reproducible in a master build?

Good point Xisco, thanks for pointing that out, yes, it probably is the same thing.

Can't test right now with master, but will give it a try when back in office
Comment 12 Alex Thurgood 2017-11-16 09:15:33 UTC
*** Bug 113003 has been marked as a duplicate of this bug. ***
Comment 13 Alex Thurgood 2017-12-13 08:27:29 UTC
*** Bug 114433 has been marked as a duplicate of this bug. ***
Comment 14 Xisco Faulí 2017-12-21 17:07:43 UTC
*** Bug 114624 has been marked as a duplicate of this bug. ***
Comment 15 Xisco Faulí 2017-12-27 23:27:07 UTC
*** Bug 114716 has been marked as a duplicate of this bug. ***
Comment 16 Xisco Faulí 2018-01-02 15:04:21 UTC
I can't reproduce it in

Version: 6.1.0.0.alpha0+
Build ID: 1e83e713b3e2ef5bb0aa123910598b37a2a97ffe
CPU threads: 8; OS: Mac OS X 10.13.2; UI render: GL; 
Locale: en-US (en_ES.UTF-8); Calc: group threaded

Alex, is it reproducible in branch 5.3 but not in 5.4 ?
Comment 17 clemens.brunner 2018-01-16 09:12:47 UTC
I can reproduce this with the latest 6.0.0RC2 build:

Version: 6.0.0.2
Build ID: 06b618bb6f431d27fd2def25aa19c833e29b61cd
CPU threads: 8; OS: Mac OS X 10.13.2; UI render: GL; 
Locale: en-US (en_US.UTF-8); Calc: group

I get a white dialog window, which freezes the whole application. In previous versions, the whole program crashed immediately.
Comment 18 Alex Thurgood 2018-01-16 13:51:50 UTC
(In reply to Xisco Faulí from comment #16)


> Alex, is it reproducible in branch 5.3 but not in 5.4 ?

Hi Xisco,

No repro with : 

Version: 5.3.7.2
Build ID: 6b8ed514a9f8b44d37a1b96673cbbdd077e24059
Threads CPU : 8; Version de l'OS :Mac OS X 10.13.2; UI Render : par défaut; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 19 Jan-Marek Glogowski 2018-12-11 17:06:22 UTC
My guess is this bug was fixed together with bug 99784 and later patches for 6.0.x. It doesn't crash or hang for me with current master (6.3 to be).

There seem to be no reproducers after the 6.0 release, except for Clemens, so if you're still able to reproduce it with a current 6.1, please reopen it.