Download it now!
Bug 114716 - LibreOffice Extension manager locks up, LO consumes all available memory when pressing "Check for updates"
Summary: LibreOffice Extension manager locks up, LO consumes all available memory when...
Status: RESOLVED DUPLICATE of bug 112414
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: x86 (IA32) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-27 16:48 UTC by nospam
Modified: 2017-12-27 23:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nospam 2017-12-27 16:48:05 UTC
Description:
When summoning "Extension Manager" and pressing "Auf Updates prüfen" ("Check for Updates"), Extension Manager no longer reacts to User Interactions like clicking on "Schließen" ("Close") in it's dialog.

Also, I see that LO's memory consumption then keeps growing until eventually it takes all the available memory, bringing down the Computer as a result.

The only way I have found to stop this is force-quitting LO from OS X's Activity monitor.

The same problem occurs when I double-click an OXT file in the Finder (I tested this with LanguageTool-3.9.oxt) -> LO opens in the Extension Manager, displays "Füge LanguageTool-3.9.oxt hinzu" ("Add LanguageTool-3.9.oxt"), then the Extension Manager locks up & consumes memory as described above).

Steps to Reproduce:
1. Open LO
2. Create new Text document
3. Open Extension Manager
4. Click "Check for Updates"


Actual Results:  
Extension Manager locks up, LO memory footprint keeps growing until OS X is out of memory

Expected Results:
Extension manager should show new/updates extensions.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
I have experienced this issue also on previous 5.4.x versions of LO.

Version: 5.4.4.2
Build-ID: 2524958677847fb3bb44820e40380acbe820f960
CPU-Threads: 8; BS: Mac OS X 10.11.6; UI-Render: Standard; 
Gebietsschema: de-AT (de_AT.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Xisco Faulí 2017-12-27 23:27:07 UTC

*** This bug has been marked as a duplicate of bug 112414 ***