Bug 113045 - Windows 10 Application Layout broken
Summary: Windows 10 Application Layout broken
Status: RESOLVED DUPLICATE of bug 107764
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Impress-OpenGL
  Show dependency treegraph
 
Reported: 2017-10-11 08:28 UTC by documentfoundation
Modified: 2017-10-12 04:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
LibreOffice UI broken (72.49 KB, image/jpeg)
2017-10-11 08:30 UTC, documentfoundation
Details

Note You need to log in before you can comment on or make changes to this bug.
Description documentfoundation 2017-10-11 08:28:29 UTC
Description:
I have tested version 5.3.6 and 5.4.2.
In both cases, the layout of the application is so broken that you can't use it.
Areas are cut off on all four sides.
A menu bar is not visible, nor can it be displayed.
I have also tried to improve the scaling with all available Windows settings. Unfortunately without success.
I'll attach a screenshot.

Steps to Reproduce:
Start the Application (Writer or Calc or ...)

Actual Results:  
looks bad and is not usable

Expected Results:
looks normal and is usable


Reproducible: Always

User Profile Reset: Yes

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 documentfoundation 2017-10-11 08:30:11 UTC
Created attachment 136904 [details]
LibreOffice UI broken
Comment 2 documentfoundation 2017-10-11 08:31:34 UTC
The screenshot is a full window capture, the missing parts are not because of the screenshot.
Comment 3 documentfoundation 2017-10-11 08:37:14 UTC
Oh... setting compatibility mode to Windows 7 solved this problem... But it should work with Windows 10 too...
Comment 4 m.a.riosv 2017-10-11 10:29:04 UTC
Please test modifying OpenGL option in Menu/Tools/Options/LibreOffice/View.
Comment 5 documentfoundation 2017-10-11 13:44:55 UTC
(In reply to m.a.riosv from comment #4)
> Please test modifying OpenGL option in Menu/Tools/Options/LibreOffice/View.

After switching to Windows 7 compatibility mode I was able to reach the menu.
I deactivated OpenGL. I then deactivated Compatibility mode.
Since then the UI works fine with Windows 10.
So active OpenGL with Windows 10 is the problem...
Comment 6 m.a.riosv 2017-10-11 16:22:41 UTC
Please can you copy here the content of the 'opengl_device.log' file that it's in the user profile.
Comment 7 documentfoundation 2017-10-11 16:34:30 UTC
(In reply to m.a.riosv from comment #6)
> Please can you copy here the content of the 'opengl_device.log' file that
> it's in the user profile.

DriverVersion: 21.20.16.4664
DriverDate: 4-21-2017
DeviceID: PCI\VEN_8086&DEV_591B&SUBSYS_07BE1028&REV_04
AdapterVendorID: 0x8086
AdapterDeviceID: 0x591b
AdapterSubsysID: 0x07be1028
DeviceKey: System\CurrentControlSet\Control\Video\{7BC3F254-D2A6-436D-A2E3-27591FD4AEB4}\0000
DeviceString: Intel(R) HD Graphics 630
Comment 8 m.a.riosv 2017-10-11 17:02:05 UTC
Thanks.
Comment 9 V Stuart Foote 2017-10-12 04:23:47 UTC
Pretty clearly a duplicate...

*** This bug has been marked as a duplicate of bug 107764 ***