Bug Hunting Session
Bug 113135 - Hebrew diacritics appear as separate letters when using Microsoft fonts
Summary: Hebrew diacritics appear as separate letters when using Microsoft fonts
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.6.1 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-Hebrew
  Show dependency treegraph
 
Reported: 2017-10-15 12:08 UTC by eladhen2
Modified: 2017-10-19 20:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Hebrew words with diacritics, using Arial font, on Libreoffice 5.1 (97.75 KB, image/jpeg)
2017-10-15 12:12 UTC, eladhen2
Details
Hebrew words with diacritics, using Arial font, on Libreoffice 5.3 (119.42 KB, image/jpeg)
2017-10-15 12:14 UTC, eladhen2
Details
An example document (13.19 KB, application/vnd.oasis.opendocument.text)
2017-10-15 13:31 UTC, eladhen2
Details
screenshot of testcast on 5.4.2 (64.64 KB, image/png)
2017-10-15 13:35 UTC, Amiad
Details
A screenshot from 5.4.1.2 on Linux Mint (24.45 KB, image/png)
2017-10-15 15:11 UTC, eladhen2
Details
screenshot with Arial and Courier (210.81 KB, image/png)
2017-10-15 15:37 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description eladhen2 2017-10-15 12:08:43 UTC
Description:
On Libreoffice 5.3 or 5.4, when writing with Microsoft fonts in Hebrew (from the ttf-mscorefonts-installer package. In particular Arial, Courier New, probably others) many of the Niqud signs (Hebrew diacritics) don't appear in the correct place under the letters, but as if they are separate letters. 

This is a regression. This behavior isn't present in Libreoffice 5.1, where the Niqud signs appear in the right places.

Steps to Reproduce:
1. Install mscorefonts

2. Switch to writing with Arial font

3. Write in Hebrew and use diacritics.

Actual Results:  
Several of the Diacritics, Qamatz (ָ), Patakh (ַ), Shewa (ְ) and others, appear as separate letters instead of under the preceding letter.

Expected Results:
The Diacritics should have appeared under the letters.


Reproducible: Always

User Profile Reset: No, but I tried it on several computers.

Additional Info:
This is an obvious regression. This bug isn't present in 5.1 and earlier versions.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 eladhen2 2017-10-15 12:12:22 UTC
Created attachment 136985 [details]
Hebrew words with diacritics, using Arial font, on Libreoffice 5.1

Hebrew words with diacritics, using Arial font, on Libreoffice 5.1. This is How the diacritics should look.
Comment 2 eladhen2 2017-10-15 12:14:06 UTC
Created attachment 136986 [details]
Hebrew words with diacritics, using Arial font, on Libreoffice 5.3

Hebrew words with diacritics, using Arial font, on Libreoffice 5.3. The diacritics are not positioned correctly.
Comment 3 eladhen2 2017-10-15 13:31:07 UTC
Created attachment 136989 [details]
An example document
Comment 4 Amiad 2017-10-15 13:35:09 UTC
Created attachment 136990 [details]
screenshot of testcast on 5.4.2

The diacritics appear correctly on 5.4.2 (Arch Linux).
Comment 5 eladhen2 2017-10-15 15:11:06 UTC
Created attachment 136992 [details]
A screenshot from 5.4.1.2 on Linux Mint

On linux Mint this is a screenshot from a fresh installation of 5.4.1.2 from the "fresh" PPA.
Comment 6 Yousuf Philips (jay) (retired) 2017-10-15 15:37:52 UTC
Created attachment 136994 [details]
screenshot with Arial and Courier

Looks fine for me on Linux Mint 18 Mate using master with Arial and Courier.

Version: 6.0.0.0.alpha0+
Build ID: 8eacd3be08bf6e1a97900624611822de9b00a379
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group

eladhen2: please copy and paste the full details from the Help > About dialog, similar to the above. Also it would be good to zoom into the text when you send in screenshots, as well as turn of Tools > Automatic Spell Checking, so the red lines dont obscure the image.
Comment 7 Yousuf Philips (jay) (retired) 2017-10-15 15:51:57 UTC
Tested 5.3 and 5.4 and still aint repo.

Version: 5.3.7.1
Build ID: 376eaac300a303c4ad2193fb7f6a7522caf550b9
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: group

Version: 5.4.1.2
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 8 Eyal Rozenberg 2017-10-15 20:55:32 UTC
Reporter, please have a look at bug 113134 (yes, same bug ID minus 1); I'm starting to think this one is a dupe of that one, in the bottom line.
Comment 9 eladhen2 2017-10-18 11:50:44 UTC
The "Fresh" PPA just upgraded to Libreoffice 5.4.2.2, and the bug is still present.
Comment 10 eladhen2 2017-10-18 11:58:27 UTC
(In reply to Eyal Rozenberg from comment #8)
> Reporter, please have a look at bug 113134 (yes, same bug ID minus 1); I'm
> starting to think this one is a dupe of that one, in the bottom line.

This does not seem to be the same bug... David CLM actually does not display the problem I'm reporting.
Comment 11 eladhen2 2017-10-18 12:00:26 UTC
(In reply to Yousuf Philips (jay) from comment #6)
> Created attachment 136994 [details]
> screenshot with Arial and Courier
> 
> Looks fine for me on Linux Mint 18 Mate using master with Arial and Courier.
> 
> Version: 6.0.0.0.alpha0+
> Build ID: 8eacd3be08bf6e1a97900624611822de9b00a379
> CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
> Locale: en-US (en_US.UTF-8); Calc: group
> 
> eladhen2: please copy and paste the full details from the Help > About
> dialog, similar to the above. Also it would be good to zoom into the text
> when you send in screenshots, as well as turn of Tools > Automatic Spell
> Checking, so the red lines dont obscure the image.

Version: 5.4.2.2
Build ID: 1:5.4.2~rc2-0ubuntu0.16.04.1~lo1
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk2; 
Locale: he-IL (en_GB.UTF-8); Calc: group
Comment 12 Shai Berger 2017-10-18 16:27:44 UTC
(In reply to eladhen2 from comment #10)
> (In reply to Eyal Rozenberg from comment #8)
> > Reporter, please have a look at bug 113134 (yes, same bug ID minus 1); I'm
> > starting to think this one is a dupe of that one, in the bottom line.
> 
> This does not seem to be the same bug... David CLM actually does not display
> the problem I'm reporting.

I concur -- I see bug 113134, but I don't see this one (LO from Debian Testing, under KDE)

Version: 5.4.1.2.0+
Build ID: 1:5.4.1-1
CPU threads: 4; OS: Linux 4.12; UI render: default; VCL: gtk3; 
Locale: en-US (en_IL.UTF-8); Calc: group
Comment 13 eladhen2 2017-10-18 21:09:28 UTC
Running Libreoffice 5.4.1 (from debian backports) on Debian Stretch KDE in a virtual machine I don't get this bug, so it might be specific to the PPA...

Version: 5.4.1.2.0+
Build ID: 1:5.4.1-1~bpo9+1
CPU threads: 1; OS: Linux 4.9; UI render: default; VCL: x11; 
Locale: en-GB (en_GB.UTF-8); Calc: group
Comment 14 eladhen2 2017-10-18 21:44:08 UTC
Just to confirm that the problem is in the PPA and not specific to Linux Mint, I tried it on Ubuntu 16.04 with the PPA, and the bug exists there. So it seems the problem IS in the PPA...

Version: 5.4.2.2
Build ID: 1:5.4.2~rc2-0ubuntu0.16.04.1~lo1
CPU threads: 1; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: he-IL (he_IL.UTF-8); Calc: group